aboutsummaryrefslogtreecommitdiff
path: root/net/bb
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1998-05-18 21:52:07 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1998-05-18 21:52:07 +0000
commit23ba558a82ea2b7a4edcb1394024cb3107f081d3 (patch)
treeff9f4a776f23e49ee7b046a9c1300530bdd002e1 /net/bb
parenta1c4e91a0e437d9e0ccc70f85d402a2634307c32 (diff)
downloadports-23ba558a82ea2b7a4edcb1394024cb3107f081d3.tar.gz
ports-23ba558a82ea2b7a4edcb1394024cb3107f081d3.zip
Notes
Diffstat (limited to 'net/bb')
-rw-r--r--net/bb/Makefile20
-rw-r--r--net/bb/distinfo2
-rw-r--r--net/bb/files/patch-aa4
-rw-r--r--net/bb/files/patch-ac11
-rw-r--r--net/bb/files/patch-ad30
-rw-r--r--net/bb/pkg-plist7
-rw-r--r--net/bb/scripts/configure15
7 files changed, 71 insertions, 18 deletions
diff --git a/net/bb/Makefile b/net/bb/Makefile
index 8f46be7f22ce..72cfe18c95cc 100644
--- a/net/bb/Makefile
+++ b/net/bb/Makefile
@@ -3,23 +3,29 @@
# Date created: So 17 Nov 1996 16:59:23 MET
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.21 1998/01/31 11:44:35 andreas Exp $
+# $Id: Makefile,v 1.22 1998/01/31 11:58:55 andreas Exp $
#
-DISTNAME= bb-1.06a
+DISTNAME= bb-1.06c
CATEGORIES= net
MASTER_SITES= http://freefall.freebsd.org/~andreas/download/
MAINTAINER= andreas@FreeBSD.ORG
-BUILD_DEPENDS= ${PREFIX}/sbin/httpd:${PORTSDIR}/www/apache
-
# The FreeBSD Ports Team has permission to include this in our CDROM
# from the author, but others who wish to do likewise will have to
# contact Sean MacGuire <sean@iti.qc.ca>.
WRKSRC= ${WRKDIR}/bb
+pre-configure:
+ @echo "==================================================="
+ @echo "You need to install a WWW Server to use this port"
+ @echo "For example: - apache or "
+ @echo " - apache-ssl
+ @echo "port."
+ @echo "==================================================="
+
post-configure:
( cd ${WRKSRC}/doc; ${SH} bbconfig freebsd )
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@@ -80,6 +86,11 @@ do-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/www/logs/later \
${PREFIX}/bb/www/logs/later
+.for file in README footer iti-s01 iti-s01.html iti-s01.iti.qc.ca \
+ iti-s01.iti.qc.ca.html router-000.htm
+ ${INSTALL_DATA} ${WRKSRC}/www/notes/$(file) \
+ ${PREFIX}/bb/www/notes
+.endfor
@${RM} -f ${PREFIX}/www/data/bb
@ln -sf ${PREFIX}/bb/www ${PREFIX}/www/data/bb
@ln -sf bb.html ${PREFIX}/bb/www/index.html
@@ -107,6 +118,5 @@ do-install:
@echo "Look here for a life sample:"
@echo " http://www.menet.umn.edu/~clolson/bb/bb.html"
@echo ""
- @echo "Have fun doing it remotely - Andreas ///"
.include <bsd.port.mk>
diff --git a/net/bb/distinfo b/net/bb/distinfo
index 5672370474c4..06031af9bdbf 100644
--- a/net/bb/distinfo
+++ b/net/bb/distinfo
@@ -1 +1 @@
-MD5 (bb-1.06a.tar.gz) = 72d938804b636eb35c1ff96486339cbf
+MD5 (bb-1.06c.tar.gz) = bf3fb34b31389af77886c8321e5a7d18
diff --git a/net/bb/files/patch-aa b/net/bb/files/patch-aa
index c1086ff382b1..2742d7bdb5a1 100644
--- a/net/bb/files/patch-aa
+++ b/net/bb/files/patch-aa
@@ -1,5 +1,5 @@
---- src/Makefile.freebsd.orig Mon Dec 16 16:08:16 1996
-+++ src/Makefile.freebsd Sun Dec 22 13:38:43 1996
+--- src/Makefile.freebsd.orig Mon May 18 23:18:48 1998
++++ src/Makefile.freebsd Mon May 18 23:19:26 1998
@@ -1,6 +1,6 @@
SHELL = /bin/sh
-MAKE = make
diff --git a/net/bb/files/patch-ac b/net/bb/files/patch-ac
new file mode 100644
index 000000000000..b4c69249edc8
--- /dev/null
+++ b/net/bb/files/patch-ac
@@ -0,0 +1,11 @@
+--- runbb.sh.orig Mon May 18 23:22:46 1998
++++ runbb.sh Mon May 18 23:23:15 1998
+@@ -16,7 +16,7 @@
+ #
+ # BBHOME IS THE ROOT DIRECTORY OF BIG BROTHER!!!
+ # YOU MUST SET THE NEXT LINE TO WHERE BB LIVES
+-BBHOME=""
++BBHOME="!!PREFIX!!/bb"
+
+ export BBHOME
+
diff --git a/net/bb/files/patch-ad b/net/bb/files/patch-ad
new file mode 100644
index 000000000000..860114aebe58
--- /dev/null
+++ b/net/bb/files/patch-ad
@@ -0,0 +1,30 @@
+--- etc/bb-hosts.orig Mon May 18 23:25:35 1998
++++ etc/bb-hosts Mon May 18 23:28:20 1998
+@@ -1,14 +1,16 @@
+ #
+ # THE BIG BROTHER HOSTS FILE
+ #
+-192.168.116.1 iti-s01.iti.qc.com # BBPAGER BBNET BBDISPLAY ftp smtp pop3 http://iti-s01/
+-192.168.117.1 ns.iti.qc.com # ftp smtp dns
+-group <H3><I>Web Servers</I></H3>
+-192.168.117.2 ns2.iti.qc.com # ftp smtp
+-192.168.117.3 ns3.iti.qc.com # ftp smtp
+-192.168.117.4 ns4.iti.qc.com # ftp smtp
+-group <H3><I>Modem Banks</I></H3>
+-dialup modem-bank1 192.168.117.1 16
+-dialup modem-bank2 192.168.117.17 16
+-dialup modem-bank3 192.168.117.33 16
+-summary canada.bc 192.168.116.1 http://www.iti.qc.com/iti/users/sean/bb/
++172.16.1.1 !!HOSTNAME!! # BBPAGER BBNET BBDISPLAY ftp smtp pop3 http://!!HOSTNAME!!/
++#
++#192.168.116.1 iti-s01.iti.qc.com # BBPAGER BBNET BBDISPLAY ftp smtp pop3 http://iti-s01/
++#192.168.117.1 ns.iti.qc.com # ftp smtp dns
++#group <H3><I>Web Servers</I></H3>
++#192.168.117.2 ns2.iti.qc.com # ftp smtp
++#192.168.117.3 ns3.iti.qc.com # ftp smtp
++#192.168.117.4 ns4.iti.qc.com # ftp smtp
++#group <H3><I>Modem Banks</I></H3>
++#dialup modem-bank1 192.168.117.1 16
++#dialup modem-bank2 192.168.117.17 16
++#dialup modem-bank3 192.168.117.33 16
++#summary canada.bc 192.168.116.1 http://www.iti.qc.com/iti/users/sean/bb/
diff --git a/net/bb/pkg-plist b/net/bb/pkg-plist
index 7b722e88bd89..a29aa72ed910 100644
--- a/net/bb/pkg-plist
+++ b/net/bb/pkg-plist
@@ -64,6 +64,13 @@ bb/www/gifs/red.gif
bb/www/gifs/yellow.gif
bb/www/index.html
bb/www/logs/later
+bb/www/notes/README
+bb/www/notes/footer
+bb/www/notes/iti-s01
+bb/www/notes/iti-s01.html
+bb/www/notes/iti-s01.iti.qc.ca
+bb/www/notes/iti-s01.iti.qc.ca.html
+bb/www/notes/router-000.htm
share/doc/bb/FAQ
share/doc/bb/README
share/doc/bb/README.SMS
diff --git a/net/bb/scripts/configure b/net/bb/scripts/configure
index 83244f6de27f..2ec829e1a972 100644
--- a/net/bb/scripts/configure
+++ b/net/bb/scripts/configure
@@ -1,17 +1,12 @@
#!/bin/sh
-# $Id$
+# $Id: configure,v 1.3 1997/10/13 20:19:25 andreas Exp $
cd $WRKSRC || exit 1
-mv runbb.sh runbb.sh.orig
-sed -e "s:/home/sean/bb:$PREFIX/bb:g" \
- < runbb.sh.orig \
- > runbb.sh
-
HOSTNAME=`hostname`
-mv $WRKSRC/etc/bb-hosts $WRKSRC/etc/bb-hosts.orig
-sed -e "s:@@IP@@:172.16.1.1:" -e "s:@@HOST@@:$HOSTNAME:g" \
- < $FILESDIR/bb-hosts \
- > $WRKSRC/etc/bb-hosts
+perl -pi -e "s=!!PREFIX!!=$PREFIX=" ${WRKSRC}/www/bb-pager.sh
+perl -pi -e "s=!!HOSTNAME!!=$HOSTNAME=" ${WRKSRC}/www/bb-pager.sh
+perl -pi -e "s=!!PREFIX!!=$PREFIX=" ${WRKSRC}/runbb.sh
+perl -pi -e "s=!!HOSTNAME!!=$HOSTNAME=g" ${WRKSRC}/etc/bb-hosts