aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-04-11 04:11:41 +0000
committerSteve Wills <swills@FreeBSD.org>2011-04-11 04:11:41 +0000
commit2100930b65246279ec22d6fb2468586703047d73 (patch)
treed006875d9bac8d4806d6730638130f1eae52ab83 /net/beacon
parentd506cda3ccf2b8e32e1d74c3c5c046b0582c8b42 (diff)
downloadports-2100930b65246279ec22d6fb2468586703047d73.tar.gz
ports-2100930b65246279ec22d6fb2468586703047d73.zip
Notes
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile20
-rw-r--r--net/beacon/distinfo4
-rw-r--r--net/beacon/files/beacon.in48
-rw-r--r--net/beacon/files/extra-patch-src_beacon.in95
-rw-r--r--net/beacon/files/patch-Makefile.in11
-rw-r--r--net/beacon/files/patch-common-beacon.patch18
-rw-r--r--net/beacon/files/patch-libbeacon-Makefile.in11
-rw-r--r--net/beacon/files/patch-src_Makefile.in13
-rw-r--r--net/beacon/pkg-descr2
-rw-r--r--net/beacon/pkg-plist1
10 files changed, 10 insertions, 213 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index c3285585a4b3..b690085f3f74 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= beacon
-PORTVERSION= 1.3
-PORTREVISION= 4
+PORTVERSION= 1.4
CATEGORIES= net perl5 mbone ipv6
-MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/releases/
+MASTER_SITES= SF/multicastbeacon/multicastbeacon/beacon%20v${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Beacon active measurement tool to monitor multicast
@@ -21,25 +20,18 @@ WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
USE_PERL5= yes
USE_AUTOTOOLS= autoconf
-USE_RC_SUBR= beacon
-.ifdef(WITHOUT_IPV6)
-CONFIGURE_ARGS=
-.else
-#enable IPv6 name lookup, and sending IPv6 multicast
+OPTIONS= IPV6 "Enable IPv6 PTR lookups" off
+
+.ifdef(WITH_IPV6)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_beacon.in
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.include <bsd.port.pre.mk>
-
post-install:
- @${ECHO} "Sample config installed at ${PREFIX}/etc/beacon.conf.sample"
- @${ECHO} "Copy the customised version to ${PREFIX}/etc/beacon.conf"
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/beacon/distinfo b/net/beacon/distinfo
index 45e65b2814de..00abd8a58b82 100644
--- a/net/beacon/distinfo
+++ b/net/beacon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (beacon-1.3.tar.gz) = ce036fb927045c6270cf3fa504b5988856ed4cd975aefd3f23a8e6c076ba32b6
-SIZE (beacon-1.3.tar.gz) = 411823
+SHA256 (beacon-1.4.tar.gz) = 0143199f2405a3c93e9f0b5d7ebf61b4877ac664f5209d180b1dbd72ce43f673
+SIZE (beacon-1.4.tar.gz) = 464268
diff --git a/net/beacon/files/beacon.in b/net/beacon/files/beacon.in
deleted file mode 100644
index 86fdb8d57b07..000000000000
--- a/net/beacon/files/beacon.in
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: beacon
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf to enable beacon.
-#
-# beacon_enable="YES"
-#
-# Optional settings:
-#
-# beacon_program (default: %%PREFIX%%/bin/beacon)
-# beacon_config (default: %%PREFIX%%/etc/beacon.conf)
-# beacon_user (default: daemon)
-# beacon_outputdir (default: %%PREFIX%%/www/data-dist/beacon)
-#
-
-. /etc/rc.subr
-
-name="beacon"
-rcvar=`set_rcvar`
-
-load_rc_config $name
-command=${beacon_program:-%%PREFIX%%/bin/${name}}
-config=${beacon_config:-%%PREFIX%%/etc/${name}.conf}
-buser=${beacon_user:-nobody}
-outputdir="${beacon_outputdir:-%%PREFIX%%/www/data-dist/beacon}"
-if [ -f ${config} ]; then
- toutputdir="`awk '$1 == "OUTPUTDIR" {print $3}' ${config}`"
- if [ -d "${toutputdir}" ]; then
- outputdir="${toutputdir}"
- fi
-fi
-pidfile="${beacon_pidfile:-${outputdir}/multicastbeacon.PID}"
-command_interpreter="%%PREFIX%%/bin/perl"
-
-start_cmd="beacon_start"
-
-beacon_start()
-{
- echo "Starting ${name}."
- daemon -u ${buser} -f ${command}
-}
-
-run_rc_command "$1"
diff --git a/net/beacon/files/extra-patch-src_beacon.in b/net/beacon/files/extra-patch-src_beacon.in
deleted file mode 100644
index dab2f29e96ae..000000000000
--- a/net/beacon/files/extra-patch-src_beacon.in
+++ /dev/null
@@ -1,95 +0,0 @@
-
-$FreeBSD$
-
---- src/beacon.in.orig
-+++ src/beacon.in
-@@ -34,6 +34,7 @@
- use Net::Multicast::Beacon; # Make rtp.c RTP calls available in Perl
- use Getopt::Long; # Allow both -g -p and --group --port cmd lines
- use IO::Socket; # For reverse IP lookups to get hostname
-+use Socket6; # For reverse IPv6 lookup
- use IO::Select;
- use Net::Domain; # For getting the FQDN of the current host
- use Sys::Hostname; # Other way of getting the name of the current host
-@@ -3387,21 +3388,41 @@
- $thishost = $host;
- $thisuser = $user;
-
--my $packed = gethostbyname($host);
--if (! defined $packed) { # Couldn't get it - Mark it bad
-- $thisip = "UNKN";
--} else { # Unpack it into a string var
-- $thisip = inet_ntoa($packed); # "141.142.2.168"
--}
-+#if group address an IPv6 address, we have to find IPv6 addresses
-
--# Do the best job we can do for getting FQDN for the hostname
--my $lookup = gethostbyaddr(inet_aton($thisip), AF_INET);
--if (defined $lookup) { # Only update if it worked
-- $thishost = $host = $lookup;
-+if ($GROUP =~ ":" ) {
-+ my @res=getaddrinfo($host,'daytime',AF_INET6);
-+ my($packed,$port) = getnameinfo($res[3],NI_NUMERICHOST);
-+ my($packed2,$port2) = getnameinfo($res[3]);
-+
-+ if( !defined $packed) {
-+ $thisip = "UNKN";
-+ } else {
-+ $thisip = $packed;
-+ }
-+ if (!defined $packed2) {
-+ $thishost = $host = $packed2;
-+ } else {
-+ $thishost = $thisip;
-+ }
- } else {
-- $thishost = $thisip;
-+ my $packed = gethostbyname($host);
-+ if (! defined $packed) { # Couldn't get i t - Mark it bad
-+ $thisip = "UNKN";
-+ } else { # Unpack it into a string var
-+ $thisip = inet_ntoa($packed); # "141.142.2.168"
-+ }
-+
-+ # Do the best job we can do for getting FQDN for the hostname
-+ my $lookup = gethostbyaddr(inet_aton($thisip), AF_INET);
-+ if (defined $lookup) { # Only update if it worked
-+ $thishost = $host = $lookup;
-+ } else {
-+ $thishost = $thisip;
-+ }
- }
-
-+
- # If host still "UNKN" at this point, things are too confused to continue
- if ($thishost eq "UNKN") {
- die "Unable to resolve hostname -- Please check your system
-@@ -3642,11 +3663,23 @@
-
- # Get the IP address of the hostname given in $h
- my $hostip;
-- my $packed = gethostbyname($h);
-- if (! defined $packed) { # Couldn't get it - Mark it bad
-- $hostip = "UNKN";
-- } else { # Unpack it into a string var
-- $hostip = inet_ntoa($packed);
-+ if ( $GROUP =~ ":" ) {
-+ my @res = getaddrinfo($h,'daytime', AF_INET6);
-+ my ($packed,$port) = getnameinfo($res[3],NI_NUMERICHOST);
-+ my ($packed2,$port2) = getnameinfo($res[3]);
-+ if(defined $packed) {
-+ $hostip = $packed;
-+ }
-+ if(defined $packed2) {
-+ $hostip = $packed2;
-+ }
-+ } else {
-+ my $packed = gethostbyname($h);
-+ if (! defined $packed) { # Couldn't get it - Mark it bad
-+ $hostip = "UNKN";
-+ } else { # Unpack it into a string var
-+ $hostip = inet_ntoa($packed);
-+ }
- }
-
- # Create a sortname using hostname and SSRC
diff --git a/net/beacon/files/patch-Makefile.in b/net/beacon/files/patch-Makefile.in
deleted file mode 100644
index 38674344c88b..000000000000
--- a/net/beacon/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2005-08-26 13:22:44.000000000 -0700
-+++ Makefile.in 2010-07-30 17:37:58.000000000 -0700
-@@ -45,7 +45,7 @@
- AWK = @AWK@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
--CFLAGS = @CFLAGS@
-+CFLAGS = @CFLAGS@ -fPIC -DHAVE_INET_NTOP
- CPP = @CPP@
- CPPFLAGS = @CPPFLAGS@
- CYGPATH_W = @CYGPATH_W@
diff --git a/net/beacon/files/patch-common-beacon.patch b/net/beacon/files/patch-common-beacon.patch
deleted file mode 100644
index b0e405b51d4d..000000000000
--- a/net/beacon/files/patch-common-beacon.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- common-beacon.patch.orig 2005-06-15 18:46:40.000000000 -0700
-+++ common-beacon.patch 2010-07-30 17:34:45.000000000 -0700
-@@ -46,3 +46,15 @@
-
- #if !defined(WORDS_BIGENDIAN) && !defined(WORDS_SMALLENDIAN)
- #error RTP library requires WORDS_BIGENDIAN or WORDS_SMALLENDIAN to be defined.
-+--- common/src/net_udp.c 2004-06-29 09:21:37.000000000 -0700
-++++ common-beacon/src/net_udp.c 2010-07-30 17:28:06.000000000 -0700
-+@@ -44,7 +44,9 @@
-+ #include "debug.h"
-+ #include "memory.h"
-+ #include "inet_pton.h"
-++#ifndef HAVE_INET_NTOP
-+ #include "inet_ntop.h"
-++#endif
-+ #include "vsnprintf.h"
-+ #include "net_udp.h"
-+
diff --git a/net/beacon/files/patch-libbeacon-Makefile.in b/net/beacon/files/patch-libbeacon-Makefile.in
deleted file mode 100644
index 340b333a69ec..000000000000
--- a/net/beacon/files/patch-libbeacon-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libbeacon/Makefile.in.orig 2010-07-30 17:13:05.000000000 -0700
-+++ libbeacon/Makefile.in 2010-07-30 17:13:12.000000000 -0700
-@@ -45,7 +45,7 @@
- AWK = @AWK@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
--CFLAGS = @CFLAGS@
-+CFLAGS = @CFLAGS@ -fPIC
- CPP = @CPP@
- CPPFLAGS = @CPPFLAGS@
- CYGPATH_W = @CYGPATH_W@
diff --git a/net/beacon/files/patch-src_Makefile.in b/net/beacon/files/patch-src_Makefile.in
deleted file mode 100644
index cb334a44b733..000000000000
--- a/net/beacon/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.in.orig Fri Apr 28 22:29:11 2006
-+++ src/Makefile.in Fri Apr 28 22:30:22 2006
-@@ -160,8 +160,8 @@
- @list='$(dist_sysconf_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- f="`echo $$p | sed -e 's|^.*/||'`"; \
-- echo " $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f"; \
-- $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f; \
-+ echo " $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.sample"; \
-+ $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.sample; \
- done
-
- uninstall-dist_sysconfDATA:
diff --git a/net/beacon/pkg-descr b/net/beacon/pkg-descr
index e5768f1ea11c..0af1ba7fd740 100644
--- a/net/beacon/pkg-descr
+++ b/net/beacon/pkg-descr
@@ -4,4 +4,4 @@ a given multicast group.
The Multicast Beacon can be used as a general-purpose active multicast
measurement tool.
-WWW: http://dast.nlanr.net/Projects/Beacon/
+WWW: http://sourceforge.net/projects/multicastbeacon/
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
index 2ea49efb5e87..b3e8ac8df098 100644
--- a/net/beacon/pkg-plist
+++ b/net/beacon/pkg-plist
@@ -12,3 +12,4 @@ bin/beacon
etc/beacon.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+etc/rc.d/beacon