aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-05-15 07:02:17 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-05-15 07:02:17 +0000
commitf523b21b61a3853563632cb09ef89b80788b261c (patch)
tree0c146e25b26fc22c51415d509bc69469d5b56651 /net/beacon
parentf617ae6f5ddae0cdf41dbf5a926c6171882f196d (diff)
downloadports-f523b21b61a3853563632cb09ef89b80788b261c.tar.gz
ports-f523b21b61a3853563632cb09ef89b80788b261c.zip
Notes
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile19
-rw-r--r--net/beacon/distinfo5
-rw-r--r--net/beacon/files/patch-NMB-Makefile.in11
-rw-r--r--net/beacon/files/patch-src_Makefile.in17
-rw-r--r--net/beacon/pkg-plist3
5 files changed, 22 insertions, 33 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 63e572828bd4..d0403574a455 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= beacon
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= net perl5 mbone ipv6
MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/releases/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-0
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Beacon active measurement tool to monitor multicast
@@ -22,14 +21,15 @@ WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
USE_PERL5= yes
USE_AUTOTOOLS= autoconf:259
-CONFIGURE_ARGS= --bindir=${WWW_DIR}/${PORTNAME}-${PORTVERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.ifdef(WITH_IPV6)
+.ifdef(WITHOUT_IPV6)
+CONFIGURE_ARGS=
+.else
#enable IPv6 name lookup, and sending IPv6 multicast
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_beacon.in
-CONFUGURE_ARGS+= --enable-ipv6
+CONFIGURE_ARGS+= --enable-ipv6
.endif
.include <bsd.port.pre.mk>
@@ -39,9 +39,14 @@ IGNORE= requires perl 5.6.1 or later. Install lang/perl5 then try again
.endif
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not compile on !i386
.endif
+pre-build:
+ cd ${WRKSRC}/Net-Multicast-Beacon && \
+ make Makefile.perl && \
+ ${REINPLACE_CMD} -E 's,doc_\$$\(INSTALLDIRS\)_install$$,,g' Makefile.perl
+
post-install:
@${ECHO} "Sample config installed at \
${PREFIX}/etc/beacon.conf.sample"
diff --git a/net/beacon/distinfo b/net/beacon/distinfo
index edc663511b23..c3290479f820 100644
--- a/net/beacon/distinfo
+++ b/net/beacon/distinfo
@@ -1,3 +1,2 @@
-MD5 (beacon-1.1-0.tar.gz) = 93c7c9278b1b37a1bb6b9f4bd0af9d9d
-SHA256 (beacon-1.1-0.tar.gz) = 6b17b4e703e9e5e2aedf310b3a36faf1ffcc4014d19dac88bd0bbdb17e987552
-SIZE (beacon-1.1-0.tar.gz) = 247815
+MD5 (beacon-1.3.tar.gz) = e01b0de6b0d7d01ea51bad799b147d8c
+SIZE (beacon-1.3.tar.gz) = 411823
diff --git a/net/beacon/files/patch-NMB-Makefile.in b/net/beacon/files/patch-NMB-Makefile.in
deleted file mode 100644
index 2144063b9b63..000000000000
--- a/net/beacon/files/patch-NMB-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Net-Multicast-Beacon/Makefile.in.orig Tue Jul 13 20:56:28 2004
-+++ Net-Multicast-Beacon/Makefile.in Sat Dec 18 16:52:21 2004
-@@ -300,7 +300,7 @@
- $(PERL) Makefile.PL MAKEFILE=$@
-
- install-data-local:
-- $(MAKE) -fMakefile.perl install
-+ $(MAKE) -fMakefile.perl pure_install
- clean-local:
- if test -f Makefile.perl; then $(MAKE) -fMakefile.perl realclean; fi
- rm -f Makefile.perl Makefile.perl.old
diff --git a/net/beacon/files/patch-src_Makefile.in b/net/beacon/files/patch-src_Makefile.in
index d56ea8fea01d..cb334a44b733 100644
--- a/net/beacon/files/patch-src_Makefile.in
+++ b/net/beacon/files/patch-src_Makefile.in
@@ -1,16 +1,13 @@
-
-$FreeBSD$
-
---- src/Makefile.in.orig Tue Jun 8 03:09:48 2004
-+++ src/Makefile.in Tue Jul 6 17:16:16 2004
-@@ -202,8 +202,8 @@
+--- src/Makefile.in.orig Fri Apr 28 22:29:11 2006
++++ src/Makefile.in Fri Apr 28 22:30:22 2006
+@@ -160,8 +160,8 @@
@list='$(dist_sysconf_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
f="`echo $$p | sed -e 's|^.*/||'`"; \
-- echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
-- $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
-+ echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f.sample'"; \
-+ $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f.sample"; \
+- echo " $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f"; \
+- $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f; \
++ echo " $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.sample"; \
++ $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.sample; \
done
uninstall-dist_sysconfDATA:
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
index 5c1f285a6f26..b734cbba0e3a 100644
--- a/net/beacon/pkg-plist
+++ b/net/beacon/pkg-plist
@@ -7,8 +7,7 @@
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
-www/beacon-%%VERSION%%/beacon
-@dirrm www/beacon-%%VERSION%%
+bin/beacon
etc/beacon.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%