aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-07-11 20:06:33 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-07-11 20:06:33 +0000
commit65ac524403c78faa418e7a4ab1ccce5e078b7cce (patch)
treef71bea89e7e8295141052b42a5a0904ef7b5ce7a /net/beacon
parent8f98f18dd3b5bbb53b14e351e827a3d2bc0ad0e5 (diff)
downloadports-65ac524403c78faa418e7a4ab1ccce5e078b7cce.tar.gz
ports-65ac524403c78faa418e7a4ab1ccce5e078b7cce.zip
Notes
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile34
-rw-r--r--net/beacon/distinfo4
-rw-r--r--net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h14
-rw-r--r--net/beacon/files/patch-beacon.pl11
-rw-r--r--net/beacon/files/patch-src_Makefile.in16
-rw-r--r--net/beacon/pkg-plist17
6 files changed, 36 insertions, 60 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 4462eecb24a6..fb688b006f55 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= beacon
-PORTVERSION= 0.9.06
-PORTREVISION= 1
+PORTVERSION= 0.9.55
CATEGORIES= net perl5 mbone ipv6
-MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
+MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/releases/
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Beacon active measurement tool to monitor multicast
@@ -17,10 +16,12 @@ COMMENT= Beacon active measurement tool to monitor multicast
BUILD_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= "Unfetchable"
-
WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
+USE_PERL5= yes
+USE_AUTOCONF_VER= 259
+CONFIGURE_ARGS= --enable-ipv6 --bindir=${WWW_DIR}/${PORTNAME}-${PORTVERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
@@ -28,30 +29,13 @@ PLIST_SUB+= VERSION=${PORTVERSION}
IGNORE= Port requires perl 5.6.1 or later. Install lang/perl5 then try again
.endif
-do-build:
- #Build unreleased NET::RTP perl module
- cd ${WRKSRC}/Net-RTP-0.4/ ; \
- ./configure --enable-ipv6 ; \
- ${PERL} Makefile.PL ; \
- make
-
-do-install:
- #Install unreleased NET::RTP perl module
- cd ${WRKSRC}/Net-RTP-0.4/ ; \
- make install
- #Install the Beacon itself
- ${MKDIR} ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
- ${INSTALL_SCRIPT} ${WRKSRC}/beacon.pl ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
- ${INSTALL_DATA} ${WRKSRC}/beacon.conf ${PREFIX}/etc/beacon.conf.sample
- @${ECHO} ""
+post-install:
@${ECHO} "Sample config installed at \
- ${PREFIX}/etc/beacon.conf.sample"
+ ${PREFIX}/etc/beacon.conf.sample"
@${ECHO} "Copy the customised version to ${PREFIX}/etc/beacon.conf"
-
.ifndef(NOPORTDOCS)
-post-install:
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/net/beacon/distinfo b/net/beacon/distinfo
index a682716f28a5..612bfd667962 100644
--- a/net/beacon/distinfo
+++ b/net/beacon/distinfo
@@ -1,2 +1,2 @@
-MD5 (beacon-0.9.06.tar.gz) = a0a845fb352eb4caa00ed8b4b9cc65ca
-SIZE (beacon-0.9.06.tar.gz) = 436777
+MD5 (beacon-0.9.55.tar.gz) = edc9876c2ca094e12a773e9bef930a86
+SIZE (beacon-0.9.55.tar.gz) = 240630
diff --git a/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h b/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h
deleted file mode 100644
index 73e127905e5f..000000000000
--- a/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- Net-RTP-0.4/inet_ntop.h.orig Tue Mar 2 14:00:58 2004
-+++ Net-RTP-0.4/inet_ntop.h Tue Mar 2 14:02:27 2004
-@@ -3,7 +3,11 @@
- extern "C" {
- #endif
-
-+#if defined(__sparc64__) || defined(__amd64__) || defined(__alpha__) || defined(__ia64__)
-+const char *inet_ntop(int af, const void *src, char *dst, socklen_t size);
-+#else
- const char *inet_ntop(int af, const void *src, char *dst, size_t size);
-+#endif
-
- #if defined(__cplusplus)
- }
diff --git a/net/beacon/files/patch-beacon.pl b/net/beacon/files/patch-beacon.pl
deleted file mode 100644
index 5dc60495f1d6..000000000000
--- a/net/beacon/files/patch-beacon.pl
+++ /dev/null
@@ -1,11 +0,0 @@
---- beacon.pl.orig Thu Feb 26 13:58:02 2004
-+++ beacon.pl Thu Feb 26 13:58:35 2004
-@@ -1849,7 +1849,7 @@
- die("Partial options specified -- You must give group, port, and ttl values - Triggered");
- } else { # Didn't specify any options at all -- Use default config file
- if (! defined $CONFIGFILE) { # They DIDN'T specify a config file on the command line
-- $CONFIGFILE = "beacon.conf"; # Default config file for Beacon -- Otherwise, use what they gave us
-+ $CONFIGFILE = "${PREFIX}/etc/beacon.conf"; # Default config file for Beacon -- Otherwise, use what they gave us
- }
- }
- }
diff --git a/net/beacon/files/patch-src_Makefile.in b/net/beacon/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..d56ea8fea01d
--- /dev/null
+++ b/net/beacon/files/patch-src_Makefile.in
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- src/Makefile.in.orig Tue Jun 8 03:09:48 2004
++++ src/Makefile.in Tue Jul 6 17:16:16 2004
+@@ -202,8 +202,8 @@
+ @list='$(dist_sysconf_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
++ echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f.sample'"; \
++ $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f.sample"; \
+ done
+
+ uninstall-dist_sysconfDATA:
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
index c1afe5f7b594..f62e8658e6fe 100644
--- a/net/beacon/pkg-plist
+++ b/net/beacon/pkg-plist
@@ -1,12 +1,13 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Net/RTP.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Net/time.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/Net/rtpdemo.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/RTP.bs
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/RTP.so
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/Beacon.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/Beacon.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/Beacon.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Net 2>/dev/null || true
-www/beacon-%%VERSION%%/beacon.pl
+www/beacon-%%VERSION%%/beacon
etc/beacon.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%