aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-28 20:39:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-28 20:39:16 +0000
commit80f46400db2598bac4265dce3042170081e81ea8 (patch)
tree45351e7844833d3de33be59343cd9e4691a717d5 /net/beacon
parent605eb95c6257651e644cb3ac9fed9ea23de19fef (diff)
downloadports-80f46400db2598bac4265dce3042170081e81ea8.tar.gz
ports-80f46400db2598bac4265dce3042170081e81ea8.zip
Notes
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile54
-rw-r--r--net/beacon/distinfo2
-rw-r--r--net/beacon/files/patch-beacon.pl11
-rw-r--r--net/beacon/pkg-descr7
-rw-r--r--net/beacon/pkg-plist12
5 files changed, 86 insertions, 0 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
new file mode 100644
index 000000000000..53c167fd2240
--- /dev/null
+++ b/net/beacon/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: beacon
+# Date created: 26 February 2004
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= beacon
+PORTVERSION= 0.9.06
+CATEGORIES= net perl5 mbone ipv6
+MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Beacon active measurement tool to monitor multicast
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WWW_DIR?= ${PREFIX}/www/
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= Port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+do-build:
+ #Build unreleased NET::RTP perl module
+ cd ${WRKSRC}/Net-RTP-0.4/ ; \
+ ./configure --enable-ipv6 ; \
+ ${PERL} Makefile.PL ; \
+ make
+
+do-install:
+ #Install unreleased NET::RTP perl module
+ cd ${WRKSRC}/Net-RTP-0.4/ ; \
+ make install
+ #Install the Beacon itself
+ ${MKDIR} ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
+ ${INSTALL_SCRIPT} ${WRKSRC}/beacon.pl ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
+ ${INSTALL_DATA} ${WRKSRC}/beacon.conf ${PREFIX}/etc/beacon.conf.sample
+ @${ECHO} ""
+ @${ECHO} "Sample config installed at \
+ ${PREFIX}/etc/beacon.conf.sample"
+ @${ECHO} "Copy the customised version to ${PREFIX}/etc/beacon.conf"
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/beacon/distinfo b/net/beacon/distinfo
new file mode 100644
index 000000000000..a682716f28a5
--- /dev/null
+++ b/net/beacon/distinfo
@@ -0,0 +1,2 @@
+MD5 (beacon-0.9.06.tar.gz) = a0a845fb352eb4caa00ed8b4b9cc65ca
+SIZE (beacon-0.9.06.tar.gz) = 436777
diff --git a/net/beacon/files/patch-beacon.pl b/net/beacon/files/patch-beacon.pl
new file mode 100644
index 000000000000..5dc60495f1d6
--- /dev/null
+++ b/net/beacon/files/patch-beacon.pl
@@ -0,0 +1,11 @@
+--- beacon.pl.orig Thu Feb 26 13:58:02 2004
++++ beacon.pl Thu Feb 26 13:58:35 2004
+@@ -1849,7 +1849,7 @@
+ die("Partial options specified -- You must give group, port, and ttl values - Triggered");
+ } else { # Didn't specify any options at all -- Use default config file
+ if (! defined $CONFIGFILE) { # They DIDN'T specify a config file on the command line
+- $CONFIGFILE = "beacon.conf"; # Default config file for Beacon -- Otherwise, use what they gave us
++ $CONFIGFILE = "${PREFIX}/etc/beacon.conf"; # Default config file for Beacon -- Otherwise, use what they gave us
+ }
+ }
+ }
diff --git a/net/beacon/pkg-descr b/net/beacon/pkg-descr
new file mode 100644
index 000000000000..e5768f1ea11c
--- /dev/null
+++ b/net/beacon/pkg-descr
@@ -0,0 +1,7 @@
+The NLANR/DAST Multicast Beacon is a program written in Perl which uses the
+RTP protocol to provide useful statistics and diagnostic information about
+a given multicast group.
+The Multicast Beacon can be used as a general-purpose active multicast
+measurement tool.
+
+WWW: http://dast.nlanr.net/Projects/Beacon/
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
new file mode 100644
index 000000000000..c1afe5f7b594
--- /dev/null
+++ b/net/beacon/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/RTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/time.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/rtpdemo.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/RTP.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP/RTP.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RTP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Net 2>/dev/null || true
+www/beacon-%%VERSION%%/beacon.pl
+etc/beacon.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%