aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-10-28 19:49:13 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-10-28 19:49:13 +0000
commitd930cfd2e520d8842c17d9fc954a0db1543f84a5 (patch)
tree2697a208b0c3ca07edf9db22515f50f5006d3cdc /net/beacon
parent3d2613df2779f6bbd017969997b7b75d0f4bccb6 (diff)
downloadports-d930cfd2e520d8842c17d9fc954a0db1543f84a5.tar.gz
ports-d930cfd2e520d8842c17d9fc954a0db1543f84a5.zip
Notes
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index ea4cb8e75de0..9f369f6a503a 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: beacon
-# Date created: 26 February 2004
-# Whom: Janos.Mohacsi@bsd.hu
-#
+# Created by: Janos.Mohacsi@bsd.hu
# $FreeBSD$
-#
PORTNAME= beacon
PORTVERSION= 1.4
@@ -22,15 +18,22 @@ PLIST_SUB+= VERSION=${PORTVERSION}
USE_PERL5= yes
USE_AUTOTOOLS= autoconf
-OPTIONS= IPV6 "Enable IPv6 PTR lookups" off
+OPTIONS_DEFINE= IPV6
+OPTIONS_DEFAULT=
-.ifdef(WITH_IPV6)
+IPV6_DESC= Enable IPv6 PTR lookups
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIPV6}
BUILD_DEPENDS+= p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
.endif
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif