aboutsummaryrefslogtreecommitdiff
path: root/net/beacon
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-02 13:11:43 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-02 13:11:43 +0000
commit55ed94befa17da805860946244e3cd8ac9d15e5c (patch)
tree76e8c50299e923a7ad8a439775e574acf53affbb /net/beacon
parentc175fc20989494346c945b2136a453f3e5be7cad (diff)
Notes
Diffstat (limited to 'net/beacon')
-rw-r--r--net/beacon/Makefile1
-rw-r--r--net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h14
2 files changed, 15 insertions, 0 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 53c167fd2240..ed7f0ede707d 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= beacon
PORTVERSION= 0.9.06
+PORTREVISION= 1
CATEGORIES= net perl5 mbone ipv6
MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
diff --git a/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h b/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h
new file mode 100644
index 000000000000..e9ca6f5f9cc1
--- /dev/null
+++ b/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h
@@ -0,0 +1,14 @@
+--- Net-RTP-0.4/inet_ntop.h.orig Tue Mar 2 14:00:58 2004
++++ Net-RTP-0.4/inet_ntop.h Tue Mar 2 14:02:27 2004
+@@ -3,7 +3,11 @@
+ extern "C" {
+ #endif
+
++#ifdef __sparc64__ || __amd64__ || __alpha__
++const char *inet_ntop(int af, const void *src, char *dst, socklen_t size);
++#else
+ const char *inet_ntop(int af, const void *src, char *dst, size_t size);
++#endif
+
+ #if defined(__cplusplus)
+ }