aboutsummaryrefslogtreecommitdiff
path: root/net/beanstalkd
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 08:32:07 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 08:32:07 +0000
commitba9cbb6ed5f38175e21a773e3976a360de044587 (patch)
tree7dfb67622d2b4fce3df6631a52b105d695c9c1b8 /net/beanstalkd
parentc78bb8f4836c030a6172c9a0e90333b60f279f0b (diff)
downloadports-ba9cbb6ed5f38175e21a773e3976a360de044587.tar.gz
ports-ba9cbb6ed5f38175e21a773e3976a360de044587.zip
Notes
Diffstat (limited to 'net/beanstalkd')
-rw-r--r--net/beanstalkd/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net/beanstalkd/Makefile b/net/beanstalkd/Makefile
index 87cf7d2ea90e..4ef7198bcc1c 100644
--- a/net/beanstalkd/Makefile
+++ b/net/beanstalkd/Makefile
@@ -10,28 +10,26 @@ COMMENT= Fast, distributed, in-memory workqueue service
LICENSE= MIT
+USES= gmake
USE_RC_SUBR= beanstalkd
-USE_GMAKE= yes
MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}"
-PLIST_FILES= bin/beanstalkd
+PLIST_FILES= bin/beanstalkd man/man1/beanstalkd.1.gz
SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
PORTDOCS= protocol.txt
-MAN1= beanstalkd.1
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/beanstalkd ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/beanstalkd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
test: configure
@cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS} check