aboutsummaryrefslogtreecommitdiff
path: root/net/belle-sip
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-17 12:03:33 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-17 12:03:33 +0000
commit9c41e6e87cd9ab280a5099f4473525d662e11e2c (patch)
treea8e747cc86242caaefbfb913ac989567b0ef33bd /net/belle-sip
parent49cf300a1135b740e0a0bc4b2674a6e639a56a2e (diff)
downloadports-9c41e6e87cd9ab280a5099f4473525d662e11e2c.tar.gz
ports-9c41e6e87cd9ab280a5099f4473525d662e11e2c.zip
Notes
Diffstat (limited to 'net/belle-sip')
-rw-r--r--net/belle-sip/Makefile8
-rw-r--r--net/belle-sip/files/patch-src_dns.c10
2 files changed, 12 insertions, 6 deletions
diff --git a/net/belle-sip/Makefile b/net/belle-sip/Makefile
index 7e0991d6d327..f491d28a0f5c 100644
--- a/net/belle-sip/Makefile
+++ b/net/belle-sip/Makefile
@@ -2,8 +2,8 @@
PORTNAME= belle-sip
PORTVERSION= 1.3.0
-PORTREVISION= 1
-CATEGORIES= net
+PORTREVISION= 2
+CATEGORIES= net java
MASTER_SITES= SAVANNAH/linphone/${PORTNAME}/:source1 \
http://www.antlr3.org/download/:source2
DISTFILES= belle-sip-1.3.0.tar.gz:source1 \
@@ -35,10 +35,6 @@ OPTIONS_DEFAULT=POLARSSL
POLARSSL_CONFIGURE_ENABLE= tls
POLARSSL_LIB_DEPENDS= libpolarssl.so:${PORTSDIR}/security/polarssl
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
post-extract:
@${CP} ${DISTDIR}/antlr-3.4-complete.jar ${WRKDIR}/antlr-complete.jar
diff --git a/net/belle-sip/files/patch-src_dns.c b/net/belle-sip/files/patch-src_dns.c
new file mode 100644
index 000000000000..3b05417a1059
--- /dev/null
+++ b/net/belle-sip/files/patch-src_dns.c
@@ -0,0 +1,10 @@
+--- src/dns.c.orig 2014-08-16 15:34:00.457977967 +0600
++++ src/dns.c 2014-08-16 15:34:32.647973864 +0600
+@@ -4306,6 +4306,7 @@
+ union res_sockaddr_union addresses[3];
+ int i,error;
+
++ bzero(&res, sizeof(res));
+ if ((error = res_ninit(&res))) {
+ return error;
+ }