aboutsummaryrefslogtreecommitdiff
path: root/net/bird/Makefile
diff options
context:
space:
mode:
authorAlexander V. Chernikov <melifaro@FreeBSD.org>2015-05-04 10:24:00 +0000
committerAlexander V. Chernikov <melifaro@FreeBSD.org>2015-05-04 10:24:00 +0000
commit7eb9f40e473cd03feffc87f1c4756ece6cd66082 (patch)
tree5c7b60ee9fadcd8f17706ecf9df960f987564361 /net/bird/Makefile
parentbcf6bf3606dc4b1d0746dc3dc4f724f7594d3a90 (diff)
Bump version to 1.5.0 (changelog below).
Remove experimental and already included patches. Add OSPF: Fixes validation of LSA checksums from git. Remove clang gnu89 constaint. Version 1.5.0 (2015-04-20) Major OSPF protocol redesign. OSPFv2 multi-instance extension (RFC 6549). BGP AS-wide unique router ID (RFC 6286). BGP enhanced route refresh (RFC 7313). Link state support in BGP. Latency tracking and internal watchdog. Uses high port range for BFD on BSD. Increase max symbol length to 64. Allows to define unnamed protocols from templates. Fixes two serious bugs in BGP. Several bugfixes and minor improvements. Several minor option changes: - OSPF: Protocol-wide 'instance id' option added. - BGP: Parameters to option 'neighbor' extended. - BGP: Separate option 'interface' added. - BGP: Option 'start delay time' renamed to 'connect delay time'. - BGP: Option 'route limit' deprecated. Upgrade notes: For OSPF, there are deep internal changes, but user-visible changes are limited to log messages and minor changes in formatting of command output. For BGP, version 1.5.0 is essentially a minor release. There are two deprecated options ('start delay time' and 'route limit') and some minor formatting changes. Reviewed by: az(implicit)
Notes
Notes: svn path=/head/; revision=385390
Diffstat (limited to 'net/bird/Makefile')
-rw-r--r--net/bird/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index a2a862933526..6d898eafb399 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME?= bird
-PORTVERSION= 1.4.5
-PORTREVISION= 2
+PORTVERSION= 1.5.0
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/ \
http://bird.mpls.in/distfiles/bird/
@@ -16,12 +15,10 @@ LICENSE= GPLv2
USES= bison gmake readline
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --localstatedir=/var
-USE_CSTD= gnu89
-OPTIONS_DEFINE?= FIREWALL AGG EXP
+OPTIONS_DEFINE?= FIREWALL AGG
FIREWALL_DESC= Enable firewall protocol
AGG_DESC= Enable aggregation protocol (EXPERIMENTAL)
-EXP_DESC= Enable some experimental patches
NO_OPTIONS_SORT= yes
MAKE_JOBS_UNSAFE= yes
@@ -34,7 +31,6 @@ PLIST_SUB?= VER=""
FIREWALL_EXTRA_PATCHES+= ${FILESDIR}/firewall_support.patch
AGG_EXTRA_PATCHES+= ${FILESDIR}/agg_support.patch
-EXP_EXTRA_PATCHES+= ${FILESDIR}/exp-templates.patch ${FILESDIR}/exp-ll.patch ${FILESDIR}/exp-locks.patch
.include <bsd.port.options.mk>