aboutsummaryrefslogtreecommitdiff
path: root/net/bird
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2019-08-28 03:15:33 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2019-08-28 03:15:33 +0000
commit2bd5f9f2de807974194ad0f124919652a014543c (patch)
tree2d94956202200b863042668193275d74791a3cd2 /net/bird
parent9712359a6252acf54ff18cc7024d4f0eeb0c83b1 (diff)
downloadports-2bd5f9f2de807974194ad0f124919652a014543c.tar.gz
ports-2bd5f9f2de807974194ad0f124919652a014543c.zip
Notes
Diffstat (limited to 'net/bird')
-rw-r--r--net/bird/Makefile1
-rw-r--r--net/bird/files/patch-proto__ospf__lsupd.c11
-rw-r--r--net/bird/files/patch-proto__ospf__topology.c32
3 files changed, 1 insertions, 43 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 934d655bdc68..88b95a42f4f8 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bird
PORTVERSION= 1.6.7
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
diff --git a/net/bird/files/patch-proto__ospf__lsupd.c b/net/bird/files/patch-proto__ospf__lsupd.c
deleted file mode 100644
index 7366734a6b61..000000000000
--- a/net/bird/files/patch-proto__ospf__lsupd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- proto/ospf/lsupd.c 2015-04-22 14:41:44.000000000 +0000
-+++ proto/ospf/lsupd.c 2016-03-22 13:09:59.000000000 +0000
-@@ -593,7 +593,7 @@
- if ((lsa.rt == p->router_id) ||
- (ospf_is_v2(p) && (lsa_type == LSA_T_NET) && ospf_addr_is_local(p, ifa->oa, ipa_from_u32(lsa.id))))
- {
-- OSPF_TRACE(D_EVENTS, "Received unexpected self-originated LSA");
-+ log(L_INFO "Received unexpected self-originated LSA");
- ospf_advance_lsa(p, en, &lsa, lsa_type, lsa_domain, body);
- continue;
- }
diff --git a/net/bird/files/patch-proto__ospf__topology.c b/net/bird/files/patch-proto__ospf__topology.c
deleted file mode 100644
index 2564ecc6ecee..000000000000
--- a/net/bird/files/patch-proto__ospf__topology.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- proto/ospf/topology.c 2015-04-22 14:41:44.000000000 +0000
-+++ proto/ospf/topology.c 2016-03-24 13:36:04.000000000 +0000
-@@ -79,8 +79,12 @@
- * then we have en->mode from the postponed LSA origination.
- */
-
-- OSPF_TRACE(D_EVENTS, "Installing LSA: Type: %04x, Id: %R, Rt: %R, Seq: %08x, Age: %u",
-- en->lsa_type, en->lsa.id, en->lsa.rt, en->lsa.sn, en->lsa.age);
-+ if (en->lsa.rt == p->router_id || (p->p.debug & D_EVENTS) ||
-+ OSPF_FORCE_DEBUG)
-+ {
-+ log(L_INFO "Installing LSA: Type: %04x, Id: %R, Rt: %R, Seq: %08x, Age: %u",
-+ en->lsa_type, en->lsa.id, en->lsa.rt, en->lsa.sn, en->lsa.age);
-+ }
-
- if (change)
- ospf_schedule_rtcalc(p);
-@@ -281,6 +285,14 @@
- if (!en->nf || !en->lsa_body)
- en->nf = lsa->nf;
-
-+ if (en->lsa_body && (en->lsa.age == LSA_MAXAGE))
-+ {
-+ /* en could be an unexpected self-originated lsa in which case nf is NULL */
-+ log(L_INFO "%s: Found flushing LSA while originating %I/%d with fib: %p",
-+ p->p.name, lsa->nf->fn.prefix, lsa->nf->fn.pxlen, en->nf);
-+ en->nf = lsa->nf;
-+ }
-+
- if (en->nf != lsa->nf)
- {
- log(L_ERR "%s: LSA ID collision for %I/%d",