aboutsummaryrefslogtreecommitdiff
path: root/net/bird
diff options
context:
space:
mode:
authorAlexander V. Chernikov <melifaro@FreeBSD.org>2013-05-07 16:29:13 +0000
committerAlexander V. Chernikov <melifaro@FreeBSD.org>2013-05-07 16:29:13 +0000
commit56fd66c403a9b57faeb52dcb0f8d428a3b601280 (patch)
tree73d214f9f73ab6ca7a3690de9f3faa885d7df967 /net/bird
parentd51d5eb42e88ea37a07311a467b2dd25401e5cc7 (diff)
Update net/bird && net/bird6 to 1.3.10.
Reviewed by: az
Notes
Notes: svn path=/head/; revision=317623
Diffstat (limited to 'net/bird')
-rw-r--r--net/bird/Makefile3
-rw-r--r--net/bird/distinfo4
-rw-r--r--net/bird/files/patch-rtrtid.diff29
3 files changed, 3 insertions, 33 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 0807960ec66c..f72ccb6afac2 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bird
-PORTVERSION= 1.3.9
-PORTREVISION= 1
+PORTVERSION= 1.3.10
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/ \
http://bird.mpls.in/distfiles/bird/
diff --git a/net/bird/distinfo b/net/bird/distinfo
index a59d196917c1..e7188e5eb13b 100644
--- a/net/bird/distinfo
+++ b/net/bird/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bird-1.3.9.tar.gz) = 928073d9f6c768869c002a0c732d48159dc50530ed90fb7f3da76a6febd0cf94
-SIZE (bird-1.3.9.tar.gz) = 994681
+SHA256 (bird-1.3.10.tar.gz) = 4c080001555fe1399920fa251e9394a4f286e2021f07e1d53f232917c2aabfbb
+SIZE (bird-1.3.10.tar.gz) = 1003066
diff --git a/net/bird/files/patch-rtrtid.diff b/net/bird/files/patch-rtrtid.diff
deleted file mode 100644
index b2fdc0c69145..000000000000
--- a/net/bird/files/patch-rtrtid.diff
+++ /dev/null
@@ -1,29 +0,0 @@
-commit 0db7a007594bf11031ea133d0df4ec7d3d88e82c
-Author: Alexander V. Chernikov <melifaro@ipfw.ru>
-Date: Fri Mar 1 16:19:47 2013 +0000
-
- Permit loopback interfaces to be used as router id source
-
-diff --git a/nest/iface.c b/nest/iface.c
-index da79b21..a12cbdc 100644
---- nest/iface.c
-+++ nest/iface.c
-@@ -589,7 +589,7 @@ if_choose_router_id(struct iface_patt *mask, u32 old_id)
- WALK_LIST(i, iface_list)
- {
- if (!(i->flags & IF_ADMIN_UP) ||
-- (i->flags & (IF_IGNORE | IF_SHUTDOWN)))
-+ (i->flags & IF_SHUTDOWN))
- continue;
-
- WALK_LIST(a, i->addrs)
-@@ -612,6 +612,9 @@ if_choose_router_id(struct iface_patt *mask, u32 old_id)
- if (mask && !iface_patt_match(mask, i, a))
- continue;
-
-+ if ((i->flags & IF_IGNORE) && !mask)
-+ continue;
-+
- /* No pattern or pattern matched */
- if (!b || ipa_to_u32(a->ip) < ipa_to_u32(b->ip))
- b = a;