aboutsummaryrefslogtreecommitdiff
path: root/net/blam
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-09-21 02:24:31 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-09-21 02:24:31 +0000
commit0f17050544bd7ca9cae3b1362193e208493006e0 (patch)
tree9e96f7a1a9b7d838d4539930b6589646cd8cf047 /net/blam
parent58db805e93e643ebd71c7f987a4e48925c03c49c (diff)
downloadports-0f17050544bd7ca9cae3b1362193e208493006e0.tar.gz
ports-0f17050544bd7ca9cae3b1362193e208493006e0.zip
Notes
Diffstat (limited to 'net/blam')
-rw-r--r--net/blam/Makefile3
-rw-r--r--net/blam/files/extra-libblam_blam-gecko-utils.cpp11
2 files changed, 14 insertions, 0 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
index 36d634569ac7..503fb2f24db9 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -36,4 +36,7 @@ GCONF_SCHEMAS= blam.schemas
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+.if ${GECKO}!="mozilla"
+EXTRA_PATCHES+= ${PATCHDIR}/extra-libblam_blam-gecko-utils.cpp
+.endif
.include <bsd.port.post.mk>
diff --git a/net/blam/files/extra-libblam_blam-gecko-utils.cpp b/net/blam/files/extra-libblam_blam-gecko-utils.cpp
new file mode 100644
index 000000000000..a9c81ae1978e
--- /dev/null
+++ b/net/blam/files/extra-libblam_blam-gecko-utils.cpp
@@ -0,0 +1,11 @@
+--- libblam/blam-gecko-utils.cpp.orig Fri May 6 04:07:49 2005
++++ libblam/blam-gecko-utils.cpp Wed Sep 20 19:15:58 2006
+@@ -29,6 +29,8 @@
+ #include <nsEmbedString.h>
+ #include <nsIPrefService.h>
+ #include <nsIServiceManager.h>
++#include <nsServiceManagerUtils.h>
++#include <nsCOMPtr.h>
+
+ #if defined (HAVE_CHROME_NSICHROMEREGISTRYSEA_H)
+ #include <chrome/nsIChromeRegistrySea.h>