aboutsummaryrefslogtreecommitdiff
path: root/net/blam
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-06-10 20:32:06 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-06-10 20:32:06 +0000
commit7027d6c4c7f8a314405b0321ff92feefc51168e0 (patch)
tree166464b512dbba509d383e1bf2566cf6f4372fa6 /net/blam
parent585198fd82b265cc0636da02a5374861c60fa92b (diff)
downloadports-7027d6c4c7f8a314405b0321ff92feefc51168e0.tar.gz
ports-7027d6c4c7f8a314405b0321ff92feefc51168e0.zip
Notes
Diffstat (limited to 'net/blam')
-rw-r--r--net/blam/Makefile25
-rw-r--r--net/blam/distinfo6
-rw-r--r--net/blam/files/extra-libblam_blam-gecko-utils.cpp11
-rw-r--r--net/blam/files/patch-blam.in9
-rw-r--r--net/blam/files/patch-src-Application.cs25
-rw-r--r--net/blam/pkg-descr2
-rw-r--r--net/blam/pkg-plist46
7 files changed, 91 insertions, 33 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
index 3693179fafe6..6b59821f9981 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -7,35 +7,38 @@
#
PORTNAME= blam
-PORTVERSION= 1.8.2
-PORTREVISION= 7
+PORTVERSION= 1.8.4
CATEGORIES= net gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.8
+MASTER_SITES= http://www.cmartin.tk/blam/
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Mono based RSS feed reader
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gecko-sharp.pc:${PORTSDIR}/www/gecko-sharp10
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gecko-sharp.pc:${PORTSDIR}/www/gecko-sharp10
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gecko-sharp-2.0.pc:${PORTSDIR}/www/gecko-sharp20
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gecko-sharp-2.0.pc:${PORTSDIR}/www/gecko-sharp20
USE_GECKO= firefox mozilla
-USE_GNOME= gnomeprefix gnomehack intlhack intltool libgnomeui gtksharp10
+USE_GNOME= gnomeprefix gnomehack intlhack intltool libgnomeui gnomesharp20
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla=${GECKO}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= blam.1
+
GCONF_SCHEMAS= blam.schemas
+post-patch:
+ @${REINPLACE_CMD} 's|img src="|img src="file://${PREFIX}/share/gnome/blam/themes/blam/|g' \
+ ${WRKSRC}/themes/blam/theme.html
+ @${REINPLACE_CMD} 's|img src="|img src="file://${PREFIX}/share/gnome/blam/themes/pimped/|g' \
+ ${WRKSRC}/themes/pimped/theme.html
+
+
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
-.if ${GECKO}!="mozilla"
-EXTRA_PATCHES+= ${PATCHDIR}/extra-libblam_blam-gecko-utils.cpp
-.endif
.include <bsd.port.post.mk>
diff --git a/net/blam/distinfo b/net/blam/distinfo
index 71d9dd705761..29bd42e955f1 100644
--- a/net/blam/distinfo
+++ b/net/blam/distinfo
@@ -1,3 +1,3 @@
-MD5 (blam-1.8.2.tar.bz2) = 9d8038f5cdcee2cd4dc5dc9cc602ccaf
-SHA256 (blam-1.8.2.tar.bz2) = 154db4de714966db2bab18b562c67b3472907aebc428e618b1a04988014de548
-SIZE (blam-1.8.2.tar.bz2) = 485604
+MD5 (blam-1.8.4.tar.bz2) = 7ec48fece9994ed71dbb53ffa35b633e
+SHA256 (blam-1.8.4.tar.bz2) = c867ce3638d31705d484538f0cd18ff7f8209eea56466b430db63267adde1c13
+SIZE (blam-1.8.4.tar.bz2) = 517873
diff --git a/net/blam/files/extra-libblam_blam-gecko-utils.cpp b/net/blam/files/extra-libblam_blam-gecko-utils.cpp
index a9c81ae1978e..e69de29bb2d1 100644
--- a/net/blam/files/extra-libblam_blam-gecko-utils.cpp
+++ b/net/blam/files/extra-libblam_blam-gecko-utils.cpp
@@ -1,11 +0,0 @@
---- libblam/blam-gecko-utils.cpp.orig Fri May 6 04:07:49 2005
-+++ libblam/blam-gecko-utils.cpp Wed Sep 20 19:15:58 2006
-@@ -29,6 +29,8 @@
- #include <nsEmbedString.h>
- #include <nsIPrefService.h>
- #include <nsIServiceManager.h>
-+#include <nsServiceManagerUtils.h>
-+#include <nsCOMPtr.h>
-
- #if defined (HAVE_CHROME_NSICHROMEREGISTRYSEA_H)
- #include <chrome/nsIChromeRegistrySea.h>
diff --git a/net/blam/files/patch-blam.in b/net/blam/files/patch-blam.in
new file mode 100644
index 000000000000..1ea7ec1c8e2c
--- /dev/null
+++ b/net/blam/files/patch-blam.in
@@ -0,0 +1,9 @@
+--- blam.in.orig Sun Apr 15 16:58:55 2007
++++ blam.in Sun Apr 15 16:59:02 2007
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ LD_LIBRARY_PATH="@prefix@/lib/blam:@MOZILLA_HOME@${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}" MOZILLA_FIVE_HOME=@MOZILLA_HOME@ \
+-MOZILLA_HOME=@MOZILLA_HOME@ exec -a 'blam' mono @prefix@/lib/blam/blam.exe $@
++MOZILLA_HOME=@MOZILLA_HOME@ exec mono @prefix@/lib/blam/blam.exe $@
diff --git a/net/blam/files/patch-src-Application.cs b/net/blam/files/patch-src-Application.cs
new file mode 100644
index 000000000000..bfde3504220a
--- /dev/null
+++ b/net/blam/files/patch-src-Application.cs
@@ -0,0 +1,25 @@
+--- src/Application.cs.orig Sun Apr 15 16:59:40 2007
++++ src/Application.cs Sun Apr 15 17:00:45 2007
+@@ -23,8 +23,7 @@
+ public class Application : Program {
+
+ [DllImport("libc")]
+- private static extern int prctl(int option, byte [] arg2, ulong arg3,
+- ulong arg4, ulong arg5);
++ private static extern void setproctitle(byte [] fmt, byte [] str_arg);
+
+ public static Application TheApp;
+
+@@ -723,11 +722,7 @@
+
+ public static void SetProcessName(string name)
+ {
+- if(prctl(15 /* PR_SET_NAME */, Encoding.ASCII.GetBytes(name + "\0"),
+- 0, 0, 0) != 0) {
+- throw new ApplicationException("Error setting process name: " +
+- Mono.Unix.Native.Stdlib.GetLastError());
+- }
++ setproctitle(Encoding.ASCII.GetBytes("%s\0"), Encoding.ASCII.GetBytes(name + "\0"));
+ }
+
+ public static void Main(string[] args)
diff --git a/net/blam/pkg-descr b/net/blam/pkg-descr
index b189b9d18360..2641a920cbaf 100644
--- a/net/blam/pkg-descr
+++ b/net/blam/pkg-descr
@@ -10,4 +10,4 @@ Among the features are:
* Print the news entries you like
* Automatically update the feeds at regular intervals
-WWW: http://www.imendio.com/projects/blam/
+WWW: http://www.cmartin.tk/blam.html
diff --git a/net/blam/pkg-plist b/net/blam/pkg-plist
index 21167ff95a44..ecfd7bf0326f 100644
--- a/net/blam/pkg-plist
+++ b/net/blam/pkg-plist
@@ -8,12 +8,29 @@ lib/blam/libblam.la
lib/blam/libblam.so
lib/blam/libblam.so.0
share/gnome/applications/blam.desktop
+share/gnome/blam/themes/planet/theme.html
+share/gnome/blam/themes/planet/planet.css
+share/gnome/blam/themes/planet/bubble-top.png
+share/gnome/blam/themes/planet/bubble-top-right.png
+share/gnome/blam/themes/planet/bubble-top-left.png
+share/gnome/blam/themes/planet/bubble-right.png
+share/gnome/blam/themes/planet/bubble-nipple.png
+share/gnome/blam/themes/planet/bubble-left.png
+share/gnome/blam/themes/planet/bubble-bottom.png
+share/gnome/blam/themes/planet/bubble-bottom-right.png
+share/gnome/blam/themes/planet/bubble-bottom-left.png
+share/gnome/blam/themes/pimped/theme.html
+share/gnome/blam/themes/pimped/pimped.css
+share/gnome/blam/themes/pimped/news.png
+share/gnome/blam/themes/pimped/blam.png
+share/gnome/blam/themes/blam/theme.html
+share/gnome/blam/themes/blam/blam-box-top-right.png
+share/gnome/blam/themes/blam/blam-box-top-left.png
+share/gnome/blam/themes/blam/blam-box-pad.png
+share/gnome/blam/themes/blam/blam-box-bottom-right.png
+share/gnome/blam/themes/blam/blam-box-bottom-left.png
+share/gnome/blam/themes/akregator/theme.html
share/gnome/blam/collection.xml
-share/gnome/blam/images/blam-box-bottom-left.png
-share/gnome/blam/images/blam-box-bottom-right.png
-share/gnome/blam/images/blam-box-pad.png
-share/gnome/blam/images/blam-box-top-left.png
-share/gnome/blam/images/blam-box-top-right.png
share/gnome/pixmaps/blam.png
share/locale/bg/LC_MESSAGES/blam.mo
share/locale/bs/LC_MESSAGES/blam.mo
@@ -36,24 +53,39 @@ share/locale/hu/LC_MESSAGES/blam.mo
share/locale/it/LC_MESSAGES/blam.mo
share/locale/ja/LC_MESSAGES/blam.mo
share/locale/lt/LC_MESSAGES/blam.mo
+share/locale/lv/LC_MESSAGES/blam.mo
share/locale/nb/LC_MESSAGES/blam.mo
+share/locale/ne/LC_MESSAGES/blam.mo
share/locale/nl/LC_MESSAGES/blam.mo
-share/locale/no/LC_MESSAGES/blam.mo
share/locale/pa/LC_MESSAGES/blam.mo
share/locale/pl/LC_MESSAGES/blam.mo
share/locale/pt/LC_MESSAGES/blam.mo
share/locale/pt_BR/LC_MESSAGES/blam.mo
share/locale/rw/LC_MESSAGES/blam.mo
+share/locale/ru/LC_MESSAGES/blam.mo
share/locale/sq/LC_MESSAGES/blam.mo
share/locale/sr/LC_MESSAGES/blam.mo
share/locale/sr@Latn/LC_MESSAGES/blam.mo
share/locale/sv/LC_MESSAGES/blam.mo
+share/locale/sk/LC_MESSAGES/blam.mo
share/locale/tr/LC_MESSAGES/blam.mo
share/locale/uk/LC_MESSAGES/blam.mo
+share/locale/vi/LC_MESSAGES/blam.mo
share/locale/zh_CN/LC_MESSAGES/blam.mo
+share/locale/zh_HK/LC_MESSAGES/blam.mo
share/locale/zh_TW/LC_MESSAGES/blam.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
-@dirrm share/gnome/blam/images
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrm share/gnome/blam/themes/planet
+@dirrm share/gnome/blam/themes/pimped
+@dirrm share/gnome/blam/themes/blam
+@dirrm share/gnome/blam/themes/akregator
+@dirrm share/gnome/blam/themes
@dirrm share/gnome/blam
@dirrm lib/blam