aboutsummaryrefslogtreecommitdiff
path: root/net/blam
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-11-26 06:08:58 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-11-26 06:08:58 +0000
commit06ea4d503d7c6079a8e7f86364b6cf2bdf304170 (patch)
tree07b1b761a5ec33485aab9c6d90db9917d6ab1e28 /net/blam
parentc424937ebe3fc21946c5bb2f9c3818aec3841f71 (diff)
downloadports-06ea4d503d7c6079a8e7f86364b6cf2bdf304170.tar.gz
ports-06ea4d503d7c6079a8e7f86364b6cf2bdf304170.zip
Notes
Diffstat (limited to 'net/blam')
-rw-r--r--net/blam/Makefile32
-rw-r--r--net/blam/distinfo2
-rw-r--r--net/blam/pkg-descr13
-rw-r--r--net/blam/pkg-plist47
4 files changed, 94 insertions, 0 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
new file mode 100644
index 000000000000..7a2f79d189de
--- /dev/null
+++ b/net/blam/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: blam
+# Date created: 20040812
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blam
+PORTVERSION= 1.6.0
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.6
+
+MAINTAINER= tmclaugh@sdf.lonestar.org
+COMMENT= Mono based RSS feed reader
+
+BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp \
+ ${X11BASE}/libdata/pkgconfig/gecko-sharp.pc:${PORTSDIR}/www/gecko-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= blam.schemas
+
+.include <bsd.port.mk>
diff --git a/net/blam/distinfo b/net/blam/distinfo
new file mode 100644
index 000000000000..54509c59073a
--- /dev/null
+++ b/net/blam/distinfo
@@ -0,0 +1,2 @@
+MD5 (blam-1.6.0.tar.bz2) = 1f8deecd3846aa738d872c7bcda2507c
+SIZE (blam-1.6.0.tar.bz2) = 418117
diff --git a/net/blam/pkg-descr b/net/blam/pkg-descr
new file mode 100644
index 000000000000..864605232765
--- /dev/null
+++ b/net/blam/pkg-descr
@@ -0,0 +1,13 @@
+Blam is a tool that helps you keep track of the growing number of news
+feeds distributed as RSS. Blam lets you subscribe to any number of feeds
+and provides an easy to use and clean interface to stay up to date. It
+is Written in C# and uses Mono, GTK#, and RSS.NET.
+
+Among the features are:
+
+* Support for RSS and RDF feeds
+* Very easy to use interface
+* Print the news entries you like
+* Automatically update the feeds at regular intervals
+
+WWW: http://www.imendio.com/projects/blam/
diff --git a/net/blam/pkg-plist b/net/blam/pkg-plist
new file mode 100644
index 000000000000..9a213593c435
--- /dev/null
+++ b/net/blam/pkg-plist
@@ -0,0 +1,47 @@
+bin/blam
+lib/blam/blam.exe
+lib/blam/libblam.a
+lib/blam/libblam.so
+lib/blam/libblam.so.0
+lib/blam/rss.dll
+share/gnome/applications/blam.desktop
+share/gnome/blam/collection.xml
+share/gnome/blam/images/blam-box-bottom-left.png
+share/gnome/blam/images/blam-box-bottom-right.png
+share/gnome/blam/images/blam-box-pad.png
+share/gnome/blam/images/blam-box-top-left.png
+share/gnome/blam/images/blam-box-top-right.png
+share/gnome/pixmaps/blam.png
+share/locale/bg/LC_MESSAGES/blam.mo
+share/locale/bs/LC_MESSAGES/blam.mo
+share/locale/ca/LC_MESSAGES/blam.mo
+share/locale/cs/LC_MESSAGES/blam.mo
+share/locale/da/LC_MESSAGES/blam.mo
+share/locale/de/LC_MESSAGES/blam.mo
+share/locale/el/LC_MESSAGES/blam.mo
+share/locale/en_CA/LC_MESSAGES/blam.mo
+share/locale/en_GB/LC_MESSAGES/blam.mo
+share/locale/es/LC_MESSAGES/blam.mo
+share/locale/eu/LC_MESSAGES/blam.mo
+share/locale/fi/LC_MESSAGES/blam.mo
+share/locale/fr/LC_MESSAGES/blam.mo
+share/locale/ga/LC_MESSAGES/blam.mo
+share/locale/gu/LC_MESSAGES/blam.mo
+share/locale/he/LC_MESSAGES/blam.mo
+share/locale/hr/LC_MESSAGES/blam.mo
+share/locale/nb/LC_MESSAGES/blam.mo
+share/locale/nl/LC_MESSAGES/blam.mo
+share/locale/no/LC_MESSAGES/blam.mo
+share/locale/pa/LC_MESSAGES/blam.mo
+share/locale/pt/LC_MESSAGES/blam.mo
+share/locale/pt_BR/LC_MESSAGES/blam.mo
+share/locale/sq/LC_MESSAGES/blam.mo
+share/locale/sr/LC_MESSAGES/blam.mo
+share/locale/sr@Latn/LC_MESSAGES/blam.mo
+share/locale/sv/LC_MESSAGES/blam.mo
+share/locale/tr/LC_MESSAGES/blam.mo
+share/locale/uk/LC_MESSAGES/blam.mo
+share/locale/zh_CN/LC_MESSAGES/blam.mo
+@dirrm share/gnome/blam/images
+@dirrm share/gnome/blam
+@dirrm lib/blam