aboutsummaryrefslogtreecommitdiff
path: root/net/bnbt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-30 21:36:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-30 21:36:28 +0000
commitfbab09fee302574e578e4f0d1b6082cdae4defb4 (patch)
tree2e89197b88b8a883c56aef7a5d0d89dc5d374850 /net/bnbt
parent94554fea09e5a189b46884a7cecc30c3eae0292f (diff)
downloadports-fbab09fee302574e578e4f0d1b6082cdae4defb4.tar.gz
ports-fbab09fee302574e578e4f0d1b6082cdae4defb4.zip
Notes
Diffstat (limited to 'net/bnbt')
-rw-r--r--net/bnbt/Makefile60
-rw-r--r--net/bnbt/distinfo3
-rw-r--r--net/bnbt/files/bnbt.sh.in38
-rw-r--r--net/bnbt/files/patch-client.cpp17
-rw-r--r--net/bnbt/files/patch-config.cpp15
-rw-r--r--net/bnbt/files/patch-server.cpp11
-rw-r--r--net/bnbt/files/pkg-message.in9
-rw-r--r--net/bnbt/pkg-descr10
-rw-r--r--net/bnbt/pkg-plist4
9 files changed, 0 insertions, 167 deletions
diff --git a/net/bnbt/Makefile b/net/bnbt/Makefile
deleted file mode 100644
index d96e838c53b5..000000000000
--- a/net/bnbt/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# New ports collection makefile for: bnbt
-# Date created: Jan 31 2004
-# Whom: Florent Thoumie <flz@xbsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= bnbt
-PORTVERSION= 8.1b3
-PORTREVISION= 1
-CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= bnbt
-DISTNAME= bnbt81b-3-sf
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT= A C++ BitTorrent Tracker
-
-USE_ZIP= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}/src
-
-USE_GMAKE= yes
-USE_REINPLACE= yes
-
-SUB_FILES= pkg-message
-USE_RC_SUBR= bnbt.sh
-
-PORTDOCS= footer.html header.html lesser.txt readme.txt users.txt
-
-.if defined(WITH_MYSQL)
-ALL_TARGET= bnbtmysql
-PKGNAMESUFFIX= -mysql
-USE_MYSQL= yes
-.else
-ALL_TARGET= bnbt
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-O2|${CFLAGS} -I${PREFIX}/include| ; \
- s|LFLAGS =|LFLAGS = -L${PREFIX}/lib/mysql|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|\([a-z]*\.bnbt\)|${PREFIX}/etc/${PORTNAME}/\1|' \
- ${WRKSRC}/config.cpp
- @${REINPLACE_CMD} -e 's|bnbt.cfg|${PREFIX}/etc/${PORTNAME}/bnbt.cfg|' \
- ${WRKSRC}/config.h ${WRKSRC}/config.cpp ${WRKSRC}/tracker.cpp
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${ALL_TARGET} ${PREFIX}/bin/bnbt
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/$i ${DOCSDIR}
-.endfor
-
-post-install:
- @${MKDIR} /var/log/${PORTNAME}
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/net/bnbt/distinfo b/net/bnbt/distinfo
deleted file mode 100644
index f9998726064f..000000000000
--- a/net/bnbt/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (bnbt81b-3-sf.zip) = 2935ffe0f51090a79d5bd76566af3b2b
-SHA256 (bnbt81b-3-sf.zip) = d9d431f86b5abbf89907c567c2ca7bf3020fe86c2585645c2888d51bcc5c842f
-SIZE (bnbt81b-3-sf.zip) = 741026
diff --git a/net/bnbt/files/bnbt.sh.in b/net/bnbt/files/bnbt.sh.in
deleted file mode 100644
index d9f67bb8fee6..000000000000
--- a/net/bnbt/files/bnbt.sh.in
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: bnbt
-# REQUIRE: LOGIN abi
-# BEFORE: securelevel
-# KEYWORD: FreeBSD shutdown
-
-# Add the following line to /etc/rc.conf to enable `bnbt':
-#
-#bnbt_enable="YES"
-#
-# See bnbt(1) for bnbt_flags
-#
-
-. "%%RC_SUBR%%"
-
-name="bnbt"
-rcvar=`set_rcvar`
-
-# path to your executable, might be libxec, bin, sbin, ...
-command="%%PREFIX%%/bin/$name"
-
-# extra required arguments
-command_args="&"
-
-# you can check for required_dirs and required_vars too, see rc.subr(8)
-#
-required_dirs="/var/log/$name"
-
-# read settings, set default values
-load_rc_config "$name"
-: ${bnbt_enable="NO"}
-: ${bnbt_flags=""}
-
-run_rc_command "$1"
diff --git a/net/bnbt/files/patch-client.cpp b/net/bnbt/files/patch-client.cpp
deleted file mode 100644
index da622fab52d6..000000000000
--- a/net/bnbt/files/patch-client.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- client.cpp Wed Sep 29 21:38:32 2004
-+++ client.cpp.new Sat Oct 23 15:40:05 2004
-@@ -19,6 +19,7 @@
- *
- ***/
-
-+#include <sys/time.h>
- #include <fcntl.h>
-
- #include "bnbt.h"
-@@ -639,4 +640,4 @@
- rsp.strContent.reserve( 1024 );
- rsp.bCompressOK = true;
- m_iLast = GetTime( );
--}
-\ No newline at end of file
-+}
diff --git a/net/bnbt/files/patch-config.cpp b/net/bnbt/files/patch-config.cpp
deleted file mode 100644
index f9a3636c1bb0..000000000000
--- a/net/bnbt/files/patch-config.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- config.cpp Fri Sep 24 20:01:58 2004
-+++ config.cpp.new Sat Oct 23 14:42:45 2004
-@@ -147,10 +147,10 @@
- CFG_SetString( "bnbt_realm", "BNBT" );
-
- if( CFG_GetString( "bnbt_error_log_dir", string( ) ).empty( ) )
-- CFG_SetString( "bnbt_error_log_dir", string( ) );
-+ CFG_SetString( "bnbt_error_log_dir", "/var/log/bnbt/" );
-
- if( CFG_GetString( "bnbt_access_log_dir", string( ) ).empty( ) )
-- CFG_SetString( "bnbt_access_log_dir", string( ) );
-+ CFG_SetString( "bnbt_access_log_dir", "/var/log/bnbt/" );
-
- if( CFG_GetInt( "bnbt_flush_interval", 0 ) < 1 )
- CFG_SetInt( "bnbt_flush_interval", 100 );
diff --git a/net/bnbt/files/patch-server.cpp b/net/bnbt/files/patch-server.cpp
deleted file mode 100644
index 856ac603c773..000000000000
--- a/net/bnbt/files/patch-server.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- server.cpp Fri Sep 10 14:43:24 2004
-+++ server.cpp.new Sat Oct 23 15:40:21 2004
-@@ -19,6 +19,8 @@
- *
- ***/
-
-+#include <sys/time.h>
-+
- #include "bnbt.h"
- #include "client.h"
- #include "config.h"
diff --git a/net/bnbt/files/pkg-message.in b/net/bnbt/files/pkg-message.in
deleted file mode 100644
index 5543af77c8df..000000000000
--- a/net/bnbt/files/pkg-message.in
+++ /dev/null
@@ -1,9 +0,0 @@
-************************************************************
-Bnbt has been successfully installed.
-
-In order to run bnbt, add the following lines to /etc/rc.conf:
- bnbt_enable="YES"
-
-Then start the server with %%PREFIX%%/etc/rc.d/bnbt.sh start
-or reboot.
-************************************************************
diff --git a/net/bnbt/pkg-descr b/net/bnbt/pkg-descr
deleted file mode 100644
index dd0656bdd952..000000000000
--- a/net/bnbt/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-BNBT was written by Trevor Hogan. BNBT is a complete port of the
-original Python BitTorrent tracker to C++ using the STL for data storage
-and basic network sockets for network communication. BNBT is fast,
-efficient, customizable, easy to use, powerful, and portable. BNBT is
-covered under the GNU Lesser General Public License (LGPL).
-
-WWW: http://bnbt.sourceforge.net/
-
-- Florent Thoumie
-flz@xbsd.org
diff --git a/net/bnbt/pkg-plist b/net/bnbt/pkg-plist
deleted file mode 100644
index 7d52743957b0..000000000000
--- a/net/bnbt/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/bnbt
-@exec mkdir -p /var/log/bnbt
-@exec mkdir -p %D/etc/bnbt
-@dirrmtry etc/bnbt