aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-02-15 15:01:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-02-15 15:01:18 +0000
commit8e0f798453cf1bed5c2fb919f9e2e304e53a294c (patch)
tree79e5030d6904e0f4bfffb136430b740feb90ecca /net/boinc-client/files
parentd41eabde85c1ce69cd43513e35cf285598955433 (diff)
Notes
Diffstat (limited to 'net/boinc-client/files')
-rw-r--r--net/boinc-client/files/patch-CPUID66
-rw-r--r--net/boinc-client/files/patch-crashes12
-rw-r--r--net/boinc-client/files/patch-headers_for_seti11
-rw-r--r--net/boinc-client/files/patch-prefer_new_libs_over_installed22
4 files changed, 78 insertions, 33 deletions
diff --git a/net/boinc-client/files/patch-CPUID b/net/boinc-client/files/patch-CPUID
new file mode 100644
index 000000000000..a3a54da26b6e
--- /dev/null
+++ b/net/boinc-client/files/patch-CPUID
@@ -0,0 +1,66 @@
+--- client/hostinfo_unix.C.orig Tue Jan 23 18:24:42 2007
++++ client/hostinfo_unix.C Wed Feb 14 23:59:49 2007
+@@ -308,6 +308,50 @@
+
+ #endif // linux
+
++#ifdef __FreeBSD__
++#if defined(__i386__) || defined(__amd64__)
++#include <sys/types.h>
++#include <sys/cdefs.h>
++#include <machine/cpufunc.h>
++
++void use_cpuid(HOST_INFO& host) {
++ u_int p[4];
++ int hasMMX, hasSSE, hasSSE2, hasSSE3, has3DNow, has3DNowExt = 0;
++ char capabilities[256];
++
++ do_cpuid(0x0, p);
++
++ if (p[0] >= 0x1) {
++
++ do_cpuid(0x1, p);
++
++ hasMMX = (p[3] & (1 << 23 )) >> 23; // 0x0800000
++ hasSSE = (p[3] & (1 << 25 )) >> 25; // 0x2000000
++ hasSSE2 = (p[3] & (1 << 26 )) >> 26; // 0x4000000
++ hasSSE3 = (p[2] & (1 << 0 )) >> 0;
++ }
++
++ do_cpuid(0x80000000, p);
++ if (p[0]>=0x80000001) {
++ do_cpuid(0x80000001, p);
++ hasMMX |= (p[3] & (1 << 23 )) >> 23; // 0x0800000
++ has3DNow = (p[3] & (1 << 31 )) >> 31; //0x80000000
++ has3DNowExt = (p[3] & (1 << 30 )) >> 30;
++ }
++
++ capabilities[0] = '\0';
++ if (hasSSE) strncat(capabilities, "sse ", 4);
++ if (hasSSE2) strncat(capabilities, "sse2 ", 5);
++ if (hasSSE3) strncat(capabilities, "sse3 ", 5);
++ if (has3DNow) strncat(capabilities, "3dnow ", 6);
++ if (has3DNowExt) strncat(capabilities, "3dnowext ", 9);
++ if (hasMMX) strncat(capabilities, "mmx ", 4);
++ strip_whitespace(capabilities);
++ snprintf(host.p_model, sizeof(host.p_model), "%s [] [%s]", host.p_model, capabilities);
++}
++#endif
++#endif
++
+ // get all relevant host information
+ //
+ int HOST_INFO::get_host_info() {
+@@ -356,6 +400,12 @@
+ strncpy( p_model, "Alpha ", sizeof( p_model));
+ strncat( p_model, cpu_type_name, (sizeof( p_model)- strlen( p_model)- 1));
+ #endif
++#endif
++#endif
++
++#if defined(__FreeBSD__)
++#if defined(__i386__) || defined(__amd64__)
++ use_cpuid(*this);
+ #endif
+ #endif
+
diff --git a/net/boinc-client/files/patch-crashes b/net/boinc-client/files/patch-crashes
new file mode 100644
index 000000000000..43d20915a506
--- /dev/null
+++ b/net/boinc-client/files/patch-crashes
@@ -0,0 +1,12 @@
+--- clientgui/BOINCGUIApp.cpp.orig Mon Jan 22 14:19:20 2007
++++ clientgui/BOINCGUIApp.cpp Wed Feb 14 23:50:55 2007
+@@ -81,9 +81,7 @@
+ m_pSkinManager = NULL;
+ m_pFrame = NULL;
+ m_pDocument = NULL;
+-#if defined(__WXMSW__) || defined(__WXMAC__)
+ m_pTaskBarIcon = NULL;
+-#endif
+ #ifdef __WXMAC__
+ m_pMacSystemMenu = NULL;
+ #endif
diff --git a/net/boinc-client/files/patch-headers_for_seti b/net/boinc-client/files/patch-headers_for_seti
deleted file mode 100644
index 6b94dda517ee..000000000000
--- a/net/boinc-client/files/patch-headers_for_seti
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Tue Mar 7 15:06:14 2006
-+++ lib/Makefile.in Sat Mar 11 20:15:04 2006
-@@ -403,7 +403,7 @@
- proxy_info.h \
- util.h \
- msg_log.h \
-- crypt.h
-+ crypt.h std_fixes.h error_numbers.h
-
- md5_test_SOURCES = md5_test.C md5.c md5_file.C
- shmem_test_SOURCES = shmem_test.C shmem.C
diff --git a/net/boinc-client/files/patch-prefer_new_libs_over_installed b/net/boinc-client/files/patch-prefer_new_libs_over_installed
deleted file mode 100644
index 6e7f8b1be1a5..000000000000
--- a/net/boinc-client/files/patch-prefer_new_libs_over_installed
+++ /dev/null
@@ -1,22 +0,0 @@
---- client/Makefile.in.orig Tue Mar 7 15:06:10 2006
-+++ client/Makefile.in Wed Mar 15 13:56:33 2006
-@@ -336,7 +336,7 @@
-
- AM_CFLAGS = $(AM_CPPFLAGS)
- AM_CXXFLAGS = $(AM_CPPFLAGS)
--AM_LDFLAGS =
-+AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/client
-
- # dependencies to make sure libs gets compiled before
- # programs linking to them:
---- clientgui/Makefile.in.orig Tue Mar 7 15:06:12 2006
-+++ clientgui/Makefile.in Wed Mar 15 14:27:36 2006
-@@ -354,7 +354,7 @@
-
- AM_CFLAGS = $(AM_CPPFLAGS)
- AM_CXXFLAGS = $(AM_CPPFLAGS)
--AM_LDFLAGS =
-+AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/client
-
- # dependencies to make sure libs gets compiled before
- # programs linking to them: