aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-29 18:08:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-29 18:08:17 +0000
commite8dc9c80da040cac241b2910de0ef4d8a69e342a (patch)
tree6db44c0525c10c54d0690099e6c3c64023045278 /net/boinc-client
parent088dd9a465f05aed60b45b6a46fabe3ecbe4fe11 (diff)
downloadports-e8dc9c80da040cac241b2910de0ef4d8a69e342a.tar.gz
ports-e8dc9c80da040cac241b2910de0ef4d8a69e342a.zip
Notes
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile3
-rw-r--r--net/boinc-client/distinfo6
-rw-r--r--net/boinc-client/files/patch-CPUID44
-rw-r--r--net/boinc-client/files/patch-lib_util.C10
-rw-r--r--net/boinc-client/pkg-plist2
5 files changed, 46 insertions, 19 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index cc6f05986c06..7e2e18c4ecd4 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= boinc-client
-PORTVERSION= 5.8.17
+PORTVERSION= 5.10.32
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
@@ -66,6 +66,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gui_rpc_auth.cfg|${BOINC_HOME}/gui_rpc_auth.cfg|g' \
${WRKSRC}/client/file_names.h ${WRKSRC}/lib/boinc_cmd.C \
${WRKSRC}/clientgui/MainDocument.cpp
+ @${REINPLACE_CMD} -e 's|../curl/ca-bundle.crt||' ${WRKSRC}/client/Makefile.in
@${REINPLACE_CMD} -e 's|ca-bundle.crt|${LOCALBASE}/share/curl/curl-ca-bundle.crt|' ${WRKSRC}/client/http_curl.C
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/clientgui/stdwx.h
diff --git a/net/boinc-client/distinfo b/net/boinc-client/distinfo
index ffae7a8989b3..2cd7369d488b 100644
--- a/net/boinc-client/distinfo
+++ b/net/boinc-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (boinc-client-5.8.17.tar.bz2) = 7211c99f46412aefba591991eb3ca617
-SHA256 (boinc-client-5.8.17.tar.bz2) = 082754617ea0b5e974808ded7166ca34b7f5c3d90ab415cba5fe4335162bba77
-SIZE (boinc-client-5.8.17.tar.bz2) = 3417355
+MD5 (boinc-client-5.10.32.tar.bz2) = 0718535f78c4097b8e3fb740b7d423d3
+SHA256 (boinc-client-5.10.32.tar.bz2) = 7d3570a0de643b9623731eea45df5601e046504865946c033fc08e2273940c60
+SIZE (boinc-client-5.10.32.tar.bz2) = 4022383
diff --git a/net/boinc-client/files/patch-CPUID b/net/boinc-client/files/patch-CPUID
index a3a54da26b6e..c97768e4b0c0 100644
--- a/net/boinc-client/files/patch-CPUID
+++ b/net/boinc-client/files/patch-CPUID
@@ -1,7 +1,7 @@
---- client/hostinfo_unix.C.orig Tue Jan 23 18:24:42 2007
-+++ client/hostinfo_unix.C Wed Feb 14 23:59:49 2007
-@@ -308,6 +308,50 @@
-
+--- client/hostinfo_unix.C.orig 2007-12-28 19:59:40.000000000 +0100
++++ client/hostinfo_unix.C 2007-12-28 20:36:26.000000000 +0100
+@@ -451,6 +451,50 @@
+ }
#endif // linux
+#ifdef __FreeBSD__
@@ -48,19 +48,33 @@
+#endif
+#endif
+
- // get all relevant host information
- //
- int HOST_INFO::get_host_info() {
-@@ -356,6 +400,12 @@
- strncpy( p_model, "Alpha ", sizeof( p_model));
- strncat( p_model, cpu_type_name, (sizeof( p_model)- strlen( p_model)- 1));
+ #ifdef __APPLE__
+ static void get_cpu_info_maxosx(HOST_INFO& host) {
+ int p_model_size = sizeof(host.p_model);
+@@ -573,6 +617,12 @@
+ #error Need to specify a method to get p_vendor, p_model
#endif
-+#endif
-+#endif
-+
+
+#if defined(__FreeBSD__)
+#if defined(__i386__) || defined(__amd64__)
+ use_cpuid(*this);
- #endif
- #endif
++#endif
++#endif
++
+ ///////////// p_ncpus /////////////////
+ // sysconf not working on OS2
+@@ -639,6 +689,13 @@
+ int mem_size;
+ getsysinfo( GSI_PHYSMEM, (caddr_t) &mem_size, sizeof( mem_size));
+ m_nbytes = 1024.* (double)mem_size;
++#elif defined(__FreeBSD__)
++ unsigned int mem_size;
++ mib[0] = CTL_HW;
++ mib[1] = HW_PHYSMEM;
++ len = sizeof(mem_size);
++ sysctl(mib, 2, &mem_size, &len, NULL, 0);
++ m_nbytes = mem_size;
+ #else
+ #error Need to specify a method to get memory size
+ #endif
diff --git a/net/boinc-client/files/patch-lib_util.C b/net/boinc-client/files/patch-lib_util.C
new file mode 100644
index 000000000000..bbe80a0a25b2
--- /dev/null
+++ b/net/boinc-client/files/patch-lib_util.C
@@ -0,0 +1,10 @@
+--- lib/util.C.orig 2007-12-28 19:58:32.000000000 +0100
++++ lib/util.C 2007-12-28 20:24:07.000000000 +0100
+@@ -41,6 +41,7 @@
+ #include <fstream>
+ #include <cctype>
+ #include <sys/types.h>
++#include <signal.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <fcntl.h>
diff --git a/net/boinc-client/pkg-plist b/net/boinc-client/pkg-plist
index f6aea7f65f60..e052f8eb1e33 100644
--- a/net/boinc-client/pkg-plist
+++ b/net/boinc-client/pkg-plist
@@ -26,6 +26,7 @@ include/BOINC/parse.h
include/BOINC/prefs.h
include/BOINC/proxy_info.h
include/BOINC/std_fixes.h
+include/BOINC/str_util.h
include/BOINC/version.h
include/BOINC/util.h
lib/libboinc.a
@@ -33,6 +34,7 @@ lib/libboinc_api.a
%%BOINC_GUI%%lib/libboinc_graphics_api.a
%%BOINC_GUI%%lib/libboinc_graphics_impl.a
%%BOINC_GUI%%lib/libboinc_graphics_lib.a
+%%BOINC_GUI%%lib/libboinc_graphics2.a
lib/libboinc_zip.a
@dirrm include/BOINC
@unexec if [ -d %%BOINC_HOME%% ]; then echo "If you are deinstalling boinc completely, remove the %%BOINC_HOME%% directory."; fi