aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-11-26 16:21:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-11-26 16:21:44 +0000
commitc92f476da973518994c16b1eb8afdc16ba5d3804 (patch)
treeb4347d93f027ae51718682cf17e86fca1c866997 /net/boinc-client
parent7ee7ff8b985834a4e9763413f2ed7087be0f91d4 (diff)
downloadports-c92f476da973518994c16b1eb8afdc16ba5d3804.tar.gz
ports-c92f476da973518994c16b1eb8afdc16ba5d3804.zip
Notes
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index d0b62ac2de20..bbea8841ed2e 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -32,7 +32,10 @@ SUB_LIST= BOINC_HOME="${BOINC_HOME}" BOINC_USER="${BOINC_USER}" BOINC_GROUP="${B
USE_RC_SUBR= boinc.sh
CONFIGURE_ARGS= --disable-server
-CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include CXXFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include -O3" CFLAGS="${CFLAGS} -O3"
+CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS:= ${CXXFLAGS:N-O*:N-f*} -O3
+CFLAGS:= ${CFLAGS:N-O*:N-f*} -O3
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGSS="${CXXFLAGS}" CFLAGS="${CFLAGS}"
OPTIONS= X11 "Build Boinc Manager GUI" on
@@ -40,6 +43,7 @@ OPTIONS= X11 "Build Boinc Manager GUI" on
.if !defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
+CPPFLAGS+= -I${X11BASE}/include
.else
CONFIGURE_ARGS+= --with-wx-config=false
.endif