aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-02-15 15:01:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-02-15 15:01:18 +0000
commit8e0f798453cf1bed5c2fb919f9e2e304e53a294c (patch)
tree79e5030d6904e0f4bfffb136430b740feb90ecca /net/boinc-client
parentd41eabde85c1ce69cd43513e35cf285598955433 (diff)
downloadports-8e0f798453cf1bed5c2fb919f9e2e304e53a294c.tar.gz
ports-8e0f798453cf1bed5c2fb919f9e2e304e53a294c.zip
Notes
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile14
-rw-r--r--net/boinc-client/distinfo6
-rw-r--r--net/boinc-client/files/patch-CPUID66
-rw-r--r--net/boinc-client/files/patch-crashes12
-rw-r--r--net/boinc-client/files/patch-headers_for_seti11
-rw-r--r--net/boinc-client/files/patch-prefer_new_libs_over_installed22
-rw-r--r--net/boinc-client/pkg-descr2
-rw-r--r--net/boinc-client/pkg-plist7
8 files changed, 97 insertions, 43 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index f505c2cfb075..78ecaa7eeb89 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= boinc-client
-PORTVERSION= 5.4.9
-PORTREVISION= 1
+PORTVERSION= 5.8.11
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.oook.cz/bsd/distfiles/
MASTER_SITE_SUBDIR= pav
MAINTAINER= pav@FreeBSD.org
@@ -44,7 +44,7 @@ OPTIONS= X11 "Build Boinc Manager GUI" on
.if !defined(WITHOUT_X11)
USE_XLIB= yes
-USE_WX= 2.6
+USE_WX= 2.6+
WX_CONF_ARGS= absolute
CPPFLAGS+= -I${X11BASE}/include
.else
@@ -71,8 +71,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|gui_rpc_auth.cfg|${BOINC_HOME}/gui_rpc_auth.cfg|g' \
${WRKSRC}/client/file_names.h ${WRKSRC}/lib/boinc_cmd.C \
${WRKSRC}/clientgui/MainDocument.cpp
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/clientgui/stdwx.h
+
+# kill -O3 from clientgui build, it triggers some optimization bug and segfaults on runtime with -O3
+post-configure:
+ @${REINPLACE_CMD} -e 's|-O3 ||' ${WRKSRC}/clientgui/Makefile
post-install:
+ ${INSTALL_DATA} ${WRKSRC}/version.h ${PREFIX}/include/BOINC
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/net/boinc-client/distinfo b/net/boinc-client/distinfo
index 0ee690a0a1f2..271e8d91a587 100644
--- a/net/boinc-client/distinfo
+++ b/net/boinc-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (boinc-client-5.4.9.tar.bz2) = 161d1c2397e126a92fd5878d6664d4df
-SHA256 (boinc-client-5.4.9.tar.bz2) = 1b0d1d364fca1690171e7d489ffc6e13c3f79aad01478a07ca17c5d896334e40
-SIZE (boinc-client-5.4.9.tar.bz2) = 2512800
+MD5 (boinc-client-5.8.11.tar.bz2) = 921dec0902bacef6f8775dca3b4bfc24
+SHA256 (boinc-client-5.8.11.tar.bz2) = 018462e9df861ed38c394e27d5550220bc49aba88e9784d1e3b9e7d1df98aef9
+SIZE (boinc-client-5.8.11.tar.bz2) = 3399856
diff --git a/net/boinc-client/files/patch-CPUID b/net/boinc-client/files/patch-CPUID
new file mode 100644
index 000000000000..a3a54da26b6e
--- /dev/null
+++ b/net/boinc-client/files/patch-CPUID
@@ -0,0 +1,66 @@
+--- client/hostinfo_unix.C.orig Tue Jan 23 18:24:42 2007
++++ client/hostinfo_unix.C Wed Feb 14 23:59:49 2007
+@@ -308,6 +308,50 @@
+
+ #endif // linux
+
++#ifdef __FreeBSD__
++#if defined(__i386__) || defined(__amd64__)
++#include <sys/types.h>
++#include <sys/cdefs.h>
++#include <machine/cpufunc.h>
++
++void use_cpuid(HOST_INFO& host) {
++ u_int p[4];
++ int hasMMX, hasSSE, hasSSE2, hasSSE3, has3DNow, has3DNowExt = 0;
++ char capabilities[256];
++
++ do_cpuid(0x0, p);
++
++ if (p[0] >= 0x1) {
++
++ do_cpuid(0x1, p);
++
++ hasMMX = (p[3] & (1 << 23 )) >> 23; // 0x0800000
++ hasSSE = (p[3] & (1 << 25 )) >> 25; // 0x2000000
++ hasSSE2 = (p[3] & (1 << 26 )) >> 26; // 0x4000000
++ hasSSE3 = (p[2] & (1 << 0 )) >> 0;
++ }
++
++ do_cpuid(0x80000000, p);
++ if (p[0]>=0x80000001) {
++ do_cpuid(0x80000001, p);
++ hasMMX |= (p[3] & (1 << 23 )) >> 23; // 0x0800000
++ has3DNow = (p[3] & (1 << 31 )) >> 31; //0x80000000
++ has3DNowExt = (p[3] & (1 << 30 )) >> 30;
++ }
++
++ capabilities[0] = '\0';
++ if (hasSSE) strncat(capabilities, "sse ", 4);
++ if (hasSSE2) strncat(capabilities, "sse2 ", 5);
++ if (hasSSE3) strncat(capabilities, "sse3 ", 5);
++ if (has3DNow) strncat(capabilities, "3dnow ", 6);
++ if (has3DNowExt) strncat(capabilities, "3dnowext ", 9);
++ if (hasMMX) strncat(capabilities, "mmx ", 4);
++ strip_whitespace(capabilities);
++ snprintf(host.p_model, sizeof(host.p_model), "%s [] [%s]", host.p_model, capabilities);
++}
++#endif
++#endif
++
+ // get all relevant host information
+ //
+ int HOST_INFO::get_host_info() {
+@@ -356,6 +400,12 @@
+ strncpy( p_model, "Alpha ", sizeof( p_model));
+ strncat( p_model, cpu_type_name, (sizeof( p_model)- strlen( p_model)- 1));
+ #endif
++#endif
++#endif
++
++#if defined(__FreeBSD__)
++#if defined(__i386__) || defined(__amd64__)
++ use_cpuid(*this);
+ #endif
+ #endif
+
diff --git a/net/boinc-client/files/patch-crashes b/net/boinc-client/files/patch-crashes
new file mode 100644
index 000000000000..43d20915a506
--- /dev/null
+++ b/net/boinc-client/files/patch-crashes
@@ -0,0 +1,12 @@
+--- clientgui/BOINCGUIApp.cpp.orig Mon Jan 22 14:19:20 2007
++++ clientgui/BOINCGUIApp.cpp Wed Feb 14 23:50:55 2007
+@@ -81,9 +81,7 @@
+ m_pSkinManager = NULL;
+ m_pFrame = NULL;
+ m_pDocument = NULL;
+-#if defined(__WXMSW__) || defined(__WXMAC__)
+ m_pTaskBarIcon = NULL;
+-#endif
+ #ifdef __WXMAC__
+ m_pMacSystemMenu = NULL;
+ #endif
diff --git a/net/boinc-client/files/patch-headers_for_seti b/net/boinc-client/files/patch-headers_for_seti
deleted file mode 100644
index 6b94dda517ee..000000000000
--- a/net/boinc-client/files/patch-headers_for_seti
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Tue Mar 7 15:06:14 2006
-+++ lib/Makefile.in Sat Mar 11 20:15:04 2006
-@@ -403,7 +403,7 @@
- proxy_info.h \
- util.h \
- msg_log.h \
-- crypt.h
-+ crypt.h std_fixes.h error_numbers.h
-
- md5_test_SOURCES = md5_test.C md5.c md5_file.C
- shmem_test_SOURCES = shmem_test.C shmem.C
diff --git a/net/boinc-client/files/patch-prefer_new_libs_over_installed b/net/boinc-client/files/patch-prefer_new_libs_over_installed
deleted file mode 100644
index 6e7f8b1be1a5..000000000000
--- a/net/boinc-client/files/patch-prefer_new_libs_over_installed
+++ /dev/null
@@ -1,22 +0,0 @@
---- client/Makefile.in.orig Tue Mar 7 15:06:10 2006
-+++ client/Makefile.in Wed Mar 15 13:56:33 2006
-@@ -336,7 +336,7 @@
-
- AM_CFLAGS = $(AM_CPPFLAGS)
- AM_CXXFLAGS = $(AM_CPPFLAGS)
--AM_LDFLAGS =
-+AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/client
-
- # dependencies to make sure libs gets compiled before
- # programs linking to them:
---- clientgui/Makefile.in.orig Tue Mar 7 15:06:12 2006
-+++ clientgui/Makefile.in Wed Mar 15 14:27:36 2006
-@@ -354,7 +354,7 @@
-
- AM_CFLAGS = $(AM_CPPFLAGS)
- AM_CXXFLAGS = $(AM_CPPFLAGS)
--AM_LDFLAGS =
-+AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/client
-
- # dependencies to make sure libs gets compiled before
- # programs linking to them:
diff --git a/net/boinc-client/pkg-descr b/net/boinc-client/pkg-descr
index cbcc724ae59d..370f550a3b5d 100644
--- a/net/boinc-client/pkg-descr
+++ b/net/boinc-client/pkg-descr
@@ -5,4 +5,4 @@ Many different projects can use BOINC. SETI@HOME, for example, has
been redesigned to use BOINC and the astro/boinc-setiathome port
supercedes the astro/setiathome port.
-WWW: http://boinc.berkeley.edu/
+WWW: http://boinc.berkeley.edu/
diff --git a/net/boinc-client/pkg-plist b/net/boinc-client/pkg-plist
index 590807d74e55..f6aea7f65f60 100644
--- a/net/boinc-client/pkg-plist
+++ b/net/boinc-client/pkg-plist
@@ -1,19 +1,22 @@
bin/boinc_client
bin/boinc_cmd
bin/crypt_prog
+bin/switcher
%%BOINC_GUI%%bin/boinc_gui
include/BOINC/app_ipc.h
include/BOINC/boinc_api.h
include/BOINC/boinc_win.h
include/BOINC/boinc_zip.h
+include/BOINC/common_defs.h
+include/BOINC/config.h
include/BOINC/crypt.h
include/BOINC/diagnostics.h
include/BOINC/error_numbers.h
-include/BOINC/exception.h
include/BOINC/filesys.h
include/BOINC/graphics_api.h
include/BOINC/graphics_impl.h
include/BOINC/graphics_lib.h
+include/BOINC/gui_rpc_client.h
include/BOINC/gutil.h
include/BOINC/hostinfo.h
include/BOINC/mfile.h
@@ -23,8 +26,8 @@ include/BOINC/parse.h
include/BOINC/prefs.h
include/BOINC/proxy_info.h
include/BOINC/std_fixes.h
+include/BOINC/version.h
include/BOINC/util.h
-lib/libbenchmark.a
lib/libboinc.a
lib/libboinc_api.a
%%BOINC_GUI%%lib/libboinc_graphics_api.a