aboutsummaryrefslogtreecommitdiff
path: root/net/bounce
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2007-08-26 11:05:00 +0000
committerAndrej Zverev <az@FreeBSD.org>2007-08-26 11:05:00 +0000
commit5d8cecb46182220994167614d0a9f5be34cfd148 (patch)
tree929919a17d0a8b21094bb1e5b4e79533a34ad601 /net/bounce
parent98fd28e98631f86e440e85f1604a0082acf69d48 (diff)
downloadports-5d8cecb46182220994167614d0a9f5be34cfd148.tar.gz
ports-5d8cecb46182220994167614d0a9f5be34cfd148.zip
Notes
Diffstat (limited to 'net/bounce')
-rw-r--r--net/bounce/Makefile2
-rw-r--r--net/bounce/files/patch-0458
2 files changed, 59 insertions, 1 deletions
diff --git a/net/bounce/Makefile b/net/bounce/Makefile
index 9bac16f1afaa..45386ecf108a 100644
--- a/net/bounce/Makefile
+++ b/net/bounce/Makefile
@@ -8,7 +8,7 @@
PORTNAME= bounce
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net security
MASTER_SITES= http://www.iagora.com/~espel/ \
${MASTER_SITE_LOCAL}
diff --git a/net/bounce/files/patch-04 b/net/bounce/files/patch-04
new file mode 100644
index 000000000000..a2910794d148
--- /dev/null
+++ b/net/bounce/files/patch-04
@@ -0,0 +1,58 @@
+--- bounce.c.orig Sun Aug 26 14:24:58 2007
++++ bounce.c Sun Aug 26 14:34:57 2007
+@@ -31,6 +31,7 @@
+ #define DEFAULT_PORT 1523
+
+ char sbuf[16384], cbuf[16384];
++int t=0;
+
+ void sigchld() {
+ signal(SIGCHLD, sigchld);
+@@ -46,12 +47,15 @@
+
+ struct itimerval itime;
+
++ if (t)
++ {
+ itime.it_interval.tv_sec=0;
+ itime.it_interval.tv_usec=0;
+- itime.it_value.tv_sec=21600;
++ itime.it_value.tv_sec=t;
+ itime.it_value.tv_usec=0;
+ setitimer(ITIMER_REAL,&itime,NULL);
+ /* arbitrary connection time limit: 6 hours (in case the client hangs) */
++ }
+
+ chead=ctail=cbuf;
+ cpos=0;
+@@ -153,7 +157,7 @@
+
+ /* Process arguments */
+
+- while( (ch = getopt(argc, argv, "p:a:b:d")) != -1 ) {
++ while( (ch = getopt(argc, argv, "p:a:b:d:t:")) != -1 ) {
+ switch(ch) {
+ case 'b': b = 1;
+ case 'd': d = 1; break;
+@@ -172,6 +176,12 @@
+ exit(-1);
+ }
+ break;
++ case 't':
++ if ((t=atoi(optarg)) == 0) {
++ fprintf(stderr, "Bad timer value.\n");
++ exit(-1);
++ }
++ break;
+ }
+ }
+
+@@ -179,7 +189,7 @@
+ argv += optind;
+
+ if (argc!=2) {
+- fprintf(stderr,"Use: %s [-a localaddr | -b localaddr] [-p localport] [-d] machine port \n",myname);
++ fprintf(stderr,"Use: %s [-a localaddr | -b localaddr] [-d] [-p localport] [-t timer] machine port \n",myname);
+ exit(-1);
+ }
+ if ((remoteport=atoi(argv[1]))<=0) {