aboutsummaryrefslogtreecommitdiff
path: root/net/bsdec2-image-upload
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2020-04-08 03:27:35 +0000
committerColin Percival <cperciva@FreeBSD.org>2020-04-08 03:27:35 +0000
commit214e46c02044b1a9c131959e3f30c8b74a996f14 (patch)
tree2c39beaa653f8e99c9935aee1385c9a9afd08877 /net/bsdec2-image-upload
parentfc760e65d239baefed6284cc29e091c285d46351 (diff)
downloadports-214e46c02044b1a9c131959e3f30c8b74a996f14.tar.gz
ports-214e46c02044b1a9c131959e3f30c8b74a996f14.zip
Notes
Diffstat (limited to 'net/bsdec2-image-upload')
-rw-r--r--net/bsdec2-image-upload/Makefile5
-rw-r--r--net/bsdec2-image-upload/distinfo6
-rw-r--r--net/bsdec2-image-upload/files/patch-Makefile10
3 files changed, 7 insertions, 14 deletions
diff --git a/net/bsdec2-image-upload/Makefile b/net/bsdec2-image-upload/Makefile
index b1cf00341aff..a88870b45788 100644
--- a/net/bsdec2-image-upload/Makefile
+++ b/net/bsdec2-image-upload/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= bsdec2-image-upload
-PORTVERSION= 1.2.2
+PORTVERSION= 1.3.0
CATEGORIES= net
MASTER_SITES= http://freebsd-ec2-dist.s3.amazonaws.com/
@@ -17,6 +17,9 @@ USES= ssl tar:tgz uidfix
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+BROKEN_SSL= libressl
+BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL
+
# Install into ${STAGEDIR}${PREFIX}; but the build respects ${DESTDIR} so
# all we need to give is the ${PREFIX}/bin part.
MAKE_ARGS+= BINDIR=${PREFIX}/bin
diff --git a/net/bsdec2-image-upload/distinfo b/net/bsdec2-image-upload/distinfo
index 543f3f02dd64..1de936175952 100644
--- a/net/bsdec2-image-upload/distinfo
+++ b/net/bsdec2-image-upload/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553049579
-SHA256 (bsdec2-image-upload-1.2.2.tgz) = f776ea3695f825e2a6e0962f4e63ca7d8be4e721e04f79fcabac161bd3b00a92
-SIZE (bsdec2-image-upload-1.2.2.tgz) = 25660
+TIMESTAMP = 1586308422
+SHA256 (bsdec2-image-upload-1.3.0.tgz) = 0380b26f50edadf4483c1ab3b8d3a9b227822841b45196fd1b8fdafdf806f908
+SIZE (bsdec2-image-upload-1.3.0.tgz) = 32960
diff --git a/net/bsdec2-image-upload/files/patch-Makefile b/net/bsdec2-image-upload/files/patch-Makefile
deleted file mode 100644
index 8bf7e52f66e8..000000000000
--- a/net/bsdec2-image-upload/files/patch-Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig
-+++ Makefile
-@@ -1,6 +1,6 @@
- PROG= bsdec2-image-upload
- SRCS= main.c
--NO_MAN ?= yes
-+MAN =
- WARNS ?= 3
- BINDIR ?= /usr/local/bin
- LDADD += -lcrypto -lssl