aboutsummaryrefslogtreecommitdiff
path: root/net/ccxstream
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-15 13:04:37 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-15 13:04:37 +0000
commit73b056be3daa5334d349f225d98f0b7b963be87a (patch)
treee5e0567d4ead6403f16456c023468ff85f869142 /net/ccxstream
parent2efcd87f3b3b817e84e6796606c6678600be295c (diff)
downloadports-73b056be3daa5334d349f225d98f0b7b963be87a.tar.gz
ports-73b056be3daa5334d349f225d98f0b7b963be87a.zip
Notes
Diffstat (limited to 'net/ccxstream')
-rw-r--r--net/ccxstream/Makefile49
-rw-r--r--net/ccxstream/distinfo2
-rw-r--r--net/ccxstream/files/ccxstream.sh.sample53
-rw-r--r--net/ccxstream/pkg-descr4
-rw-r--r--net/ccxstream/pkg-message3
5 files changed, 111 insertions, 0 deletions
diff --git a/net/ccxstream/Makefile b/net/ccxstream/Makefile
new file mode 100644
index 000000000000..14a364b2a5f7
--- /dev/null
+++ b/net/ccxstream/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: ccxstream
+# Date created: 2004-08-14
+# Whom: Michael Handler <handler@grendel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccxstream
+PORTVERSION= 1.0.15
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xbplayer
+
+MAINTAINER= handler@grendel.net
+COMMENT= Stream media files to XBox Media Center via XBMSP
+
+USE_GMAKE= yes
+
+USE_RC_SUBR= yes
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+SAMPLERC= ${PORTNAME}.sh.sample
+REALRC= ${SAMPLERC:S/.sample//}
+
+PLIST_FILES= bin/ccxstream bin/ccxtest etc/rc.d/${REALRC}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README ChangeLog TODO xbmsp-xml.txt xbmsp.txt
+.endif
+
+post-build:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/${SAMPLERC} > ${WRKDIR}/${SAMPLERC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/ccxstream ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/ccxtest ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/${SAMPLERC} ${PREFIX}/etc/rc.d/${REALRC}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+post-install:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/net/ccxstream/distinfo b/net/ccxstream/distinfo
new file mode 100644
index 000000000000..51f385ff8abf
--- /dev/null
+++ b/net/ccxstream/distinfo
@@ -0,0 +1,2 @@
+MD5 (ccxstream-1.0.15.tar.gz) = c589fff48ce541f26b394c9d82ccbead
+SIZE (ccxstream-1.0.15.tar.gz) = 40384
diff --git a/net/ccxstream/files/ccxstream.sh.sample b/net/ccxstream/files/ccxstream.sh.sample
new file mode 100644
index 000000000000..7ebff4f09e37
--- /dev/null
+++ b/net/ccxstream/files/ccxstream.sh.sample
@@ -0,0 +1,53 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ccxstream
+# REQUIRE: DAEMON
+# KEYWORD: FreeBSD
+
+# Define these ccxstream_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/ccxstream
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE!
+#
+# The port will refuse to start unless ccxstream_flags is initalized,
+# in addition to ccxstream_enable. For information on the arguments
+# to ccxstream, look at %%PREFIX%%/share/doc/ccxstream/README (if you
+# installed the port documentation by not specifying NOPORTDOCS) or the
+# output of "ccxstream -h". At bare minimum, you'll want to add the
+# "-u <user>" argument to specify the userid the server will run under
+# (unless you WANT to run this code as root), and the "-r <directory>"
+# argument to configure the directory root that the server will share
+# from.
+#
+# Don't worry about the "-f" (background) and "-F <pidfile>" arguments;
+# this script takes care of them for you.
+
+. %%RC_SUBR%%
+
+name="ccxstream"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/ccxstream"
+
+load_rc_config "$name"
+: ${ccxstream_enable="NO"}
+: ${ccxstream_flags="DEFAULT"}
+
+pidfile=${ccxstream_pidfile="/var/run/${name}.pid"}
+
+command_args="-f -F ${pidfile}"
+
+ccxstream_precmd () {
+ if [ x"${ccxstream_flags}" = xDEFAULT ]; then
+ warn must set ccxstream_flags first, no acceptable defaults
+ return 1
+ fi
+ return 0
+}
+
+run_rc_command "$1"
diff --git a/net/ccxstream/pkg-descr b/net/ccxstream/pkg-descr
new file mode 100644
index 000000000000..8b26c62f1429
--- /dev/null
+++ b/net/ccxstream/pkg-descr
@@ -0,0 +1,4 @@
+Server to stream music and video files from your UNIX server to an
+XBox running XBox Media Player using the XBMSP protocol.
+
+WWW: http://www.xboxmediacenter.de/
diff --git a/net/ccxstream/pkg-message b/net/ccxstream/pkg-message
new file mode 100644
index 000000000000..e1d8a57b906c
--- /dev/null
+++ b/net/ccxstream/pkg-message
@@ -0,0 +1,3 @@
+The ccxstream port will not start when enabled unless the configuration
+variable ccxstream_flags is also initialized. See ccxstream.sh in
+your ports startup directory for details.