aboutsummaryrefslogtreecommitdiff
path: root/net/citrix_ica/Makefile
diff options
context:
space:
mode:
authorMike Smith <msmith@FreeBSD.org>1998-12-28 23:38:16 +0000
committerMike Smith <msmith@FreeBSD.org>1998-12-28 23:38:16 +0000
commit9f13cb8112c74abe784a282c000127119f083b22 (patch)
treed059362d4ceabfbe0caeeaaaca0c88f5310e77c6 /net/citrix_ica/Makefile
parent5ac223b556df7617d85b10340ea2a2a135303310 (diff)
downloadports-9f13cb8112c74abe784a282c000127119f083b22.tar.gz
ports-9f13cb8112c74abe784a282c000127119f083b22.zip
Notes
Diffstat (limited to 'net/citrix_ica/Makefile')
-rw-r--r--net/citrix_ica/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 21a8f7b13cf1..b60ce913c882 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -1,15 +1,15 @@
-# New ports collection makefile for: Citrix ICA Client
+# New ports collection makefile for: Citrix(R) ICA(R) Client
# Version required: 2.80.76
# Date created: 20 Sep 1998
# Whom: msmith
#
-# $Id: Makefile,v 1.1.1.1 1998/09/21 21:30:24 msmith Exp $
+# $Id: Makefile,v 1.2 1998/11/06 07:09:15 msmith Exp $
#
DISTNAME= linux
PKGNAME= citrix_ica-2.8.1
CATEGORIES= comms
-MASTER_SITES= http://citrix.com/bin/client/ICA/
+MASTER_SITES= "Distfile must be fetched manually"
EXTRACT_SUFX= .tar.z
MAINTAINER= msmith@FreeBSD.ORG
@@ -25,6 +25,25 @@ IS_INTERACTIVE= "Noisy license agreement ignores stdin"
CDIR= ${PREFIX}/lib/ICAClient
BINDIR= ${PREFIX}/bin
+do-fetch:
+ @if [ ! -f ${DISTDIR}/${DISTFILES} ]; then \
+ ${ECHO} "" ; \
+ ${ECHO} " The source to this port may not be automatically fetched"
+; \
+ ${ECHO} " due to licensing restrictions. You MUST fetch the source"
+; \
+ ${ECHO} " manually after reading and agreeing to the license at:" ;
+\
+ ${ECHO} "" ; \
+ ${ECHO} " http://download.citrix.com/download.asp?client=LINUX" ; \
+ ${ECHO} "" ; \
+ ${ECHO} " Once ${DISTFILES} has been downloaded, move it to ${DISTDI
+R}" ; \
+ ${ECHO} " and then restart this build." ; \
+ ${ECHO} "" ; \
+ exit 1 ; \
+ fi
+
do-install:
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/response \
> ${WRKSRC}/response