aboutsummaryrefslogtreecommitdiff
path: root/net/clamz
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-10 15:41:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-10 15:41:41 +0000
commitcdbf23a172984c74b68ee4b46fc9deff22523d25 (patch)
tree28f2405fa93878b2471f579ac06bf82d5ff2ef86 /net/clamz
parentd91de51c21a2a24c8649af2c00e0bb1388040611 (diff)
Clamz is a little command-line program to
download MP3 files from Amazon.com's music store. It is intended to serve as a substitute for Amazon's official MP3 Downloader, which is not free software (and therefore is only available in binary form for a limited set of platforms.) Clamz can be used to download either individual songs or complete albums that you have purchased from Amazon. Text from http://code.google.com/p/clamz/. WWW: http://code.google.com/p/clamz/ PR: 135401 Submitted by: Helko Glathe <glathe.helko@googlemail.com>
Notes
Notes: svn path=/head/; revision=235544
Diffstat (limited to 'net/clamz')
-rw-r--r--net/clamz/Makefile32
-rw-r--r--net/clamz/distinfo3
-rw-r--r--net/clamz/pkg-descr15
3 files changed, 50 insertions, 0 deletions
diff --git a/net/clamz/Makefile b/net/clamz/Makefile
new file mode 100644
index 000000000000..18b36e7cb647
--- /dev/null
+++ b/net/clamz/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: clamz
+# Date created: 2009-06-08
+# Whom: Helko Glathe <glathe.helko@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clamz
+PORTVERSION= 0.2
+CATEGORIES= net audio
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= glathe.helko@googlemail.com
+COMMENT= Command-line program to download MP3 files from Amazon's music store
+
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl \
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ gcrypt.16:${PORTSDIR}/security/libgcrypt
+
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-configure:
+ @${REINPLACE_CMD} \
+ -e 's|^\(compile.*\)|\1 -I${LOCALBASE}/include|' \
+ -e 's|^\(LIBS\ =\)|\1 ${LOCALBASE}/lib/libexpat.so|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/clamz/distinfo b/net/clamz/distinfo
new file mode 100644
index 000000000000..6a928773e570
--- /dev/null
+++ b/net/clamz/distinfo
@@ -0,0 +1,3 @@
+MD5 (clamz-0.2.tar.gz) = 7e7bacae51a8be9ebf3b17ddf0b55499
+SHA256 (clamz-0.2.tar.gz) = 6a0014c85a7723c414de4d19f8b76b64761b46ba4f71f1a55938147d4189702a
+SIZE (clamz-0.2.tar.gz) = 65165
diff --git a/net/clamz/pkg-descr b/net/clamz/pkg-descr
new file mode 100644
index 000000000000..9a45a7e22545
--- /dev/null
+++ b/net/clamz/pkg-descr
@@ -0,0 +1,15 @@
+Clamz is a little command-line program to
+download MP3 files from Amazon.com's music
+store. It is intended to serve as a
+substitute for Amazon's official MP3
+Downloader, which is not free software
+(and therefore is only available in binary
+form for a limited set of platforms.)
+
+Clamz can be used to download either individual
+songs or complete albums that you have purchased
+from Amazon.
+
+Text from http://code.google.com/p/clamz/.
+
+WWW: http://code.google.com/p/clamz/