aboutsummaryrefslogtreecommitdiff
path: root/net/cloud-init
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-27 19:48:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-27 19:48:03 +0000
commit93c6b5cf52c6f97a07c798fb1cfc14958673f77a (patch)
treee04f7b198d0c5c49b1b985802ce5b2317cd08c14 /net/cloud-init
parent524ca4f82420dd7c0d23b2ffd8a0587b2abf04c0 (diff)
downloadports-93c6b5cf52c6f97a07c798fb1cfc14958673f77a.tar.gz
ports-93c6b5cf52c6f97a07c798fb1cfc14958673f77a.zip
Notes
Diffstat (limited to 'net/cloud-init')
-rw-r--r--net/cloud-init/Makefile45
-rw-r--r--net/cloud-init/distinfo2
-rw-r--r--net/cloud-init/pkg-descr3
-rw-r--r--net/cloud-init/pkg-message7
4 files changed, 57 insertions, 0 deletions
diff --git a/net/cloud-init/Makefile b/net/cloud-init/Makefile
new file mode 100644
index 000000000000..5781a70fc12d
--- /dev/null
+++ b/net/cloud-init/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= cloud-init
+PORTVERSION= 0.7.6
+CATEGORIES= net python
+MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= harm@weites.com
+COMMENT= Init scripts for use on cloud images
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= dmidecode>0:${PORTSDIR}/sysutils/dmidecode \
+ sudo>0:${PORTSDIR}/security/sudo \
+ gpart>0:${PORTSDIR}/sysutils/gpart \
+ ${PYTHON_PKGNAMEPREFIX}boto>0:${PORTSDIR}/devel/py-boto \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>0:${PORTSDIR}/devel/py-prettytable \
+ ${PYTHON_PKGNAMEPREFIX}configobj>0:${PORTSDIR}/devel/py-configobj \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}argparse>0:${PORTSDIR}/devel/py-argparse \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}serial>0:${PORTSDIR}/comms/py-serial \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}oauth>0:${PORTSDIR}/net/py-oauth \
+ ${PYTHON_PKGNAMEPREFIX}jsonpatch>0:${PORTSDIR}/devel/py-jsonpatch \
+ ${PYTHON_PKGNAMEPREFIX}jsonpointer>0:${PORTSDIR}/devel/py-jsonpointer
+
+ETCDIR= ${PREFIX}/etc/cloud
+
+USES= python:2.7 shebangfix
+SHEBANG_FILES= tools/validate-yaml.py tools/read-dependencies \
+ tools/read-version tools/hacking.py
+python_OLD_CMD= /usr/bin/env python
+python_CMD= ${PYTHON_CMD}
+USE_PYTHON= autoplist distutils
+
+PYDISTUTILS_INSTALLARGS+= "--init-system=sysvinit_freebsd"
+
+post-build:
+ @cd ${WRKSRC} && ${MV} config/cloud.cfg-freebsd config/cloud.cfg
+
+.include <bsd.port.mk>
diff --git a/net/cloud-init/distinfo b/net/cloud-init/distinfo
new file mode 100644
index 000000000000..d779589ea7e1
--- /dev/null
+++ b/net/cloud-init/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cloud-init-0.7.6.tar.gz) = 9e8fd22eb7f6e40ae6a5f66173ddc3cc18f65ee406c460a728092b37db2f3ed7
+SIZE (cloud-init-0.7.6.tar.gz) = 515670
diff --git a/net/cloud-init/pkg-descr b/net/cloud-init/pkg-descr
new file mode 100644
index 000000000000..84e23c9d1637
--- /dev/null
+++ b/net/cloud-init/pkg-descr
@@ -0,0 +1,3 @@
+Package provides configuration and customization of cloud instance.
+
+WWW: https://launchpad.net/cloud-init
diff --git a/net/cloud-init/pkg-message b/net/cloud-init/pkg-message
new file mode 100644
index 000000000000..8ae498bfa99e
--- /dev/null
+++ b/net/cloud-init/pkg-message
@@ -0,0 +1,7 @@
+==========================================================
+To enable cloud-init, add the following line to rc.conf:
+
+cloudinit_enable="YES"
+
+This will make sure cloud-init is started at boot.
+==========================================================