aboutsummaryrefslogtreecommitdiff
path: root/net/coda6_server
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-10-05 17:09:55 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-10-05 17:09:55 +0000
commit16dadb7cc6b213bb8bd564a7967410efc0abca3d (patch)
tree41d42d4aac7a8854dd9e523c9b57ea2efc3c71e0 /net/coda6_server
parent6d3e082b4995c9497faa3370cb1945d78f46dfb1 (diff)
downloadports-16dadb7cc6b213bb8bd564a7967410efc0abca3d.tar.gz
ports-16dadb7cc6b213bb8bd564a7967410efc0abca3d.zip
Notes
Diffstat (limited to 'net/coda6_server')
-rw-r--r--net/coda6_server/Makefile86
-rw-r--r--net/coda6_server/distinfo6
-rw-r--r--net/coda6_server/files/patch-coda-src_scripts_Makefile.in24
-rw-r--r--net/coda6_server/files/patch-coda-src_venus_fso1.cc11
-rw-r--r--net/coda6_server/files/patch-coda.h22
-rw-r--r--net/coda6_server/files/patch-configure25
-rw-r--r--net/coda6_server/files/patch-hostname33
-rw-r--r--net/coda6_server/files/patch-pioctl.h10
-rw-r--r--net/coda6_server/files/patch-srv.cc20
-rw-r--r--net/coda6_server/pkg-plist5
10 files changed, 103 insertions, 139 deletions
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index 5be573d7fb14..f6724344afad 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -5,56 +5,88 @@
# $FreeBSD$
PORTNAME= coda
-PORTVERSION= ${CODA_VERSION}
+PORTVERSION= 6.1.1
CATEGORIES= net
-MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/coda/src/
+# as of 5 Oct 2006 the archive is not present on ftp.wu-wien.ac.at
+# but maybe it'll appear there soon
+MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/coda/src/ \
+ ftp://ftp.planetmirror.com/pub/coda/src/ \
+ ftp://ftp.nctu.edu.tw/mirror/Coda/src/ \
+ ftp://ftp.wu-wien.ac.at/pub/systems/coda/src/
PKGNAMESUFFIX= -${CODA_SUITE}
-DISTNAME= coda-${PORTVERSION}
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Server programs for a replicated high-performance network file system
LIB_DEPENDS= lwp.2:${PORTSDIR}/devel/lwp \
- rpc2.6:${PORTSDIR}/devel/rpc2 \
+ rpc2.8:${PORTSDIR}/devel/rpc2 \
rvm.3:${PORTSDIR}/devel/rvm
-CONFLICTS= coda-server-5.*
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
ALL_TARGET= coda
INSTALL_TARGET= ${CODA_SUITE}-install
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-
CODA_SUITE?= server
-CODA_VERSION?= 6.0.7
.if ${CODA_SUITE} == server
-MAN5= vicetab.5 passwd.coda.5
-MAN8= pdbtool.8 auth2.8 initpw.8 norton.8
+MAN5= backuplogs.5 \
+ dumpfile.5 \
+ dumplist.5 \
+ maxgroupid.5 \
+ passwd.coda.5 \
+ servers.5 \
+ vicetab.5 \
+ volumelist.5 \
+ vrdb.5
+MAN8= auth2.8 \
+ backup.8 \
+ bldvldb.sh.8 \
+ codasrv.8 \
+ createvol_rep.8 \
+ initpw.8 \
+ merge.8 \
+ norton.8 \
+ pdbtool.8 \
+ purgevol_rep.8 \
+ readdump.8 \
+ startserver.8 \
+ updateclnt.8 \
+ updatesrv.8 \
+ vice-setup.8 \
+ volutil.8 \
+ vutil.8
.else
-MAN1= clog.1 cpasswd.1 ctokens.1 cunlog.1 \
- repair.1 cfs.1 cmon.1 coda_replay.1 \
- hoard.1 spy.1
-MAN8= au.8 venus.8
+MAN1= au.1 \
+ cfs.1 \
+ clog.1 \
+ cmon.1 \
+ coda_replay.1 \
+ cpasswd.1 \
+ ctokens.1 \
+ cunlog.1 \
+ hoard.1 \
+ mkcodabf.1 \
+ repair.1 \
+ spy.1
+MAN8= venus-setup.8 \
+ venus.8 \
+ volmunge.8
.endif
.include <bsd.port.pre.mk>
.if ${CODA_SUITE} == client
.if ${OSVERSION} < 501106
-IGNORE= lacks kernel support on this version of FreeBSD
+IGNORE= lacks kernel support on this version of FreeBSD
.endif
-.if ${OSVERSION} >= 600000
-IGNORE= makes a kernel panic on this version of FreeBSD
+# this needs testing with the new version (6.1.1)
+#.if ${OSVERSION} >= 600000
+#IGNORE= makes a kernel panic on this version of FreeBSD
+#.endif
.endif
-.endif
-
-.if ${OSVERSION} > 505000
-BROKEN= does not compile
-.endif
-
-DEPRECATED= compiles neither on 5-STABLE nor 6-STABLE; current version is quite old
-EXPIRATION_DATE= 2006-10-11
.include <bsd.port.post.mk>
diff --git a/net/coda6_server/distinfo b/net/coda6_server/distinfo
index 5951da9781e9..4c0cfee33daf 100644
--- a/net/coda6_server/distinfo
+++ b/net/coda6_server/distinfo
@@ -1,3 +1,3 @@
-MD5 (coda-6.0.7.tar.gz) = 0f22c4f1743d7c6bc9d1c103e193905b
-SHA256 (coda-6.0.7.tar.gz) = 2cad6e7d4081e393db11df826da5b9f7233e5ddae30035f3f502c75e1c613b93
-SIZE (coda-6.0.7.tar.gz) = 1536304
+MD5 (coda-6.1.1.tar.gz) = 58916173c6e0fcdbeb0c1bbca9ee9e52
+SHA256 (coda-6.1.1.tar.gz) = c741ae187bd82cca4a3056ae21e0e77ac7e6c789738577e1468e0f3793d8b531
+SIZE (coda-6.1.1.tar.gz) = 1571873
diff --git a/net/coda6_server/files/patch-coda-src_scripts_Makefile.in b/net/coda6_server/files/patch-coda-src_scripts_Makefile.in
new file mode 100644
index 000000000000..5584c0f82a8e
--- /dev/null
+++ b/net/coda6_server/files/patch-coda-src_scripts_Makefile.in
@@ -0,0 +1,24 @@
+
+coda-setup-ports is useless with a recent /etc/services and it is the only
+file installed by both server and client thus remove it to avoid conflicting
+plists
+
+--- coda-src/scripts/Makefile.in.orig Wed Apr 27 03:12:50 2005
++++ coda-src/scripts/Makefile.in Thu Oct 5 19:36:14 2006
+@@ -25,14 +25,14 @@
+ # Need to conditionalize this
+ include $(TOPDIR)/Makeconf
+
+-VENUS-SCRIPTS = vutil volmunge venus-setup coda-setup-ports \
++VENUS-SCRIPTS = vutil volmunge venus-setup \
+ coda-client-logrotate
+
+ VOL-SCRIPTS = createvol_rep purgevol_rep bldvldb.sh
+ VICE-SCRIPTS = startserver codastart coda-server-logrotate
+ REINIT-SCRIPTS = partial-reinit.sh
+ UPGRADE-SCRIPTS = #pwdtopdbtool.py
+-VICE-SETUP = vice-setup vice-setup-rvm vice-setup-scm vice-setup-srvdir vice-setup-user vice-killvolumes coda-setup-ports
++VICE-SETUP = vice-setup vice-setup-rvm vice-setup-scm vice-setup-srvdir vice-setup-user vice-killvolumes
+
+ BACKUP-SCRIPTS = backup.sh tape.pl
+
diff --git a/net/coda6_server/files/patch-coda-src_venus_fso1.cc b/net/coda6_server/files/patch-coda-src_venus_fso1.cc
new file mode 100644
index 000000000000..e7be0d222e86
--- /dev/null
+++ b/net/coda6_server/files/patch-coda-src_venus_fso1.cc
@@ -0,0 +1,11 @@
+--- coda-src/venus/fso1.cc.orig Thu Oct 5 16:11:23 2006
++++ coda-src/venus/fso1.cc Thu Oct 5 16:18:40 2006
+@@ -2895,7 +2895,7 @@
+ char confstr[4];
+
+ close(pfd[1]);
+- if(setpgrp() < 0) { perror("setpgrp"); exit(EXIT_FAILURE); }
++ if(setpgid(0, 0) < 0) { perror("setpgid"); exit(EXIT_FAILURE); }
+
+ sprintf(confstr, "%d", conflict_type);
+
diff --git a/net/coda6_server/files/patch-coda.h b/net/coda6_server/files/patch-coda.h
deleted file mode 100644
index 5865405dde2d..000000000000
--- a/net/coda6_server/files/patch-coda.h
+++ /dev/null
@@ -1,22 +0,0 @@
-On Thu, Sep 18, 2003 at 07:50:18PM -0700, Kris Kennaway wrote:
-
-> http://bento.freebsd.org/errorlogs/i386-4-full/coda-server-6.0.2_1.log
->
-> Can you please investigate?
-
-Drop this file into ports/coda6_server/files/patch-aa (or disconnect it from
-the build - coda 6 is not very useful on freebsd 4).
-
---- lib-src/kernel-includes/coda.h.orig Fri Sep 19 18:34:03 2003
-+++ lib-src/kernel-includes/coda.h Fri Sep 19 18:34:19 2003
-@@ -125,8 +125,8 @@
- #define __BIT_TYPES_DEFINED__
- #endif
-
--/* FreeBSD 5.0 */
--#if __FreeBSD__ >= 5
-+/* FreeBSD 3.0 and above */
-+#if __FreeBSD__ >= 3
- #define __BIT_TYPES_DEFINED__
- #endif
-
diff --git a/net/coda6_server/files/patch-configure b/net/coda6_server/files/patch-configure
deleted file mode 100644
index 8d494fe471e9..000000000000
--- a/net/coda6_server/files/patch-configure
+++ /dev/null
@@ -1,25 +0,0 @@
---- configure.orig Wed Oct 20 20:43:56 2004
-+++ configure Tue Nov 16 23:58:20 2004
-@@ -3059,13 +3059,6 @@
- initsuffix='../etc'
- ;;
-
-- */coda* )
-- # If '/coda*' is already in the prefix, we don't need to add
-- # a coda subdirectory to the sysconfdir.
-- sysconfdir=${prefix}/etc
-- initsuffix='etc'
-- ;;
--
- * )
- # Otherwise append '/coda' so that we don't throw our configuration
- # files all over the place.
-@@ -3074,7 +3067,7 @@
- else
- sysconfdir=${ac_default_prefix}/etc/coda
- fi
-- initsuffix='etc'
-+ initsuffix='etc/rc.d'
- ;;
- esac
- echo "$as_me:$LINENO: result: ${sysconfdir}" >&5
diff --git a/net/coda6_server/files/patch-hostname b/net/coda6_server/files/patch-hostname
deleted file mode 100644
index 924cdf96916f..000000000000
--- a/net/coda6_server/files/patch-hostname
+++ /dev/null
@@ -1,33 +0,0 @@
---- coda-src/scripts/vice-setup.in.orig Tue Oct 5 18:36:16 2004
-+++ coda-src/scripts/vice-setup.in Wed Nov 17 00:40:31 2004
-@@ -318,7 +318,7 @@
- #
- # ${vicedir}/hostname
- #
--hn=`hostname -f`
-+hn=`hostname`
- echo $hn > ${vicedir}/hostname
-
- #
---- coda-src/scripts/vice-setup-scm.orig Tue Oct 5 18:36:16 2004
-+++ coda-src/scripts/vice-setup-scm Wed Nov 17 00:40:12 2004
-@@ -53,7 +53,7 @@
- # making hostname
- #
-
--hn=`hostname -f`
-+hn=`hostname`
- cd ${vicedir}/db
-
- if [ $numservers -eq 1 ]; then
---- coda-src/scripts/vice-setup-srvdir.orig Sat Sep 4 08:03:32 2004
-+++ coda-src/scripts/vice-setup-srvdir Wed Nov 17 11:00:10 2004
-@@ -32,7 +32,7 @@
- numservers=1
- . "`codaconfedit server.conf`"
-
--hn=`hostname -f`
-+hn=`hostname`
-
- n=1
- while [ $n -le $numservers ]; do
diff --git a/net/coda6_server/files/patch-pioctl.h b/net/coda6_server/files/patch-pioctl.h
index d2ca61184263..2bdeff78574a 100644
--- a/net/coda6_server/files/patch-pioctl.h
+++ b/net/coda6_server/files/patch-pioctl.h
@@ -1,11 +1,11 @@
---- coda-src/kerndep/pioctl.h.orig Thu Aug 26 17:23:04 2004
-+++ coda-src/kerndep/pioctl.h Tue Nov 16 22:04:33 2004
-@@ -104,7 +104,7 @@
+--- coda-src/kerndep/pioctl.h.orig Thu Oct 5 11:54:04 2006
++++ coda-src/kerndep/pioctl.h Thu Oct 5 11:54:20 2006
+@@ -81,7 +81,7 @@
/* unpacking macros */
#ifndef _IOC_NR
--#if defined(__CYGWIN32__) || defined(__NetBSD__)
-+#if defined(__CYGWIN32__) || defined(__NetBSD__) || defined(__FreeBSD__)
+-#if defined(__NetBSD__)
++#if defined(__NetBSD__) || defined(__FreeBSD__)
#define _IOC_TYPEMASK 0xff
#define _IOC_TYPESHIFT 8
#define _IOC_NRMASK 0xff
diff --git a/net/coda6_server/files/patch-srv.cc b/net/coda6_server/files/patch-srv.cc
deleted file mode 100644
index b070dc255870..000000000000
--- a/net/coda6_server/files/patch-srv.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- coda-src/vice/srv.cc.orig Fri Sep 3 16:22:14 2004
-+++ coda-src/vice/srv.cc Tue Nov 16 22:19:04 2004
-@@ -1204,6 +1204,7 @@
- void SwapLog()
- {
- struct timeval tp;
-+ time_t start;
-
- /* Need to chdir() again, since salvage may have put me elsewhere */
- if(chdir(vice_file("srv"))) {
-@@ -1216,7 +1217,8 @@
-
- /* Print out time/date, since date info has "scrolled off" */
- TM_GetTimeOfDay(&tp, 0);
-- SLog(0, "Coda Vice, version " PACKAGE_VERSION "\tlog started at %s", ctime(&tp.tv_sec));
-+ start=tp.tv_sec;
-+ SLog(0, "Coda Vice, version " PACKAGE_VERSION "\tlog started at %s", ctime(&start));
- }
-
- static void FileMsg()
diff --git a/net/coda6_server/pkg-plist b/net/coda6_server/pkg-plist
index e27aea93aded..8563044bd040 100644
--- a/net/coda6_server/pkg-plist
+++ b/net/coda6_server/pkg-plist
@@ -4,7 +4,7 @@ bin/rpc2ping
bin/rvmsizer
bin/smon2
etc/coda/server.conf.ex
-@dirrm etc/coda
+@dirrmtry etc/coda
sbin/auth2
sbin/backup
sbin/backup.sh
@@ -12,7 +12,6 @@ sbin/bldvldb.sh
sbin/codadump2tar
sbin/codaconfedit
sbin/coda-server-logrotate
-sbin/coda-setup-ports
sbin/codasrv
sbin/codastart
sbin/createvol_rep
@@ -25,10 +24,8 @@ sbin/parserecdump
sbin/partial-reinit.sh
sbin/pdbtool
sbin/printvrdb
-sbin/purgevol
sbin/purgevol_rep
sbin/readdump
-sbin/rpc2portmap
sbin/startserver
sbin/tape.pl
sbin/updateclnt