aboutsummaryrefslogtreecommitdiff
path: root/net/concourse-fly/Makefile
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2017-10-09 21:15:29 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2017-10-09 21:15:29 +0000
commitaaf7a324d7030573f501e91a1b7e52328aa4d47e (patch)
treef93701723073d1a4e10f9c8043d8070a9ae52704 /net/concourse-fly/Makefile
parent0ca334a7596edf90dbdd02ca0b4a19c39d68f658 (diff)
Notes
Diffstat (limited to 'net/concourse-fly/Makefile')
-rw-r--r--net/concourse-fly/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net/concourse-fly/Makefile b/net/concourse-fly/Makefile
index bb31da4495fc..6724adba9a74 100644
--- a/net/concourse-fly/Makefile
+++ b/net/concourse-fly/Makefile
@@ -18,6 +18,8 @@ GO_PKGNAME= github.com/concourse/fly
USES= go tar:xz
+CONFLICTS_INSTALL= fly
+
PLIST_FILES= bin/fly
STRIP= # stripping can break go binaries
@@ -51,9 +53,7 @@ post-extract:
do-build:
(cd ${WRKDIR}; \
${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} \
- install -v -ldflags="-X github.com/concourse/fly/version.Version=${PORTVERSION}" ${GO_TARGET})
-
-.include <bsd.port.mk>
+ 'install' -v -ldflags="-X github.com/concourse/fly/version.Version=${PORTVERSION}" ${GO_TARGET})
.PHONY: create-src-archive
ARCHIVE_DIR= ${DISTDIR}/concourse-${PORTVERSION}
@@ -62,7 +62,9 @@ create-src-archive:
git clone --recursive -b v${PORTVERSION} \
https://github.com/concourse/concourse.git \
${ARCHIVE_DIR}
- ${FIND} ${ARCHIVE_DIR} \( -name ".git*" -o -name "testdata" \) -depth -exec rm -rf {} \;
+ ${FIND} ${ARCHIVE_DIR} \( -name ".git*" -o -name "testdata" \) -depth -exec ${RM} -rf {} \;
${TAR} -cf - -C ${ARCHIVE_DIR:H} ${ARCHIVE_DIR:T} | ${XZ_CMD} > ${ARCHIVE_DIR}.tar.xz
${RM} -rf ${ARCHIVE_DIR}
${MAKE} makesum
+
+.include <bsd.port.mk>