aboutsummaryrefslogtreecommitdiff
path: root/net/concourse-fly/Makefile
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2020-11-20 09:19:29 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2020-11-20 09:19:29 +0000
commitc595b90c8246c8d8c881252dca92bf3a360aa2e6 (patch)
treee9fed977851c41f6dfb2e8eede16c265f86ba417 /net/concourse-fly/Makefile
parent1295cfab558bd8e2432f0122fa2a69bcafcf993d (diff)
downloadports-c595b90c8246c8d8c881252dca92bf3a360aa2e6.tar.gz
ports-c595b90c8246c8d8c881252dca92bf3a360aa2e6.zip
Notes
Diffstat (limited to 'net/concourse-fly/Makefile')
-rw-r--r--net/concourse-fly/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/net/concourse-fly/Makefile b/net/concourse-fly/Makefile
index 3386ff83ad4a..a7bfbd066e8a 100644
--- a/net/concourse-fly/Makefile
+++ b/net/concourse-fly/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= concourse
-PORTVERSION= 5.7.2
+PORTVERSION= 6.7.1
CATEGORIES= net sysutils
MASTER_SITES= LOCAL/dumbbell/concourse/
PKGNAMESUFFIX= -fly
@@ -11,11 +11,11 @@ COMMENT= CLI for Concourse
LICENSE= APACHE20
-GO_PKGNAME= github.com/concourse/fly
-GO_BUILDFLAGS+= -mod=vendor \
- -ldflags="-X github.com/concourse/concourse.Version=${PORTVERSION}"
+USES= go:modules tar:xz
-USES= go tar:xz
+GO_TARGET= ./cmd/concourse:fly
+GO_BUILDFLAGS= -ldflags="-s -w -X github.com/concourse/concourse.Version=${PORTVERSION}"
+CGO_CFLAGS= -I.
CONFLICTS_INSTALL= fly
@@ -42,23 +42,10 @@ PLIST_FILES= bin/fly
#
# make create-src-archive
#
-# Because it doesn't match the project layout USES=go expects, we
-# override the post-extract and do-build targets to adapt the commands.
-#
-# In particular, we must pass `-mod=vendor` to go-install to be able to
-# use the third-party dependencies fetched with `go mod vendor`.
-
# `fly` version is set by default to "0.0.0-dev" in version/Version.go.
# Instead of patching the file, we use a linker flag to set the variable
# to the port's version.
-post-extract:
- @:
-
-do-build:
- (cd ${WRKSRC}/fly; \
- ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} 'install' ${GO_BUILDFLAGS})
-
.PHONY: create-src-archive
ARCHIVE_DIR= ${DISTDIR}/concourse-${PORTVERSION}
create-src-archive: