aboutsummaryrefslogtreecommitdiff
path: root/net/courier-authlib-ldap/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-03-15 17:13:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-03-15 17:13:49 +0000
commit87869765a81defe85cf450f1ec1083a3ab613620 (patch)
tree7a0c1d7181fdd907f042357f1e8e03dbcf7f689d /net/courier-authlib-ldap/Makefile
parent1b989cb195cdaf9b1ab53b7e332f25af3936bf92 (diff)
downloadports-87869765a81defe85cf450f1ec1083a3ab613620.tar.gz
ports-87869765a81defe85cf450f1ec1083a3ab613620.zip
Notes
Diffstat (limited to 'net/courier-authlib-ldap/Makefile')
-rw-r--r--net/courier-authlib-ldap/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/net/courier-authlib-ldap/Makefile b/net/courier-authlib-ldap/Makefile
index 09788f1fb902..a9de1f36fc2c 100644
--- a/net/courier-authlib-ldap/Makefile
+++ b/net/courier-authlib-ldap/Makefile
@@ -41,6 +41,8 @@ OPTIONS= PAM "Build with PAM support" on \
AUTHUSERDB "Build with authuserdb" on
VPOPMAILDIR?= ${LOCALBASE}/vpopmail
+WITH_MAILUSER?= daemon
+WITH_MAILGROUP?=daemon
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
@@ -50,7 +52,12 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-authshadow \
--without-authcustom \
--enable-unicode \
- --enable-ltdl-install=no
+ --enable-ltdl-install=no \
+ --with-mailuser=${WITH_MAILUSER} \
+ --with-mailgroup=${WITH_MAILGROUP} \
+ --with-authdaemonvar=/var/run/authdaemond
+
+PLIST_SUB= MAILUSER=${WITH_MAILUSER} MAILGROUP=${WITH_MAILGROUP}
.include <bsd.port.pre.mk>
@@ -117,14 +124,6 @@ PLIST_SUB+= AUTHUSERDBFLAG="@comment "
PLIST_SUB+= AUTHUSERDBFLAG=""
.endif
-.if defined(WITH_MAILUSER)
-CONFIGURE_ARGS+=--with-mailuser=${WITH_MAILUSER}
-.endif
-
-.if defined(WITH_MAILGROUP)
-CONFIGURE_ARGS+=--with-mailgroup=${WITH_MAILGROUP}
-.endif
-
RC_SCRIPTS_SUB=PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAN1= courierlogger.1