aboutsummaryrefslogtreecommitdiff
path: root/net/cphone
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-10 12:45:41 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-10 12:45:41 +0000
commit2c8a0e00ab9e6dd611a446124f25cd9bc69d857a (patch)
tree7a8cff920f7616d4c8f056541d6240e8e4a6c261 /net/cphone
parent5aac148861ab3edd41c18bc55e9fdfbb0f9a7ab2 (diff)
downloadports-2c8a0e00ab9e6dd611a446124f25cd9bc69d857a.tar.gz
ports-2c8a0e00ab9e6dd611a446124f25cd9bc69d857a.zip
Notes
Diffstat (limited to 'net/cphone')
-rw-r--r--net/cphone/Makefile2
-rw-r--r--net/cphone/files/patch-cpendpoint.h10
-rw-r--r--net/cphone/files/patch-options.h10
-rw-r--r--net/cphone/files/patch-qtvid.cxx25
-rw-r--r--net/cphone/files/patch-qtvid.h19
5 files changed, 65 insertions, 1 deletions
diff --git a/net/cphone/Makefile b/net/cphone/Makefile
index 97d648364bd3..affe115e4c20 100644
--- a/net/cphone/Makefile
+++ b/net/cphone/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cphone
DISTVERSION= 0.3.2.cvs.20060407
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/distfiles/
diff --git a/net/cphone/files/patch-cpendpoint.h b/net/cphone/files/patch-cpendpoint.h
new file mode 100644
index 000000000000..fb15c4d4f09e
--- /dev/null
+++ b/net/cphone/files/patch-cpendpoint.h
@@ -0,0 +1,10 @@
+--- ./cpendpoint.h.orig 2008-03-02 22:47:13.000000000 +0800
++++ ./cpendpoint.h 2008-03-02 22:47:30.000000000 +0800
+@@ -53,6 +53,7 @@
+ #define _CPhone_CPENDPOINT_H
+
+ #include <ptlib.h>
++#include <ptlib/video.h>
+ #include <h323.h>
+ #include <qevent.h>
+ #include "options.h"
diff --git a/net/cphone/files/patch-options.h b/net/cphone/files/patch-options.h
new file mode 100644
index 000000000000..239488143ab2
--- /dev/null
+++ b/net/cphone/files/patch-options.h
@@ -0,0 +1,10 @@
+--- ./options.h.orig 2008-03-02 22:44:57.000000000 +0800
++++ ./options.h 2008-03-02 22:45:04.000000000 +0800
+@@ -48,6 +48,7 @@
+ #define _CPhone_OPTIONS_H
+
+ #include <ptlib.h>
++#include <ptlib/sound.h>
+
+ class MainUserInterface;
+
diff --git a/net/cphone/files/patch-qtvid.cxx b/net/cphone/files/patch-qtvid.cxx
new file mode 100644
index 000000000000..ed65671265ce
--- /dev/null
+++ b/net/cphone/files/patch-qtvid.cxx
@@ -0,0 +1,25 @@
+--- ./qtvid.cxx.orig 2008-03-02 22:45:11.000000000 +0800
++++ ./qtvid.cxx 2008-03-02 22:45:59.000000000 +0800
+@@ -263,21 +263,7 @@
+
+ BOOL PTextVideoInputDevice::GetFrameData(BYTE *buffer, PINDEX *bytesReturned)
+ {
+- if(frameRate>0) {
+- frameTimeError += msBetweenFrames;
+-
+- do {
+- if ( !GetFrameDataNoDelay(buffer, bytesReturned)) {
+- return FALSE;
+- }
+- PTime now;
+- PTimeInterval delay = now - previousFrameTime;
+- frameTimeError -= (int)delay.GetMilliSeconds();
+- previousFrameTime = now;
+- } while(frameTimeError > 0) ;
+-
+- return TRUE;
+- }
++ m_pacing.Delay(1000/GetFrameRate());
+ return GetFrameDataNoDelay(buffer, bytesReturned);
+ }
+
diff --git a/net/cphone/files/patch-qtvid.h b/net/cphone/files/patch-qtvid.h
new file mode 100644
index 000000000000..3c207c387e13
--- /dev/null
+++ b/net/cphone/files/patch-qtvid.h
@@ -0,0 +1,19 @@
+--- ./qtvid.h.orig 2008-03-02 22:45:09.000000000 +0800
++++ ./qtvid.h 2008-03-02 22:46:14.000000000 +0800
+@@ -42,6 +42,7 @@
+ #define _CPhone_Qt_H
+
+ #include <ptlib.h>
++#include <ptclib/delaychan.h>
+ #include <qimage.h>
+ #include "vdisplay.h"
+
+@@ -319,6 +320,8 @@
+
+ Rgb32Image *rgbImage;
+ PMutex bufferMutex;
++
++ PAdaptiveDelay m_pacing;
+ };
+
+