aboutsummaryrefslogtreecommitdiff
path: root/net/crtmpserver
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-07-30 15:49:07 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-07-30 15:49:07 +0000
commitb7a2d32333e7b914e6c0735b3e806db73ba56f35 (patch)
treeb3168b0c2d16dda2afac71bb01427f056f94b74c /net/crtmpserver
parent0f35c99770914d776d67e3e5e9e6b026f9d4db74 (diff)
downloadports-b7a2d32333e7b914e6c0735b3e806db73ba56f35.tar.gz
ports-b7a2d32333e7b914e6c0735b3e806db73ba56f35.zip
Notes
Diffstat (limited to 'net/crtmpserver')
-rw-r--r--net/crtmpserver/Makefile21
-rw-r--r--net/crtmpserver/distinfo4
-rw-r--r--net/crtmpserver/files/crtmpserver.in18
-rw-r--r--net/crtmpserver/pkg-plist23
4 files changed, 20 insertions, 46 deletions
diff --git a/net/crtmpserver/Makefile b/net/crtmpserver/Makefile
index c9b3f397f3bd..c6d9d184eb46 100644
--- a/net/crtmpserver/Makefile
+++ b/net/crtmpserver/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= crtmpserver
-PORTVERSION= 0.355
-PORTREVISION= 1
+PORTVERSION= 0.545
CATEGORIES= net
-MASTER_SITES= http://freebsd.rtmpd.com/
+MASTER_SITES= http://rtmpd.com/assets/sources/
MAINTAINER= support@rtmpd.com
COMMENT= C++ RTSP/RTMP/MPEG-TS Server
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+WRKSRC= ${WRKDIR}/crtmpserver-545
+
USE_CMAKE= yes
+CMAKE_ENV= "COMPILE_STATIC=1"
CMAKE_OUTSOURCE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/builders/cmake
-CMAKE_ARGS= -DCRTMPSERVER_INSTALL_PREFIX:STRING=${CMAKE_INSTALL_PREFIX} -DTEMP_FRAMEWORK_VER=0.355
-USE_LDCONFIG= 1
+CMAKE_BUILD_TYPE= Release
+CMAKE_ARGS= -DCRTMPSERVER_INSTALL_PREFIX:STRING=${CMAKE_INSTALL_PREFIX} -DTEMP_FRAMEWORK_VER=0.545
USERS= crtmpserver
GROUPS= crtmpserver
@@ -29,13 +31,10 @@ USE_RC_SUBR= crtmpserver
MAN1= crtmpserver.1
-pre-install:
- @sh $(WRKSRC)/fixConfFile.sh "${WRKSRC}/builders/cmake/crtmpserver/crtmpserver.lua" "${PREFIX}" "${WRKSRC}"
-
post-install:
- @if [ ! -f ${PREFIX}/etc/crtmpserver.lua ]; then \
- ${CP} -p ${PREFIX}/etc/crtmpserver.lua.sample ${PREFIX}/etc/crtmpserver.lua ; \
- fi
+ @if [ ! -f ${PREFIX}/etc/crtmpserver.lua ]; then \
+ ${CP} -p ${PREFIX}/etc/crtmpserver.lua.sample ${PREFIX}/etc/crtmpserver.lua ; \
+ fi
.include <bsd.port.pre.mk>
diff --git a/net/crtmpserver/distinfo b/net/crtmpserver/distinfo
index 9a9c02f18e81..30098fee4919 100644
--- a/net/crtmpserver/distinfo
+++ b/net/crtmpserver/distinfo
@@ -1,2 +1,2 @@
-SHA256 (crtmpserver-0.355.tar.gz) = 27b36755782879f97151a70103351a0369620b735809bcde7dbe023279885883
-SIZE (crtmpserver-0.355.tar.gz) = 1422310
+SHA256 (crtmpserver-0.545.tar.gz) = 8ba7920c8a90f1e79dbddfeb4c8e22ccaec8dda1ad7f374a210baf57a3e61698
+SIZE (crtmpserver-0.545.tar.gz) = 1605578
diff --git a/net/crtmpserver/files/crtmpserver.in b/net/crtmpserver/files/crtmpserver.in
index d4b3b3bfce20..a0b913fdb4e2 100644
--- a/net/crtmpserver/files/crtmpserver.in
+++ b/net/crtmpserver/files/crtmpserver.in
@@ -10,12 +10,11 @@
# to enable this service:
#
# crtmpserver_enable (bool): Set to NO by default.
-# Set it to YES to enable doormand.
+# Set it to YES to enable crtmpserver.
# crtmpserver_config (path): Set to %%PREFIX%%/etc/crtmpserver.lua
# by default.
# crtmpserver_username (username): Set to crtmpserver
# by default.
-#
. /etc/rc.subr
@@ -23,23 +22,18 @@ name="crtmpserver"
rcvar=${name}_enable
command=%%PREFIX%%/sbin/${name}
-pidfile=/var/run/${name}.pid
-
-start_postcmd="${name}_poststart"
-
-crtmpserver_poststart()
-{
- pgrep crtmpserver > /var/run/crtmpserver.pid
-}
load_rc_config $name
: ${crtmpserver_enable="NO"}
: ${crtmpserver_config="%%PREFIX%%/etc/crtmpserver.lua"}
-: ${crtmpserver_username="%%USERS%%"}
+: ${crtmpserver_username="crtmpserver"}
+: ${crtmpserver_groupname="crtmpserver"}
+: ${crtmpserver_pidfile="/var/run/${name}.pid"}
required_files="$crtmpserver_config"
-command_args="--daemon --uid=`id -u ${crtmpserver_username}` $required_files"
+command_args="--daemon --uid=`id -u ${crtmpserver_username}` --gid=`pw groupshow ${crtmpserver_groupname} | awk -F ":" '{print $3}'` --pid=${crtmpserver_pidfile} $required_files"
run_rc_command "$1"
+
diff --git a/net/crtmpserver/pkg-plist b/net/crtmpserver/pkg-plist
index fba2ba014c62..883062bb8047 100644
--- a/net/crtmpserver/pkg-plist
+++ b/net/crtmpserver/pkg-plist
@@ -3,25 +3,6 @@
etc/crtmpserver.lua.sample
@exec if [ ! -f %D/etc/crtmpserver.lua ] ; then cp -p %D/%F %B/crtmpserver.lua; fi
-lib/crtmpserver/liblua.so
-lib/crtmpserver/libcommon.so
-lib/crtmpserver/libthelib.so
-lib/crtmpserver/applications/flvplayback/libflvplayback.so
-lib/crtmpserver/applications/appselector/libappselector.so
-lib/crtmpserver/applications/samplefactory/libsamplefactory.so
-lib/crtmpserver/applications/vptests/libvptests.so
-lib/crtmpserver/applications/admin/libadmin.so
-lib/crtmpserver/applications/proxypublish/libproxypublish.so
-lib/crtmpserver/applications/stresstest/libstresstest.so
-lib/crtmpserver/applications/applestreamingclient/libapplestreamingclient.so
sbin/crtmpserver
-@dirrmtry lib/crtmpserver/applications/flvplayback
-@dirrmtry lib/crtmpserver/applications/appselector
-@dirrmtry lib/crtmpserver/applications/samplefactory
-@dirrmtry lib/crtmpserver/applications/vptests
-@dirrmtry lib/crtmpserver/applications/admin
-@dirrmtry lib/crtmpserver/applications/proxypublish
-@dirrmtry lib/crtmpserver/applications/stresstest
-@dirrmtry lib/crtmpserver/applications/applestreamingclient
-@dirrmtry lib/crtmpserver/applications
-@dirrmtry lib/crtmpserver
+@dirrmtry var/crtmpserver/media
+@dirrmtry var/crtmpserver