aboutsummaryrefslogtreecommitdiff
path: root/net/csync2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-26 20:17:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-26 20:17:22 +0000
commit869c04242a5d6d9ef9c8b90c3d3f032e6331572b (patch)
treea50715faeb1d249ba227d63e612da2e47d2e8080 /net/csync2
parent8dc039df69aed61c7c54bca851d95b34c899a579 (diff)
downloadports-869c04242a5d6d9ef9c8b90c3d3f032e6331572b.tar.gz
ports-869c04242a5d6d9ef9c8b90c3d3f032e6331572b.zip
Notes
Diffstat (limited to 'net/csync2')
-rw-r--r--net/csync2/Makefile31
1 files changed, 13 insertions, 18 deletions
diff --git a/net/csync2/Makefile b/net/csync2/Makefile
index b7607009bba9..642a56814a1a 100644
--- a/net/csync2/Makefile
+++ b/net/csync2/Makefile
@@ -11,22 +11,17 @@ MASTER_SITES= http://oss.linbit.com/csync2/ \
MAINTAINER= alexey@renatasystems.org
COMMENT= Cluster synchronization tool
-LIB_DEPENDS= rsync.1:${PORTSDIR}/net/librsync \
- tasn1.7:${PORTSDIR}/security/libtasn1 \
- gnutls.26:${PORTSDIR}/security/gnutls \
- sqlite.2:${PORTSDIR}/databases/sqlite2 \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gpg-error.0:${PORTSDIR}/security/libgpg-error
+LIB_DEPENDS= librsync.so:${PORTSDIR}/net/librsync \
+ libtasn1.so:${PORTSDIR}/security/libtasn1 \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libsqlite.so:${PORTSDIR}/databases/sqlite2 \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
OPTIONS_DEFINE= CSYNC2_COMPARE
CSYNC2_COMPARE_DESC= Install csync2-compare script
-USES= pkgconfig
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-MAN1= csync2.1
+USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
@@ -37,7 +32,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_RC_SUBR= csync2
PLIST_FILES= etc/csync2.cfg-dist \
- sbin/csync2
+ sbin/csync2 \
+ man/man1/csync2.1.gz
+
+SUB_FILES= pkg-install
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCSYNC2_COMPARE}
RUN_DEPENDS+= bash>=0:${PORTSDIR}/shells/bash
@@ -47,12 +47,7 @@ CSYNC2_COMPARE= csync2-compare
CSYNC2_COMPARE=
.endif
-SUB_FILES= pkg-install
-
post-patch:
${REINPLACE_CMD} -E "s#%%CSYNC2_COMPARE%%#${CSYNC2_COMPARE}#" ${WRKSRC}/Makefile.in
-post-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.mk>