aboutsummaryrefslogtreecommitdiff
path: root/net/ctrace
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-08-25 11:20:49 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-08-25 11:20:49 +0000
commitaa460bf537d198aa9aabc92880601f01cec83d18 (patch)
treedcc5760c44fb2891c2d9677ae89ec73aac46befe /net/ctrace
parent4a3c01bb47b25382fd4987a72675690ad7469e4c (diff)
downloadports-aa460bf537d198aa9aabc92880601f01cec83d18.tar.gz
ports-aa460bf537d198aa9aabc92880601f01cec83d18.zip
Add ctrace-0.8
ctrace is an IPv4 traceroute tool that supports many features missing in standard 4.3BSD traceroute(8). It is programmed entirely in perl. Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=46880
Diffstat (limited to 'net/ctrace')
-rw-r--r--net/ctrace/Makefile27
-rw-r--r--net/ctrace/distinfo1
-rw-r--r--net/ctrace/pkg-comment1
-rw-r--r--net/ctrace/pkg-descr19
-rw-r--r--net/ctrace/pkg-plist1
5 files changed, 49 insertions, 0 deletions
diff --git a/net/ctrace/Makefile b/net/ctrace/Makefile
new file mode 100644
index 000000000000..fd1cd08fa622
--- /dev/null
+++ b/net/ctrace/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: ctrace
+# Date created: 24 Aug 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctrace
+PORTVERSION= 0.8
+CATEGORIES= net
+MASTER_SITES= http://www.pratyeka.org/ctrace/download/
+
+MAINTAINER= kris@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+
+NO_BUILD= yes
+USE_BZIP2= yes
+
+MAN1= ctrace.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ctrace ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/ctrace.man ${PREFIX}/man/man1/ctrace.1
+
+.include <bsd.port.mk>
diff --git a/net/ctrace/distinfo b/net/ctrace/distinfo
new file mode 100644
index 000000000000..e419c24fb534
--- /dev/null
+++ b/net/ctrace/distinfo
@@ -0,0 +1 @@
+MD5 (ctrace-0.8.tar.bz2) = bc9bbd8cd603b9c95f4563e1f878f4e1
diff --git a/net/ctrace/pkg-comment b/net/ctrace/pkg-comment
new file mode 100644
index 000000000000..223202c36750
--- /dev/null
+++ b/net/ctrace/pkg-comment
@@ -0,0 +1 @@
+Multiprotocol traceroute tool
diff --git a/net/ctrace/pkg-descr b/net/ctrace/pkg-descr
new file mode 100644
index 000000000000..853d86fa7406
--- /dev/null
+++ b/net/ctrace/pkg-descr
@@ -0,0 +1,19 @@
+ctrace is an IPv4 traceroute tool that supports many features missing
+in standard 4.3BSD traceroute(8). It is programmed entirely in perl.
+
+The primary difference between ctrace and other traceroute tools is
+its ability to trace routes in multiple protocols. ctrace also has
+some additional nifty features:
+* Automatic round-trip-time (RTT) averaging, which makes output
+ cleaner and more intelligible.
+* One or more packets can be launched per TTL/hop. By way of contrast,
+ 4.3BSD traceroute(8) forces at least two. This capability makes
+ ctrace faster.
+* 4.3BSD traceroute(8) emulation in most output, so it will hook in to
+ existing parsers.
+* The ability to skip an arbitrary number of hops, saving you time
+ that would be normally wasted tracerouting your own network.
+* Fine-grained control over trace packet headers, assisting in
+ bypassing burdensome packet filters.
+
+WWW: http://www.pratyeka.org/ctrace/
diff --git a/net/ctrace/pkg-plist b/net/ctrace/pkg-plist
new file mode 100644
index 000000000000..c7432b89adee
--- /dev/null
+++ b/net/ctrace/pkg-plist
@@ -0,0 +1 @@
+sbin/ctrace