aboutsummaryrefslogtreecommitdiff
path: root/net/cvsup-static
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-09 10:39:05 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-09 10:39:05 +0000
commite1a58b0f0bea28584b44a627811bfa6d09da063a (patch)
tree0cceb388db4b23259f7ba6e885679b5c1863120a /net/cvsup-static
parent6783ba5b736d841c331b3b699aa2c5acde4576e6 (diff)
downloadports-e1a58b0f0bea28584b44a627811bfa6d09da063a.tar.gz
ports-e1a58b0f0bea28584b44a627811bfa6d09da063a.zip
Notes
Diffstat (limited to 'net/cvsup-static')
-rw-r--r--net/cvsup-static/Makefile28
-rw-r--r--net/cvsup-static/Makefile.DragonFly1
-rw-r--r--net/cvsup-static/distinfo.amd642
-rw-r--r--net/cvsup-static/pkg-descr11
-rw-r--r--net/cvsup-static/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/net/cvsup-static/Makefile b/net/cvsup-static/Makefile
new file mode 100644
index 000000000000..b533580a9209
--- /dev/null
+++ b/net/cvsup-static/Makefile
@@ -0,0 +1,28 @@
+# Created by: Xin Li <delphij@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cvsup-static
+PORTVERSION= 16.1h
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= delphij
+PKGNAMEPREFIX= binary-
+DISTNAME= cvsup-without-gui-static-${ARCH}-${PORTVERSION}
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= File distribution system optimized for CVS
+
+ONLY_FOR_ARCHS= amd64
+
+DISTINFO_FILE= ${.CURDIR}/distinfo.${ARCH}
+
+NO_BUILD= yes
+USES= tar:xz
+
+do-install:
+ (cd ${WRKDIR} && ${COPYTREE_BIN} bin ${STAGEDIR}${PREFIX})
+ (cd ${WRKDIR} && ${COPYTREE_BIN} sbin ${STAGEDIR}${PREFIX})
+ (cd ${WRKDIR} && ${COPYTREE_SHARE} share/cvsup ${STAGEDIR}${PREFIX})
+ (cd ${WRKDIR} && ${COPYTREE_SHARE} man ${STAGEDIR}${PREFIX})
+
+.include <bsd.port.mk>
diff --git a/net/cvsup-static/Makefile.DragonFly b/net/cvsup-static/Makefile.DragonFly
new file mode 100644
index 000000000000..54a508c6a0a8
--- /dev/null
+++ b/net/cvsup-static/Makefile.DragonFly
@@ -0,0 +1 @@
+IGNORE= statically compiled binaries will not execute on DragonFly
diff --git a/net/cvsup-static/distinfo.amd64 b/net/cvsup-static/distinfo.amd64
new file mode 100644
index 000000000000..ef20ce2aa2d9
--- /dev/null
+++ b/net/cvsup-static/distinfo.amd64
@@ -0,0 +1,2 @@
+SHA256 (cvsup-without-gui-static-amd64-16.1h.tar.xz) = c095b584293344031167511d2fb616bb7f26012c834e96c1d749becaf69c45b2
+SIZE (cvsup-without-gui-static-amd64-16.1h.tar.xz) = 799616
diff --git a/net/cvsup-static/pkg-descr b/net/cvsup-static/pkg-descr
new file mode 100644
index 000000000000..0d4d24c540ae
--- /dev/null
+++ b/net/cvsup-static/pkg-descr
@@ -0,0 +1,11 @@
+CVSup is a software package for distributing and updating collections
+of files across a network. It can efficiently and accurately mirror
+all types of files, including sources, binaries, hard links, symbolic
+links, and even device nodes. CVSup's streaming communication
+protocol and multithreaded architecture make it most likely the
+fastest mirroring tool in existence today. In addition to being
+a great general-purpose mirroring tool, CVSup includes special
+features and optimizations specifically tailored to CVS repositories.
+
+This is a package that is statically compiled for FreeBSD 7.x omits
+the GUI.
diff --git a/net/cvsup-static/pkg-plist b/net/cvsup-static/pkg-plist
new file mode 100644
index 000000000000..042bffd64a7c
--- /dev/null
+++ b/net/cvsup-static/pkg-plist
@@ -0,0 +1,8 @@
+bin/cvpasswd
+bin/cvsup
+man/man1/cvpasswd.1.gz
+man/man1/cvsup.1.gz
+man/man8/cvsupd.8.gz
+sbin/cvsupd
+share/cvsup/License
+@dirrm share/cvsup