aboutsummaryrefslogtreecommitdiff
path: root/net/cvsup
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>2000-02-13 23:31:33 +0000
committerJohn Polstra <jdp@FreeBSD.org>2000-02-13 23:31:33 +0000
commite08736e7b83fd0f192295d490f003fc251ca6f7f (patch)
treeef19096e69dc3d29360259ddc670ac27825ad053 /net/cvsup
parent2b26c24e031343316c9d52630364eafc948b87ef (diff)
downloadports-e08736e7b83fd0f192295d490f003fc251ca6f7f.tar.gz
ports-e08736e7b83fd0f192295d490f003fc251ca6f7f.zip
Notes
Diffstat (limited to 'net/cvsup')
-rw-r--r--net/cvsup/Makefile65
1 files changed, 49 insertions, 16 deletions
diff --git a/net/cvsup/Makefile b/net/cvsup/Makefile
index 666302a1a6cf..aabe22ee6720 100644
--- a/net/cvsup/Makefile
+++ b/net/cvsup/Makefile
@@ -13,29 +13,62 @@ MASTER_SITES= ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/sources/ \
MAINTAINER= jdp@FreeBSD.org
-BUILD_DEPENDS= m3build-6:${PORTSDIR}/lang/modula-3
-LIB_DEPENDS= m3.6:${PORTSDIR}/lang/modula-3-lib
+.ifdef NO_X11
+M3FLAGS+= -DNOGUI
+BUILD_DEPENDS= ${L1}libm3tcp${L2}:${PORTSDIR}/lang/pm3-net
+RUN_DEPENDS= ${L1}libm3tcp${L2}:${PORTSDIR}/lang/pm3-net
+.else
+BUILD_DEPENDS= ${L1}libm3formsvbt${L2}:${PORTSDIR}/lang/pm3-forms
+RUN_DEPENDS= ${L1}libm3formsvbt${L2}:${PORTSDIR}/lang/pm3-forms
+.endif
+MAKE_ARGS+= PREFIX=${PREFIX} M3FLAGS="${M3FLAGS}"
MAN1= cvpasswd.1 cvsup.1
MAN8= cvsupd.8
-NOT_FOR_ARCHS= alpha
-# Support building on systems with or without X11 installed.
-.ifdef NO_X11
-M3FLAGS+= -DNOGUI
+L1= ${PREFIX}/lib/m3/${TARGET}/
+SOVERSION= 7
+
+# To link the programs statically:
+#M3FLAGS+= -DSTATIC
+
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "aout"
+L2= .so.${SOVERSION}.0
+TARGET= FreeBSD2
+TARGETDIR= freebsd-2
+WORDSIZE= 32
+.elif ${ARCH} == "i386"
+L2= .so.${SOVERSION}
+.if ${OSVERSION} < 400011
+TARGET= FreeBSD3
+TARGETDIR= freebsd-3
.else
+TARGET= FreeBSD4
+TARGETDIR= freebsd-4
+.endif
+WORDSIZE= 32
+.elif ${ARCH} == "alpha"
+.if ${OSVERSION} < 400011
+BROKEN= Not supported on older versions of FreeBSD/Alpha
+.endif
+CFLAGS+= -mieee
+L2= .so.${SOVERSION}
+TARGET= FBSD_ALPHA
+TARGETDIR= fbsd-alpha
+WORDSIZE= 64
+.endif
+
pre-fetch:
+.if empty(TARGET)
+ @${ECHO_MSG} "Cannot determine M3 target for this architecture"
+ @${FALSE}
+.endif
+.ifndef NO_X11
@${ECHO_MSG} -n "To build this port without X11 (and without the GUI),"
@${ECHO_MSG} " define \"NO_X11\"."
-
.endif
+ @${TRUE}
-# Build options. Uncomment the desired ones.
-# To link the programs statically:
-#M3FLAGS+= -DSTATIC
-# To link just the Modula-3 libraries statically:
-#M3FLAGS+= -DM3STATIC
-
-MAKE_ARGS+= PREFIX=${PREFIX} M3FLAGS="${M3FLAGS}"
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>