aboutsummaryrefslogtreecommitdiff
path: root/net/cvsupchk
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-12-13 23:15:53 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-12-13 23:15:53 +0000
commit9909c1df7d4df3dcd9cd2cb0d8973a827dd13b9e (patch)
treea859cab6e5b85d1fae408fe60f3e068166fb42a9 /net/cvsupchk
parent7f46736192dc45fc37e112f3ce98f1ee42053aae (diff)
Notes
Diffstat (limited to 'net/cvsupchk')
-rw-r--r--net/cvsupchk/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net/cvsupchk/Makefile b/net/cvsupchk/Makefile
index d985b7df9a7e..9b54afad684e 100644
--- a/net/cvsupchk/Makefile
+++ b/net/cvsupchk/Makefile
@@ -19,21 +19,20 @@ PORTDOCS= *
USE_PYTHON= yes
NO_BUILD= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-src!= ${MAKE} -C ${PORTSDIR}/net/cvsup-without-gui -V WRKSRC
+get_src= ${MAKE} -C ${PORTSDIR}/net/cvsup-without-gui -V WRKSRC
do-extract:
${MKDIR} ${WRKSRC}
- ${SED} 's:^#!/usr/local/bin/python:#!${PYTHON_CMD}:' <${src}/contrib/cvsupchk/cvsupchk >${WRKSRC}/cvsupchk
+ ${SED} 's:^#!/usr/local/bin/python:#!${PYTHON_CMD}:' <$$(${get_src})/contrib/cvsupchk/cvsupchk >${WRKSRC}/cvsupchk
do-install:
- ${MKDIR} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/cvsupchk ${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/cvsupchk ${STAGEDIR}${PREFIX}/bin/
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${src}/contrib/cvsupchk/README ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} $$(${get_src})/contrib/cvsupchk/README ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.post.mk>