aboutsummaryrefslogtreecommitdiff
path: root/net/cvsupchk
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-08 23:38:52 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-08 23:38:52 +0000
commit53bd74128e9d9259f7f97b9afc25d50faa2b097c (patch)
tree57f637f562dfed5598264b98a2fbea94732f7547 /net/cvsupchk
parentdb55cc2ce635d8abefff4702ab0a85f0a8f43469 (diff)
downloadports-53bd74128e9d9259f7f97b9afc25d50faa2b097c.tar.gz
ports-53bd74128e9d9259f7f97b9afc25d50faa2b097c.zip
Notes
Diffstat (limited to 'net/cvsupchk')
-rw-r--r--net/cvsupchk/Makefile6
-rw-r--r--net/cvsupchk/files/patch-spaces-in-filenames14
2 files changed, 18 insertions, 2 deletions
diff --git a/net/cvsupchk/Makefile b/net/cvsupchk/Makefile
index c9035870de13..43e9fa3c1a17 100644
--- a/net/cvsupchk/Makefile
+++ b/net/cvsupchk/Makefile
@@ -7,24 +7,26 @@
PORTNAME= cvsupchk
PORTVERSION= 19990209
+PORTREVISION= 1
CATEGORIES= net
DISTFILES=
MAINTAINER= matthias.andree@gmx.de
COMMENT= Check a CVSup directory hierarchy against the checkouts file
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/cvsup:extract
+EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/cvsup:extract
PLIST_FILES= bin/cvsupchk
PORTDOCS= *
USE_PYTHON= yes
+NO_BUILD= yes
.include <bsd.port.pre.mk>
src!= cd ${PORTSDIR}/net/cvsup && make -V WRKSRC
-do-build:
+do-extract:
${MKDIR} ${WRKSRC}
${SED} 's:^#!/usr/local/bin/python:#!${PYTHON_CMD}:' <${src}/contrib/cvsupchk/cvsupchk >${WRKSRC}/cvsupchk
diff --git a/net/cvsupchk/files/patch-spaces-in-filenames b/net/cvsupchk/files/patch-spaces-in-filenames
new file mode 100644
index 000000000000..3a09f90371f7
--- /dev/null
+++ b/net/cvsupchk/files/patch-spaces-in-filenames
@@ -0,0 +1,14 @@
+This patch by Rudolf Cejka aims to fix cvsupchk for names
+that contain spaces. -- Matthias Andree, 2006-11-07
+
+--- cvsupchk.orig Tue Oct 31 14:51:57 2006
++++ cvsupchk Tue Oct 31 14:57:47 2006
+@@ -396,6 +396,8 @@
+
+ c = string.split(l)
+
++ c[1] = string.replace(c[1], "\_", " ")
++
+ if c[0] not in [ 'C', 'c', 'D', 'F', 'U', 'V', 'v' ]:
+ diag_fatal('Unrecognized line: "%s"' % l[0:-1])
+