aboutsummaryrefslogtreecommitdiff
path: root/net/cyphesis
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-08 22:30:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-08 22:30:55 +0000
commit81100672d4de2795c4284cf568383d48955cbdcb (patch)
tree47e3d403298c2fd50b0ec056f62df5c31925decb /net/cyphesis
parent6d138c2d46f8ea88c939a76298099dbcf07491af (diff)
downloadports-81100672d4de2795c4284cf568383d48955cbdcb.tar.gz
ports-81100672d4de2795c4284cf568383d48955cbdcb.zip
Notes
Diffstat (limited to 'net/cyphesis')
-rw-r--r--net/cyphesis/Makefile7
-rw-r--r--net/cyphesis/files/patch-configure252
2 files changed, 258 insertions, 1 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index 09d685c49061..2ae3548721aa 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cyphesis
PORTVERSION= 0.5.20
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=worldforge
@@ -31,6 +32,8 @@ USE_LDCONFIG= yes
USE_PGSQL= yes
USE_PYTHON= yes
+CFLAGS+= -I${LOCALBASE}/include
+
MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
cyconvertrules.1 cydumprules.1 cyloadrules.1 cypasswd.1
@@ -39,10 +42,12 @@ MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' ${WRKSRC}/data/Makefile.in
- @${REINPLACE_CMD} -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g'
@${REINPLACE_CMD} -e 's|/bash|/sh|' ${WRKSRC}/scripts/extract_revision.sh
+ @${REINPLACE_CMD} -e '1s|python|${LOCALBASE}/bin/${PYTHON_VERSION}|' ${WRKSRC}/scripts/gen_buildid.py
post-install:
.if !defined(NOPORTDOCS)
diff --git a/net/cyphesis/files/patch-configure b/net/cyphesis/files/patch-configure
new file mode 100644
index 000000000000..70f39e726269
--- /dev/null
+++ b/net/cyphesis/files/patch-configure
@@ -0,0 +1,252 @@
+--- configure.orig 2009-05-31 11:22:02.000000000 +0200
++++ configure 2009-05-31 11:22:33.000000000 +0200
+@@ -4565,8 +4565,7 @@
+ fi
+
+
+-
+-python_prefix=/usr
++python_prefix=%%LOCALBASE%%
+
+ # Check whether --with-python was given.
+ if test "${with_python+set}" = set; then
+@@ -6196,6 +6195,153 @@
+
+
+
++
++if test "${ac_cv_header_python2_6_Python_h+set}" = set; then
++ { echo "$as_me:$LINENO: checking for python2.6/Python.h" >&5
++echo $ECHO_N "checking for python2.6/Python.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_python2_6_Python_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_header_python2_6_Python_h" >&5
++echo "${ECHO_T}$ac_cv_header_python2_6_Python_h" >&6; }
++else
++ # Is the header compilable?
++{ echo "$as_me:$LINENO: checking python2.6/Python.h usability" >&5
++echo $ECHO_N "checking python2.6/Python.h usability... $ECHO_C" >&6; }
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <python2.6/Python.h>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (ac_try="$ac_compile"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_compile") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } && {
++ test -z "$ac_cxx_werror_flag" ||
++ test ! -s conftest.err
++ } && test -s conftest.$ac_objext; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_compiler=no
++fi
++
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++{ echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6; }
++
++# Is the header present?
++{ echo "$as_me:$LINENO: checking python2.6/Python.h presence" >&5
++echo $ECHO_N "checking python2.6/Python.h presence... $ECHO_C" >&6; }
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <python2.6/Python.h>
++_ACEOF
++if { (ac_try="$ac_cpp conftest.$ac_ext"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null && {
++ test -z "$ac_cxx_preproc_warn_flag$ac_cxx_werror_flag" ||
++ test ! -s conftest.err
++ }; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++
++rm -f conftest.err conftest.$ac_ext
++{ echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6; }
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_cxx_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: python2.6/Python.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: python2.6/Python.h: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: python2.6/Python.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: python2.6/Python.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: python2.6/Python.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: python2.6/Python.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: python2.6/Python.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: python2.6/Python.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: python2.6/Python.h: in the future, the compiler will take precedence" >&2;}
++ ( cat <<\_ASBOX
++## --------------------------------------- ##
++## Report this to alriddoch@googlemail.com ##
++## --------------------------------------- ##
++_ASBOX
++ ) | sed "s/^/$as_me: WARNING: /" >&2
++ ;;
++esac
++{ echo "$as_me:$LINENO: checking for python2.6/Python.h" >&5
++echo $ECHO_N "checking for python2.6/Python.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_python2_6_Python_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_cv_header_python2_6_Python_h=$ac_header_preproc
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_header_python2_6_Python_h" >&5
++echo "${ECHO_T}$ac_cv_header_python2_6_Python_h" >&6; }
++
++fi
++if test $ac_cv_header_python2_6_Python_h = yes; then
++
++ python_include_path=-I${python_prefix}/include/python2.6
++ python_version=2.6
++
++else
++
++
++
++
++
++
++
++
++
++
+ if test "${ac_cv_header_python2_5_Python_h+set}" = set; then
+ { echo "$as_me:$LINENO: checking for python2.5/Python.h" >&5
+ echo $ECHO_N "checking for python2.5/Python.h... $ECHO_C" >&6; }
+@@ -6771,6 +6917,9 @@
+ fi
+
+
++fi
++
++
+
+ PYTHON_VERSION=${python_version}
+ PYTHON_INCLUDES=${python_include_path}
+@@ -7175,13 +7324,13 @@
+ if test x"$link_static" = "xfalse"; then
+
+ as_ac_Lib=`echo "ac_cv_lib_python${python_version}''_Py_Initialize" | $as_tr_sh`
+-{ echo "$as_me:$LINENO: checking for Py_Initialize in -lpython${python_version}" >&5
+-echo $ECHO_N "checking for Py_Initialize in -lpython${python_version}... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for Py_Initialize in -pthread -lpython${python_version}" >&5
++echo $ECHO_N "checking for Py_Initialize in -pthread -lpython${python_version}... $ECHO_C" >&6; }
+ if { as_var=$as_ac_Lib; eval "test \"\${$as_var+set}\" = set"; }; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpython${python_version} $LIBS"
++LIBS="-pthread -lpython${python_version} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -7239,19 +7388,19 @@
+ echo "${ECHO_T}$ac_res" >&6; }
+ if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+
+- python_libs="-lpython${python_version}"
++ python_libs="-pthread -lpython${python_version}"
+ PYTHON_UTIL_LIBS=
+
+ else
+
+ as_ac_Lib=`echo "ac_cv_lib_python${python_version}''_Py_Initialize" | $as_tr_sh`
+-{ echo "$as_me:$LINENO: checking for Py_Initialize in -lpython${python_version}" >&5
+-echo $ECHO_N "checking for Py_Initialize in -lpython${python_version}... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for Py_Initialize in -pthread -lpython${python_version}" >&5
++echo $ECHO_N "checking for Py_Initialize in -pthread -lpython${python_version}... $ECHO_C" >&6; }
+ if { as_var=$as_ac_Lib; eval "test \"\${$as_var+set}\" = set"; }; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpython${python_version} -L${python_lib_path} ${PYTHON_UTIL_LIBS} $LIBS"
++LIBS="-pthread -lpython${python_version} -L${python_lib_path} ${PYTHON_UTIL_LIBS} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -7309,7 +7458,7 @@
+ echo "${ECHO_T}$ac_res" >&6; }
+ if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+
+- python_libs="-L${python_lib_path} -lpython${python_version}"
++ python_libs="-L${python_lib_path} -pthread -lpython${python_version}"
+ PYTHON_LINKER_FLAGS="-export-dynamic"
+
+ else
+@@ -7329,13 +7478,13 @@
+ else
+
+ as_ac_Lib=`echo "ac_cv_lib_python${python_version}''_Py_Initialize" | $as_tr_sh`
+-{ echo "$as_me:$LINENO: checking for Py_Initialize in -lpython${python_version}" >&5
+-echo $ECHO_N "checking for Py_Initialize in -lpython${python_version}... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for Py_Initialize in -pthread -lpython${python_version}" >&5
++echo $ECHO_N "checking for Py_Initialize in -pthread -lpython${python_version}... $ECHO_C" >&6; }
+ if { as_var=$as_ac_Lib; eval "test \"\${$as_var+set}\" = set"; }; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpython${python_version} -L${python_lib_path} ${PYTHON_UTIL_LIBS} $LIBS"
++LIBS="-pthread -lpython${python_version} -L${python_lib_path} ${PYTHON_UTIL_LIBS} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -7393,7 +7542,7 @@
+ echo "${ECHO_T}$ac_res" >&6; }
+ if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+
+- python_libs="-L${python_lib_path} -lpython${python_version}"
++ python_libs="-L${python_lib_path} -pthread -lpython${python_version}"
+ PYTHON_LINKER_FLAGS="-export-dynamic"
+
+ else