aboutsummaryrefslogtreecommitdiff
path: root/net/cyphesis
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2014-06-15 14:08:52 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2014-06-15 14:08:52 +0000
commit8bf9130c1ea32e80b083c19eb0ca0b158ae4d2ea (patch)
treecdf2a62da6e022a058542959f901716daaf249a0 /net/cyphesis
parent6ddbb159115e49ab177b496d2653c9681ccaad14 (diff)
downloadports-8bf9130c1ea32e80b083c19eb0ca0b158ae4d2ea.tar.gz
ports-8bf9130c1ea32e80b083c19eb0ca0b158ae4d2ea.zip
Notes
Diffstat (limited to 'net/cyphesis')
-rw-r--r--net/cyphesis/Makefile6
-rw-r--r--net/cyphesis/files/patch-physics-BBox.cpp11
2 files changed, 15 insertions, 2 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index a7acd0f77457..db17fea4e64d 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -22,8 +22,6 @@ LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
CONFIGURE_ARGS= --with-python=${LOCALBASE}
-BROKEN= Does not compile with clang
-
GNU_CONFIGURE= yes
USE_BZIP2= yes
USES= gmake pathfix pkgconfig compiler:c++11-lib
@@ -40,6 +38,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+BROKEN= Does not compile with clang
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' \
diff --git a/net/cyphesis/files/patch-physics-BBox.cpp b/net/cyphesis/files/patch-physics-BBox.cpp
new file mode 100644
index 000000000000..d7bb311100dd
--- /dev/null
+++ b/net/cyphesis/files/patch-physics-BBox.cpp
@@ -0,0 +1,11 @@
+--- physics/BBox.cpp.orig 2014-06-15 17:53:14.000000000 +0200
++++ physics/BBox.cpp 2014-06-15 17:51:40.000000000 +0200
+@@ -19,7 +19,7 @@
+ #include "BBox.h"
+
+ #include "common/const.h"
+-
++#include <algorithm>
+ #include <wfmath/axisbox.h>
+ #include <wfmath/point.h>
+