aboutsummaryrefslogtreecommitdiff
path: root/net/cyphesis
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-09-12 18:43:17 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-09-12 18:43:17 +0000
commite8e4740965759b1e92344e22a2bab95535f8b7e8 (patch)
tree09bd20c83c19e6c5c4418b2c522bf73a8b64bb93 /net/cyphesis
parent8c386dbc3b096a076ab50ba66c48fd36b87989cb (diff)
downloadports-e8e4740965759b1e92344e22a2bab95535f8b7e8.tar.gz
ports-e8e4740965759b1e92344e22a2bab95535f8b7e8.zip
Notes
Diffstat (limited to 'net/cyphesis')
-rw-r--r--net/cyphesis/Makefile18
-rw-r--r--net/cyphesis/pkg-plist9
2 files changed, 15 insertions, 12 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index f4a8d4d1def5..8ba03e482a80 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cyphesis
PORTVERSION= 0.6.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
@@ -23,22 +23,18 @@ LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
CONFIGURE_ARGS= --with-python=${LOCALBASE}
GNU_CONFIGURE= yes
-USES= gmake pathfix pkgconfig compiler:c++11-lib tar:bzip2
+USES= gmake pathfix pkgconfig compiler:c++11-lib tar:bzip2 \
+ python:2 pgsql
USE_LDCONFIG= yes
-USE_PGSQL= yes
-USE_PYTHON= 2
CFLAGS+= -I${LOCALBASE}/include
-MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
- cyconvertrules.1 cydumprules.1 cyloadrules.1 cypasswd.1
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-BROKEN= Does not compile with clang
+BROKEN= Does not compile on FreeBSD 10+
.endif
post-patch:
@@ -60,7 +56,6 @@ post-patch:
${WRKSRC}/server/CommUnixListener.cpp
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}/conf
.for file in README COPYING AUTHORS THANKS NEWS ChangeLog TODO FIXME
@@ -69,6 +64,5 @@ post-install:
.for xmlfile in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
@${INSTALL_DATA} ${WRKSRC}/data/${xmlfile} ${STAGEDIR}${DOCSDIR}/conf
.endfor
-.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/cyphesis/pkg-plist b/net/cyphesis/pkg-plist
index 2160f2582bcb..e045f051564b 100644
--- a/net/cyphesis/pkg-plist
+++ b/net/cyphesis/pkg-plist
@@ -34,6 +34,15 @@ etc/cyphesis/minimal.d/basic.xml
etc/cyphesis/minimal.d/characters.xml
etc/cyphesis/minimal.d/environment.xml
etc/cyphesis/minimal.d/terrain.xml
+man/man/cyclient.1.gz
+man/man/cycmd.1.gz
+man/man/cyphesis.1.gz
+man/man/cyphesis-tools.1.gz
+man/man/cyaddrules.1.gz
+man/man/cyconvertrules.1.gz
+man/man/cydumprules.1.gz
+man/man/cyloadrules.1.gz
+man/man/cypasswd.1.gz
%%DATADIR%%/rulesets/basic/mind/Goal.py
%%DATADIR%%/rulesets/basic/mind/Knowledge.py
%%DATADIR%%/rulesets/basic/mind/Memory.py