aboutsummaryrefslogtreecommitdiff
path: root/net/dante
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-02-14 21:18:16 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-02-14 21:18:16 +0000
commit327b106b2e8740d2d3054262b16ceb94a362b62d (patch)
tree155812231bec0353202596131558bfb3908b3c55 /net/dante
parentbeec8de8c1f7f70c03e9bbef514911277c55b1dc (diff)
downloadports-327b106b2e8740d2d3054262b16ceb94a362b62d.tar.gz
ports-327b106b2e8740d2d3054262b16ceb94a362b62d.zip
Notes
Diffstat (limited to 'net/dante')
-rw-r--r--net/dante/Makefile5
-rw-r--r--net/dante/distinfo6
-rw-r--r--net/dante/files/sockd.sh15
-rw-r--r--net/dante/files/sockd.sh.in29
-rw-r--r--net/dante/pkg-plist3
5 files changed, 36 insertions, 22 deletions
diff --git a/net/dante/Makefile b/net/dante/Makefile
index 455ca31a0f18..cf66c0d9c586 100644
--- a/net/dante/Makefile
+++ b/net/dante/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dante
-PORTVERSION= 1.1.15
+PORTVERSION= 1.1.19
CATEGORIES= net security
MASTER_SITES= ftp://ftp.inet.no/pub/socks/ \
ftp://ftp.nuug.no/pub/anders/distfiles/ \
@@ -24,13 +24,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
INSTALLS_SHLIB= yes
+USE_RC_SUBR= sockd.sh
+
MAN5= sockd.conf.5 socks.conf.5
MAN8= sockd.8
post-install:
@${INSTALL_DATA} ${WRKSRC}/example/socks.conf ${PREFIX}/etc/socks.conf.example
@${INSTALL_DATA} ${WRKSRC}/example/sockd.conf ${PREFIX}/etc/sockd.conf.example
- @${INSTALL_SCRIPT} ${FILESDIR}/sockd.sh ${PREFIX}/etc/rc.d/sockd.sh-dist
.if !defined(NOPORTDOCS)
${INSTALL} -d -m 555 ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/README* ${DOCSDIR}
diff --git a/net/dante/distinfo b/net/dante/distinfo
index 8d3eef36b980..8a0db348ef99 100644
--- a/net/dante/distinfo
+++ b/net/dante/distinfo
@@ -1,3 +1,3 @@
-MD5 (dante-1.1.15.tar.gz) = c737faf4ba6282777070d8c0580c3832
-SHA256 (dante-1.1.15.tar.gz) = a2bc514933305e3a03558c8520e871dcaa9e031e241c7af9e2ef88346ea23d69
-SIZE (dante-1.1.15.tar.gz) = 839660
+MD5 (dante-1.1.19.tar.gz) = 58b56d1e964f3f0186f3eeed3d95d9a4
+SHA256 (dante-1.1.19.tar.gz) = b49f0936282a14c41a03cd70158d1a11e6af3564a18d4b3337f291fb6dae0936
+SIZE (dante-1.1.19.tar.gz) = 895713
diff --git a/net/dante/files/sockd.sh b/net/dante/files/sockd.sh
deleted file mode 100644
index 34653ae14bf7..000000000000
--- a/net/dante/files/sockd.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-start)
- [ -x /usr/local/sbin/sockd ] && /usr/local/sbin/sockd -D > /dev/null && echo -n ' sockd'
- ;;
-stop)
- [ -r /var/run/sockd.pid ] && kill `cat /var/run/sockd.pid` && echo -n ' sockd'
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/net/dante/files/sockd.sh.in b/net/dante/files/sockd.sh.in
new file mode 100644
index 000000000000..3ed415c9fdbc
--- /dev/null
+++ b/net/dante/files/sockd.sh.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: sockd
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable sockd:
+#
+#sockd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=sockd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/sockd
+pidfile=/var/run/sockd.pid
+required_files=%%PREFIX%%/etc/sockd.conf
+
+sockd_enable=${sockd_enable:-"NO"}
+sockd_flags=${sockd_flags:-"-D"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/dante/pkg-plist b/net/dante/pkg-plist
index 9eee0b6a8e07..056eeb98a195 100644
--- a/net/dante/pkg-plist
+++ b/net/dante/pkg-plist
@@ -1,7 +1,7 @@
+@unexec %D/etc/rc.d/sockd.sh forcestop 2>/dev/null || true
bin/socksify
etc/sockd.conf.example
etc/socks.conf.example
-etc/rc.d/sockd.sh-dist
include/socks.h
lib/libdsocks.so
lib/libdsocks.so.1
@@ -9,7 +9,6 @@ lib/libsocks.a
lib/libsocks.so
lib/libsocks.so.1
sbin/sockd
-%%PORTDOCS%%%%DOCSDIR%%/README.msproxy
%%PORTDOCS%%%%DOCSDIR%%/README.socksify
%%PORTDOCS%%%%DOCSDIR%%/README.survey
%%PORTDOCS%%%%DOCSDIR%%/README.usage