aboutsummaryrefslogtreecommitdiff
path: root/net/delegate/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>2000-02-22 07:55:45 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>2000-02-22 07:55:45 +0000
commit99e9a795f7a6dd9451dd7743c313fe75da45098b (patch)
tree82e4c0c86546d7a79e07d2986722b290f7f09820 /net/delegate/Makefile
parent1c6aef5ca8c6fc2f0a9027fff1fa13d99c80b9ae (diff)
downloadports-99e9a795f7a6dd9451dd7743c313fe75da45098b.tar.gz
ports-99e9a795f7a6dd9451dd7743c313fe75da45098b.zip
Notes
Diffstat (limited to 'net/delegate/Makefile')
-rw-r--r--net/delegate/Makefile37
1 files changed, 28 insertions, 9 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index fe6e74513897..ee996ccade54 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -1,25 +1,44 @@
# New ports collection makefile for: DeleGate
-# Version required: 5.9.12
+# Version required: 5.9.13
# Date created: 26 Jan 1997
# Whom: Masafumi NAKANE <max@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= delegate5.9.12
-PKGNAME= delegate-5.9.12
+DISTNAME= delegate5.9.13
+PKGNAME= delegate-5.9.13
CATEGORIES= net www japanese
MASTER_SITES= ftp://etlport.etl.go.jp/pub/DeleGate/
MAINTAINER= max@FreeBSD.org
-
-#FORBIDDEN= "Remote buffer overflow yielding setuid nobody shell"
-
+NO_PACKAGE= "Insecure program."
MAKE_ENV= PATH=$${PATH}:.
+IS_INTERACTIVE= YES
-.if defined(BATCH)
-pre-build:
- @${ECHO} "MANAGER=root@localhost" >> ${WRKSRC}/DELEGATE_CONF
+pre-fetch:
+.if !defined(FORCE_BUILD) || ${FORCE_BUILD}!="YES"
+ @${ECHO} "*********************************************************************"
+ @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO} "* This program has know security problems which may allow a remote *"
+ @${ECHO} "* attacker to take control of your machine. *"
+ @${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
+ @${ECHO} "* *"
+ @${ECHO} "* It is strongly recommended that you avoid using this program. *"
+ @${ECHO} "* *"
+ @${ECHO} "* If you would like to use this program despite the danger, run *"
+ @${ECHO} "* make with ``FORCE_BUILD=YES'' *"
+ @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO} "*********************************************************************"
+ @${FALSE}
+.else
+ @${ECHO} "*********************************************************************"
+ @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO} "* You have chosen to build an insecure program. *"
+ @${ECHO} "* This program has know security problems which may allow a remote *"
+ @${ECHO} "* attacker to take control of your machine. *"
+ @${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
+ @${ECHO} "*********************************************************************"
.endif
do-install: