aboutsummaryrefslogtreecommitdiff
path: root/net/delegate
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-04-15 11:35:31 +0000
committerClive Lin <clive@FreeBSD.org>2001-04-15 11:35:31 +0000
commitd8469c395237b6c96afdf5f050d0def2daa6f215 (patch)
tree29e197eeaf825e28f71c2c118e7b203c557170e1 /net/delegate
parent064d6c61a537bc4457f04211dee7bc6fd81f3a51 (diff)
downloadports-d8469c395237b6c96afdf5f050d0def2daa6f215.tar.gz
ports-d8469c395237b6c96afdf5f050d0def2daa6f215.zip
Notes
Diffstat (limited to 'net/delegate')
-rw-r--r--net/delegate/Makefile26
-rw-r--r--net/delegate/pkg-message20
2 files changed, 46 insertions, 0 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index b125a842bd9b..b383772df4f7 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -14,8 +14,33 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= max@FreeBSD.org
+NO_PACKAGE= "Insecure program."
IS_INTERACTIVE= YES
+pre-fetch:
+.if !defined(FORCE_BUILD) || ${FORCE_BUILD}!="YES"
+ @${ECHO} "*********************************************************************"
+ @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO} "* This program has know security problems which may allow a remote *"
+ @${ECHO} "* attacker to take control of your machine. *"
+ @${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
+ @${ECHO} "* *"
+ @${ECHO} "* It is strongly recommended that you avoid using this program. *"
+ @${ECHO} "* *"
+ @${ECHO} "* If you would like to use this program despite the danger, run *"
+ @${ECHO} "* make with ``FORCE_BUILD=YES'' *"
+ @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO} "*********************************************************************"
+ @${FALSE}
+.else
+ @${ECHO} "*********************************************************************"
+ @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
+ @${ECHO} "* You have chosen to build an insecure program. *"
+ @${ECHO} "* This program has know security problems which may allow a remote *"
+ @${ECHO} "* attacker to take control of your machine. *"
+ @${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
+ @${ECHO} "*********************************************************************"
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/delegated ${PREFIX}/sbin
@${MKDIR} ${PREFIX}/share/examples/delegate
@@ -26,5 +51,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/Manual.htm \
${PREFIX}/share/doc/delegate
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/delegate/pkg-message b/net/delegate/pkg-message
new file mode 100644
index 000000000000..5edcb5021a47
--- /dev/null
+++ b/net/delegate/pkg-message
@@ -0,0 +1,20 @@
+*********************************************************************
+* WARNING! WARNING! WARNING! WARNING! WARNING! *
+* You have installed an insecure program. *
+* This program has know security problems which may allow a remote *
+* attacker to take control of your machine. *
+* Use with great caution! *
+* See FreeBSD security advisory 00:04 for more information. *
+*********************************************************************
+
+----------------------------------------------------------------------
+Now, edit the sample script in /usr/local/share/examples/delegate directory
+and copy it into /usr/local/etc/rc.d.
+Especially, don't forget to specify correct value for the MANAGER.
+
+You can also run an interactive configuration session by executing
+delegated with no argument.
+
+Consult /usr/local/share/doc/delegate/Manual.htm for configuration
+information.
+----------------------------------------------------------------------