aboutsummaryrefslogtreecommitdiff
path: root/net/delegate
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-10-29 13:41:28 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-10-29 13:41:28 +0000
commitbaf2613128095213d89ff15bf7796c5270056e2c (patch)
treec968a6e18749bca45eb064ae26ff9f98716d4291 /net/delegate
parentb38d3b2bb88ffa1ad16814b0781d7153cc9b7448 (diff)
downloadports-baf2613128095213d89ff15bf7796c5270056e2c.tar.gz
ports-baf2613128095213d89ff15bf7796c5270056e2c.zip
Notes
Diffstat (limited to 'net/delegate')
-rw-r--r--net/delegate/Makefile5
-rw-r--r--net/delegate/distinfo2
-rw-r--r--net/delegate/files/delegated.sh5
-rw-r--r--net/delegate/files/patch-aj7
-rw-r--r--net/delegate/files/patch-ak7
5 files changed, 20 insertions, 6 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 3d6fd45d6f8f..ffa72803d769 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= delegate
-PORTVERSION= 6.1.16
+PORTVERSION= 6.1.19
CATEGORIES= net www japanese
-MASTER_SITES= ftp://etlport.etl.go.jp/pub/DeleGate/
+MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/ \
+ ftp://ftp.etl.go.jp/pub/DeleGate/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= max@FreeBSD.org
diff --git a/net/delegate/distinfo b/net/delegate/distinfo
index 550e3c9ac848..c1041df078af 100644
--- a/net/delegate/distinfo
+++ b/net/delegate/distinfo
@@ -1 +1 @@
-MD5 (delegate6.1.16.tar.gz) = 558db358eaae9f511396f0e81971addd
+MD5 (delegate6.1.19.tar.gz) = 3cfa4f8b801a669bb4d1588e9afd62a8
diff --git a/net/delegate/files/delegated.sh b/net/delegate/files/delegated.sh
index e8670c891c5e..805880396a17 100644
--- a/net/delegate/files/delegated.sh
+++ b/net/delegate/files/delegated.sh
@@ -3,12 +3,11 @@
umask 027
if [ -x /usr/local/sbin/delegated ]; then
echo -n ' delegated'
- /usr/local/sbin/delegated -P8080 \
- MANAGER=delegate-master@your.host.domain \
+ /usr/local/sbin/delegated -P8080 -Txt \
+ ADMIN=delegate-master@your.host.domain \
CHARCODE=JIS \
CACHEDIR=/var/spool/delegate/cache \
EXPIRE=7d \
RELIABLE=hostname \
> /dev/null 2>&1
-
fi
diff --git a/net/delegate/files/patch-aj b/net/delegate/files/patch-aj
new file mode 100644
index 000000000000..55cf79d58ecb
--- /dev/null
+++ b/net/delegate/files/patch-aj
@@ -0,0 +1,7 @@
+--- maker/__fork.c.orig Tue Jun 3 22:56:42 1997
++++ maker/__fork.c Sun Oct 29 22:32:55 2000
+@@ -1,3 +1,4 @@
++#include <sys/types.h>
+ #include <sys/wait.h>
+
+ INHERENT_fork(){ return 1; }
diff --git a/net/delegate/files/patch-ak b/net/delegate/files/patch-ak
new file mode 100644
index 000000000000..960895f0a73b
--- /dev/null
+++ b/net/delegate/files/patch-ak
@@ -0,0 +1,7 @@
+--- maker/spawnvp_.c.orig Thu Jun 19 02:40:16 1997
++++ maker/spawnvp_.c Sun Oct 29 22:32:55 2000
+@@ -1,3 +1,4 @@
++#include <sys/types.h>
+ #include <sys/wait.h>
+
+ INHERENT_spawn(){ return 0; }