aboutsummaryrefslogtreecommitdiff
path: root/net/dhcp6
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-09-02 21:02:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-09-02 21:02:10 +0000
commitff3c4f36c1df639a78a5faee8e0bedc817f52f7f (patch)
treeefe9795a0571433153a8c4f8ff3aa7ee3bfff187 /net/dhcp6
parentd010f9e7f206d6f9b05de5a177795a359beac656 (diff)
net/dhcp6: several fixes
- rcorder incorrect (Circular dependency on provision `DAEMON') - command_flags do not need to be referenced inside of the command_args - dhcp6s exits because of shutdown on non-connected UDP socket PR: 216673, 217452, 228994 Submitted by: tdb, Andrey Pevnev <apevnev@me.com>, leres, Dries Michiels <driesm.michiels@gmail.com> Approved by: hrs (maintainer timeout) Differential Revision: D16994
Notes
Notes: svn path=/head/; revision=478819
Diffstat (limited to 'net/dhcp6')
-rw-r--r--net/dhcp6/Makefile2
-rw-r--r--net/dhcp6/files/dhcp6c.in2
-rw-r--r--net/dhcp6/files/dhcp6s.in2
-rw-r--r--net/dhcp6/files/patch-dhcp6s.c11
4 files changed, 14 insertions, 3 deletions
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
index 5ab4596d3c0a..78db05cf75e4 100644
--- a/net/dhcp6/Makefile
+++ b/net/dhcp6/Makefile
@@ -4,7 +4,7 @@
PORTNAME= dhcp6
PORTVERSION= 20080615.2
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MAINTAINER= hrs@FreeBSD.org
diff --git a/net/dhcp6/files/dhcp6c.in b/net/dhcp6/files/dhcp6c.in
index 4cec6989d571..ec4bb64cd16e 100644
--- a/net/dhcp6/files/dhcp6c.in
+++ b/net/dhcp6/files/dhcp6c.in
@@ -42,7 +42,7 @@ load_rc_config $name
required_files="${dhcp6c_config}"
pidfile="${dhcp6c_pidfile}"
-command_args="-c ${dhcp6c_config} -p ${dhcp6c_pidfile} ${dhcp6c_flags} ${dhcp6c_interfaces}"
+command_args="-c ${dhcp6c_config} -p ${dhcp6c_pidfile} ${dhcp6c_interfaces}"
dhcp6c_precmd()
{
diff --git a/net/dhcp6/files/dhcp6s.in b/net/dhcp6/files/dhcp6s.in
index d9e1d6ff2a7a..66e7dd95e535 100644
--- a/net/dhcp6/files/dhcp6s.in
+++ b/net/dhcp6/files/dhcp6s.in
@@ -35,7 +35,7 @@ load_rc_config $name
: ${dhcp6s_config="%%PREFIX%%/etc/${name}.conf"}
required_files=${dhcp6s_config}
-command_args="-c ${dhcp6s_config} ${dhcp6s_flags} ${dhcp6s_interface}"
+command_args="-c ${dhcp6s_config} ${dhcp6s_interface}"
dhcp6s_precmd()
{
diff --git a/net/dhcp6/files/patch-dhcp6s.c b/net/dhcp6/files/patch-dhcp6s.c
new file mode 100644
index 000000000000..1eaa28049ecc
--- /dev/null
+++ b/net/dhcp6/files/patch-dhcp6s.c
@@ -0,0 +1,11 @@
+--- dhcp6s.c.orig 2018-09-02 19:43:29 UTC
++++ dhcp6s.c
+@@ -527,7 +527,7 @@ server6_init()
+ strerror(errno));
+ exit(1);
+ }
+-#if !defined(__linux__) && !defined(__sun__)
++#if !defined(__linux__) && !defined(__sun__) && !defined(__FreeBSD__)
+ /* make the socket write-only */
+ if (shutdown(outsock, 0)) {
+ d_printf(LOG_ERR, FNAME, "shutdown(outbound, 0): %s",