aboutsummaryrefslogtreecommitdiff
path: root/net/dhcpcd
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2007-12-31 17:23:26 +0000
committerLars Engels <lme@FreeBSD.org>2007-12-31 17:23:26 +0000
commitc7e6df59748cd15ebea3c4e83e7f3bcdda529879 (patch)
treec6cd802e0c182ac53499e6f01f936aa08476bc51 /net/dhcpcd
parent9d72d66aa63cb52bb7e2dc862e50a9e94a9c9bb9 (diff)
downloadports-c7e6df59748cd15ebea3c4e83e7f3bcdda529879.tar.gz
ports-c7e6df59748cd15ebea3c4e83e7f3bcdda529879.zip
Notes
Diffstat (limited to 'net/dhcpcd')
-rw-r--r--net/dhcpcd/Makefile24
-rw-r--r--net/dhcpcd/distinfo3
-rw-r--r--net/dhcpcd/files/dhcpcd.in36
-rw-r--r--net/dhcpcd/pkg-descr3
4 files changed, 66 insertions, 0 deletions
diff --git a/net/dhcpcd/Makefile b/net/dhcpcd/Makefile
new file mode 100644
index 000000000000..c7b4696a60ac
--- /dev/null
+++ b/net/dhcpcd/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: dhcpcd
+# Date created: 30 December 2007
+# Whom: Roy Marples <roy@marples.name>
+#
+# $FreeBSD$
+
+PORTNAME= dhcpcd
+PORTVERSION= 3.1.8
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= dhcpcd
+
+MAINTAINER= roy@marples.name
+COMMENT= DHCP client
+
+PLIST_FILES= sbin/dhcpcd
+MAN8= dhcpcd.8
+
+USE_BZIP2= yes
+USE_RC_SUBR= dhcpcd
+
+MAKE_ARGS= INFODIR=/var/db
+
+.include <bsd.port.mk>
diff --git a/net/dhcpcd/distinfo b/net/dhcpcd/distinfo
new file mode 100644
index 000000000000..392847f4f6c9
--- /dev/null
+++ b/net/dhcpcd/distinfo
@@ -0,0 +1,3 @@
+MD5 (dhcpcd-3.1.8.tar.bz2) = 6332c695e28100acbb84730e7ff7f6e9
+SHA256 (dhcpcd-3.1.8.tar.bz2) = c78eae99a63da25b9220995f62dbe735520e5044c199211c923503fd5981d2a1
+SIZE (dhcpcd-3.1.8.tar.bz2) = 45423
diff --git a/net/dhcpcd/files/dhcpcd.in b/net/dhcpcd/files/dhcpcd.in
new file mode 100644
index 000000000000..1dd02b1a0d01
--- /dev/null
+++ b/net/dhcpcd/files/dhcpcd.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+# PROVIDE: dhclient
+# KEYWORD: nojail nostart
+#
+
+. /etc/rc.subr
+. /etc/network.subr
+
+name="dhcpcd"
+ifn="$2"
+command="/usr/local/sbin/dhcpcd"
+command_args="$ifn"
+pidfile="/var/run/dhcpcd-$ifn.pid"
+start_precmd="dhcpcd_precmd"
+
+dhcpcd_precmd()
+{
+ # Override for $ifn specific flags (see rc.subr for $flags setting)
+ specific=`get_if_var $ifn dhcpcd_flags_IF`
+ if [ -z "$flags" -a -n "$specific" ]; then
+ rc_flags=$specific
+ fi
+
+ # dhcpcd may need local binaries
+ export PATH=${PATH}:/usr/local/sbin
+}
+
+load_rc_config $name
+load_rc_config network
+
+if ! dhcpif $ifn; then
+ return 1
+fi
+
+run_rc_command "$1"
diff --git a/net/dhcpcd/pkg-descr b/net/dhcpcd/pkg-descr
new file mode 100644
index 000000000000..2c158a15ad88
--- /dev/null
+++ b/net/dhcpcd/pkg-descr
@@ -0,0 +1,3 @@
+dhcpcd is an RFC2131 compliant DHCP client.
+
+WWW: http://dhcpcd.berlios.de