aboutsummaryrefslogtreecommitdiff
path: root/net/dhcpd-pools
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-19 11:44:12 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-19 11:44:12 +0000
commit676a207ea99b565eca08e81ff16f3bf80cbbe1ff (patch)
treef5a0ca7b45d7c23cf8a3329b636f65af8814e7d6 /net/dhcpd-pools
parentf8db12782ec5c3d56734d271ed32743699048590 (diff)
downloadports-676a207ea99b565eca08e81ff16f3bf80cbbe1ff.tar.gz
ports-676a207ea99b565eca08e81ff16f3bf80cbbe1ff.zip
Notes
Diffstat (limited to 'net/dhcpd-pools')
-rw-r--r--net/dhcpd-pools/Makefile6
-rw-r--r--net/dhcpd-pools/distinfo4
-rw-r--r--net/dhcpd-pools/files/patch-src__other.c31
3 files changed, 5 insertions, 36 deletions
diff --git a/net/dhcpd-pools/Makefile b/net/dhcpd-pools/Makefile
index a04f2e0468a2..3f155c217de7 100644
--- a/net/dhcpd-pools/Makefile
+++ b/net/dhcpd-pools/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dhcpd-pools
-PORTVERSION= 2.17
+PORTVERSION= 2.18
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}
@@ -20,8 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:${PORTSDIR}/devel/uthash
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-dhcpd-conf=${LOCALBASE}/etc/dhcpd.conf \
- --with-dhcpd-leases=/var/db/dhcpd/dhcpd.leases
-CFLAGS+= -I/usr/include -I${LOCALBASE}/include
+ --with-dhcpd-leases=/var/db/dhcpd/dhcpd.leases \
+ --with-uthash=${LOCALBASE}/include
PLIST_FILES= bin/dhcpd-pools
PORTDATA= dhcpd-pools.cgi snmptest.pl
diff --git a/net/dhcpd-pools/distinfo b/net/dhcpd-pools/distinfo
index 76cec43daf9d..b80e73a0100e 100644
--- a/net/dhcpd-pools/distinfo
+++ b/net/dhcpd-pools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dhcpd-pools-2.17.tar.gz) = 99f966dc9745f2061d9ca5039837b543876ea02113a920d330f0fbf31f3f495e
-SIZE (dhcpd-pools-2.17.tar.gz) = 366581
+SHA256 (dhcpd-pools-2.18.tar.gz) = 340ccb76232aaa5a77290c29f4af963e26c002a9d987146a0619e8ea7ba2b0b3
+SIZE (dhcpd-pools-2.18.tar.gz) = 367741
diff --git a/net/dhcpd-pools/files/patch-src__other.c b/net/dhcpd-pools/files/patch-src__other.c
deleted file mode 100644
index deb1b7078c7b..000000000000
--- a/net/dhcpd-pools/files/patch-src__other.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- ./src/other.c.orig 2012-05-02 13:52:56.000000000 -0400
-+++ ./src/other.c 2012-05-06 13:52:32.000000000 -0400
-@@ -53,13 +53,28 @@
-
- #include <err.h>
- #include <errno.h>
-+#ifndef __FreeBSD__
- #include <error.h>
-+#endif
- #include <stdbool.h>
- #include <stddef.h>
- #include <stdio.h>
-+#ifndef __FreeBSD__
- #include <stdio_ext.h>
-+#endif
- #include <unistd.h>
-
-+#ifdef __FreeBSD__
-+#define error errc
-+#endif
-+
-+#ifdef __FreeBSD__
-+static size_t __fpending (FILE *fp)
-+{
-+ return (fp->_p - fp->_bf._base);
-+}
-+#endif
-+
- /* Simple memory allocation wrapper */
- void *safe_malloc(const size_t size)
- {