aboutsummaryrefslogtreecommitdiff
path: root/net/dhcpd
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-12-06 09:50:48 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-12-06 09:50:48 +0000
commit27b9d817fcc53621db9fa83630f89b0865996028 (patch)
tree7dbe551fc48f0c87605ae60a711fa1e5a131a749 /net/dhcpd
parentd8c5357f438fc2265a439c0d79d714420731bedd (diff)
downloadports-27b9d817fcc53621db9fa83630f89b0865996028.tar.gz
ports-27b9d817fcc53621db9fa83630f89b0865996028.zip
Notes
Diffstat (limited to 'net/dhcpd')
-rw-r--r--net/dhcpd/Makefile35
-rw-r--r--net/dhcpd/distinfo2
-rw-r--r--net/dhcpd/files/dhcpd.in25
-rw-r--r--net/dhcpd/pkg-descr8
-rw-r--r--net/dhcpd/pkg-plist6
5 files changed, 76 insertions, 0 deletions
diff --git a/net/dhcpd/Makefile b/net/dhcpd/Makefile
new file mode 100644
index 000000000000..a090e6d4c404
--- /dev/null
+++ b/net/dhcpd/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= dhcpd
+PORTVERSION= 5.8.20151202
+CATEGORIES= net
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= OpenBSD dhcp daemon
+
+LICENSE= BSD3CLAUSE
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/usr.sbin/${PORTNAME}
+
+USE_GITHUB= yes
+GH_ACCOUNT= koue
+
+CONFLICTS= isc-dhcp4[1-3]-server*
+
+USE_OPENSSL= yes
+USE_RC_SUBR= dhcpd
+
+CFLAGS+= -Wall
+
+MAKE_ARGS+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
+
+USERS= dhcpd
+GROUPS= dhcpd
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/dhcpd.conf \
+ ${STAGEDIR}${PREFIX}/etc/dhcpd.conf.sample
+
+.include <bsd.port.post.mk>
diff --git a/net/dhcpd/distinfo b/net/dhcpd/distinfo
new file mode 100644
index 000000000000..2252656548c5
--- /dev/null
+++ b/net/dhcpd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (koue-dhcpd-5.8.20151202_GH0.tar.gz) = 662889ea3b4654b75ed298a32b9c7dd3e2bf5f82320b84397ed330c4c75d36bc
+SIZE (koue-dhcpd-5.8.20151202_GH0.tar.gz) = 105960
diff --git a/net/dhcpd/files/dhcpd.in b/net/dhcpd/files/dhcpd.in
new file mode 100644
index 000000000000..16ec59f87ba4
--- /dev/null
+++ b/net/dhcpd/files/dhcpd.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: dhcpd
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable dhcpd:
+# dhcpd_enable="YES"
+# dhcpd_flags="<set as needed>"
+
+. /etc/rc.subr
+
+name=dhcpd
+rcvar=dhcpd_enable
+
+command="%%PREFIX%%/sbin/dhcpd"
+
+dhcpd_enable=${dhcpd_enable:-"NO"}
+dhcpd_flags=${dhcpd_flags:-"-c %%PREFIX%%/etc/dhcpd.conf"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/dhcpd/pkg-descr b/net/dhcpd/pkg-descr
new file mode 100644
index 000000000000..b8597d7da48a
--- /dev/null
+++ b/net/dhcpd/pkg-descr
@@ -0,0 +1,8 @@
+This is the FreeBSD port of the OpenBSD dhcpd.
+
+The Dynamic Host Configuration Protocol (DHCP) is a standardized
+network protocol used on Internet Protocol (IP) networks for dynamically
+distributing network configuration parameters, such as IP addresses for
+interfaces and services.
+
+WWW: https://github.com/koue/dhcpd
diff --git a/net/dhcpd/pkg-plist b/net/dhcpd/pkg-plist
new file mode 100644
index 000000000000..39448d010fd6
--- /dev/null
+++ b/net/dhcpd/pkg-plist
@@ -0,0 +1,6 @@
+@sample etc/dhcpd.conf.sample
+man/man5/dhcp-options.5.gz
+man/man5/dhcpd.conf.5.gz
+man/man5/dhcpd.leases.5.gz
+man/man8/dhcpd.8.gz
+sbin/dhcpd