aboutsummaryrefslogtreecommitdiff
path: root/net/dhcprelay
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-08-16 20:28:32 +0000
committerRene Ladan <rene@FreeBSD.org>2018-08-16 20:28:32 +0000
commit048dda04006a021f030bf1f49deffff6bc18bd3e (patch)
tree5f56fa83cb52628df1cce7e88fa14a644324e550 /net/dhcprelay
parent3bfd2446823321c2d63349c4f3dd469d81f3bbdb (diff)
downloadports-048dda04006a021f030bf1f49deffff6bc18bd3e.tar.gz
ports-048dda04006a021f030bf1f49deffff6bc18bd3e.zip
Notes
Diffstat (limited to 'net/dhcprelay')
-rw-r--r--net/dhcprelay/Makefile27
-rw-r--r--net/dhcprelay/distinfo2
-rw-r--r--net/dhcprelay/files/dhcprelay.in29
-rw-r--r--net/dhcprelay/files/patch-Makefile15
-rw-r--r--net/dhcprelay/files/patch-dhcprelay.c11
-rw-r--r--net/dhcprelay/pkg-descr26
6 files changed, 0 insertions, 110 deletions
diff --git a/net/dhcprelay/Makefile b/net/dhcprelay/Makefile
deleted file mode 100644
index 6ca5238a631f..000000000000
--- a/net/dhcprelay/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# Created by: Edwin Groothuis (edwin@mavetju.org)
-# $FreeBSD$
-
-PORTNAME= dhcprelay
-PORTVERSION= 1.2
-PORTREVISION= 4
-CATEGORIES= net
-MASTER_SITES= http://www.mavetju.org/download/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Lightweight DHCP Relay Agent with GIF tunnel support
-
-LICENSE= NONE
-
-DEPRECATED= unknown license
-EXPIRATION_DATE= 2018-08-15
-
-LIB_DEPENDS= libdnet.so:net/libdnet
-
-USE_RC_SUBR= ${PORTNAME}
-
-PLIST_FILES= bin/dhcprelay
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dhcprelay ${STAGEDIR}${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/net/dhcprelay/distinfo b/net/dhcprelay/distinfo
deleted file mode 100644
index 5a0b72c06c77..000000000000
--- a/net/dhcprelay/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (dhcprelay-1.2.tar.gz) = 031485e4e426de163dd377ee65ca0665441a821b72a635f8a6a52bdb88886d24
-SIZE (dhcprelay-1.2.tar.gz) = 4476
diff --git a/net/dhcprelay/files/dhcprelay.in b/net/dhcprelay/files/dhcprelay.in
deleted file mode 100644
index 89fd3fd55659..000000000000
--- a/net/dhcprelay/files/dhcprelay.in
+++ /dev/null
@@ -1,29 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: dhcprelay
-# REQUIRE: DAEMON
-#
-# Add the following line to /etc/rc.conf to enable dhcrelay:
-#
-# dhcprelay_enable="YES"
-#
-# dhcprelay_server dhcprelay server(s)
-# dhcprelay_ifaces ethernet interface(s)
-
-. /etc/rc.subr
-
-name=dhcprelay
-rcvar=${name}_enable
-
-load_rc_config ${name}
-
-: ${dhcprelay_enable="NO"}
-: ${dhcprelay_ifaces=""}
-
-pidfile=/var/run/${name}.pid
-command=%%PREFIX%%/bin/${name}
-command_args="${dhcprelay_ifaces} ${dhcprelay_server}"
-
-run_rc_command "$1"
diff --git a/net/dhcprelay/files/patch-Makefile b/net/dhcprelay/files/patch-Makefile
deleted file mode 100644
index 624a4b2196e7..000000000000
--- a/net/dhcprelay/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig 2006-03-21 02:46:28 UTC
-+++ Makefile
-@@ -1,8 +1,10 @@
-+all: dhcprelay
-+
- dhcprelay: dhcprelay.o
-- gcc -g -o $@ -Wall -L/usr/local/lib -lpcap -ldnet $>
-+ ${CC} ${LDFLAGS} -o $@ -Wall -L${LOCALBASE}/lib -lpcap -ldnet $>
-
- dhcprelay.o: dhcprelay.c
-- gcc -g -c -o $@ -Wall -I/usr/local/include $<
-+ ${CC} ${CFLAGS} -c -o $@ -Wall -I${LOCALBASE}/include $<
-
- clean:
- rm -f dhcprelay.o dhcprelay dhcprelay.core
diff --git a/net/dhcprelay/files/patch-dhcprelay.c b/net/dhcprelay/files/patch-dhcprelay.c
deleted file mode 100644
index 73f7b6f5b479..000000000000
--- a/net/dhcprelay/files/patch-dhcprelay.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- dhcprelay.c.orig 2006-03-21 02:46:28 UTC
-+++ dhcprelay.c
-@@ -186,7 +186,7 @@ void pcap_callback(u_char *user, const s
- printf(" %d",eh->ether_type);
- }
- // check for IPv4 packets
-- if (eh->ether_type!=8) {
-+ if (eh->ether_type != htons(0x800)) {
- if (DEBUG>1) printf("\n");
- return;
- }
diff --git a/net/dhcprelay/pkg-descr b/net/dhcprelay/pkg-descr
deleted file mode 100644
index c931f568bdf7..000000000000
--- a/net/dhcprelay/pkg-descr
+++ /dev/null
@@ -1,26 +0,0 @@
-A light-weight DHCP Relay Agent.
-
-Why not the ISC DHCP Relay Agent?
-
-- If your RA has multiple interfaces, you get multiple requests for
- each request:
-
- DHCPREQUEST for 10.199.14.216 from 00:10:dc:d1:e6:39 (foo) via 10.199.14.1
- DHCPACK on 10.199.14.216 to 00:10:dc:d1:e6:39 (foo) via 10.199.14.1
- DHCPREQUEST for 10.199.14.216 from 00:10:dc:d1:e6:39 (foo) via 10.10.3.5: wrong network.
- DHCPNAK on 10.199.14.216 to 00:10:dc:d1:e6:39 via 10.10.3.5
-
- This RA sends only one request, coming with the IP address of the
- LAN the request came from.
-
-- If your RA has multiple interfaces, the outgoing interfaces to
- the WAN needs to be active in the DHCP relay otherwise answers
- are not picked up.
-
- This RA uses a unicast socket for returning answers.
-
-- If your RA has non-ethernet interfaces (GIF-tunnels for example,
- which VPN back to the central network), the answers are not picked
- up by the RA.
-
-WWW: http://www.mavetju.org/networking/